summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorWilliam Hubbs <williamh@gentoo.org>2020-10-11 11:47:06 -0500
committerWilliam Hubbs <williamh@gentoo.org>2020-10-11 12:48:49 -0500
commit7f3a710b40db211b931e3e130e137cf8cf63740b (patch)
tree715df2dd0ff819639c27f7b71a36172349dcf94a
parentdev-lang/execline: 2.6.1.1 bump (diff)
downloadgentoo-7f3a710b40db211b931e3e130e137cf8cf63740b.tar.gz
gentoo-7f3a710b40db211b931e3e130e137cf8cf63740b.tar.bz2
gentoo-7f3a710b40db211b931e3e130e137cf8cf63740b.zip
sys-apps/s6: 2.9.2.0 bump
Signed-off-by: William Hubbs <williamh@gentoo.org>
-rw-r--r--sys-apps/s6/Manifest1
-rw-r--r--sys-apps/s6/metadata.xml3
-rw-r--r--sys-apps/s6/s6-2.9.2.0.ebuild46
3 files changed, 50 insertions, 0 deletions
diff --git a/sys-apps/s6/Manifest b/sys-apps/s6/Manifest
index 0ccf5f1cc646..c183811299c1 100644
--- a/sys-apps/s6/Manifest
+++ b/sys-apps/s6/Manifest
@@ -5,3 +5,4 @@ DIST s6-2.7.1.1.tar.gz 204738 BLAKE2B 5a322fb992197b921f12fbf1e5bdec7cf1797a2bec
DIST s6-2.7.2.1.tar.gz 207088 BLAKE2B 233413e3cd400af291c20fc1b82e4a803be50eba9854fcbbe917715afe3a9c51467795f620a2596ab067dc7dbb4edcd09177c208bfcaaa7b3b0f392f49c49ff3 SHA512 dcf032b812ce955c2276af36aa93138debcfa9e429e79af7b8da4f1e98b21e7b658564024c713fef45ffee03704d78f7618ad4b890de0bd3defa51b4689d3790
DIST s6-2.8.0.1.tar.gz 208122 BLAKE2B f24981b1f29566ae23b8a41a20a119918798ba96fad7e4e62be7d03096dfcbc44de9ea6832c166f541aa8c36bca92819dbe2acd4c46e83866130817237056aa2 SHA512 03478aed129c1e50b34e0b75d7ff50bd84f62eadee862b6227c4313153d47776e7cbeae728d63209773b91931a2abc8372bb7db4953762807d0ed3d305efd23f
DIST s6-2.9.0.1.tar.gz 201404 BLAKE2B 206bef034446753b32b19eca96b1399209e0480b785f43bb8ccfb0eb9db5d1305155de74405d851cbaccbf5ef07ef1c4d2358e0e47f33928397201417b6f3b92 SHA512 5beb6170e4a457a0a307cbace67369cc35f6fd79d13ece2e82a3ebbdb4b032304eba8124be3e45b4db921863eaa02f51472c1365b0da000eef0868c11514dfff
+DIST s6-2.9.2.0.tar.gz 205009 BLAKE2B a3b3299d7d8695b4c3555a9603763e51c7c8d84d05ea229c787e46af8f5dca3efc09d16eb3380fbbd8e9ff1d300eddb5f632082ffa8dfbe08d45b5799f705131 SHA512 ef814c0426d00112c793d4f8bb99319cde8e4ab91c24e98401559bbd28eafdb11a66d446a31816a50f67d607ed1e8c55383362e9761abca21ca24b3598929eee
diff --git a/sys-apps/s6/metadata.xml b/sys-apps/s6/metadata.xml
index 1b7eef43c733..1718e243ff88 100644
--- a/sys-apps/s6/metadata.xml
+++ b/sys-apps/s6/metadata.xml
@@ -13,4 +13,7 @@
S6 is a small suite of programs for UNIX designed to allow
service supervision similar to daemontools or runit.
</longdescription>
+ <use>
+ <flag name="execline">enable support for <pkg>dev-lang/execline</pkg></flag>
+ </use>
</pkgmetadata>
diff --git a/sys-apps/s6/s6-2.9.2.0.ebuild b/sys-apps/s6/s6-2.9.2.0.ebuild
new file mode 100644
index 000000000000..258de953b55a
--- /dev/null
+++ b/sys-apps/s6/s6-2.9.2.0.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DESCRIPTION="skarnet.org's small and secure supervision software suite"
+HOMEPAGE="https://www.skarnet.org/software/s6/"
+SRC_URI="https://www.skarnet.org/software/${PN}/${P}.tar.gz"
+
+LICENSE="ISC"
+SLOT="0/$(ver_cut 1-2)"
+KEYWORDS="~amd64 ~arm ~x86"
+IUSE="+execline static static-libs"
+
+REQUIRED_USE="static? ( static-libs )"
+
+RDEPEND="execline? ( >=dev-lang/execline-2.6.0.1:=[static-libs?] )
+ >=dev-libs/skalibs-2.9.2.1:=[static-libs?]
+"
+DEPEND="${RDEPEND}"
+
+HTML_DOCS=( doc/. )
+
+src_prepare() {
+ default
+
+ # Avoid QA warning for LDFLAGS addition; avoid overriding -fstack-protector
+ sed -i -e 's/.*-Wl,--hash-style=both$/:/' -e '/-fno-stack-protector$/d' \
+ configure || die
+}
+
+src_configure() {
+ econf \
+ --bindir=/bin \
+ --dynlibdir=/usr/$(get_libdir) \
+ --libdir=/usr/$(get_libdir)/${PN} \
+ --with-dynlib=/usr/$(get_libdir) \
+ --with-lib=/usr/$(get_libdir)/execline \
+ --with-lib=/usr/$(get_libdir)/skalibs \
+ --with-sysdeps=/usr/$(get_libdir)/skalibs \
+ $(usex execline '' '--disable-execline' )
+ --enable-shared \
+ $(use_enable static allstatic) \
+ $(use_enable static static-libc) \
+ $(use_enable static-libs static)
+}