summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatt Turner <mattst88@gentoo.org>2021-03-01 19:00:52 -0500
committerMatt Turner <mattst88@gentoo.org>2021-03-01 19:12:15 -0500
commit7f3bc141b6d8d8ec2938d70f1eff7fd9958e42dc (patch)
treea962a9c49bc46a0f2d567224a9490540b69fe5e6
parentsci-geosciences/readosm: drop vestigal static-libs (diff)
downloadgentoo-7f3bc141.tar.gz
gentoo-7f3bc141.tar.bz2
gentoo-7f3bc141.zip
app-admin/pass: Port to EAPI=7
Mostly propagating changes from v1.7.3 to v9999, but also consolidate the logic between live and non-live versions. Signed-off-by: Matt Turner <mattst88@gentoo.org>
-rw-r--r--app-admin/pass/pass-9999.ebuild25
1 files changed, 17 insertions, 8 deletions
diff --git a/app-admin/pass/pass-9999.ebuild b/app-admin/pass/pass-9999.ebuild
index 9f6082612879..f22353197ff5 100644
--- a/app-admin/pass/pass-9999.ebuild
+++ b/app-admin/pass/pass-9999.ebuild
@@ -1,17 +1,24 @@
-# Copyright 1999-2019 Gentoo Authors
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=5
+EAPI=7
-inherit bash-completion-r1 git-r3 elisp-common
+inherit bash-completion-r1 elisp-common
+
+if [[ ${PV} = 9999* ]]; then
+ EGIT_REPO_URI="https://git.zx2c4.com/password-store"
+ inherit git-r3
+else
+ SRC_URI="https://git.zx2c4.com/password-store/snapshot/password-store-${PV}.tar.xz"
+ KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~x86"
+ S="${WORKDIR}/password-store-${PV}"
+fi
DESCRIPTION="Stores, retrieves, generates, and synchronizes passwords securely"
HOMEPAGE="https://www.passwordstore.org/"
-EGIT_REPO_URI="https://git.zx2c4.com/password-store"
SLOT="0"
LICENSE="GPL-2"
-KEYWORDS=""
IUSE="+git X zsh-completion fish-completion emacs dmenu importers elibc_Darwin"
RDEPEND="
@@ -24,10 +31,12 @@ RDEPEND="
zsh-completion? ( app-shells/gentoo-zsh-completions )
fish-completion? ( app-shells/fish )
dmenu? ( x11-misc/dmenu x11-misc/xdotool )
- emacs? ( >=app-editors/emacs-23.1:* )
+ emacs? ( >=app-editors/emacs-23.1:* >=app-emacs/f-0.11.0 >=app-emacs/s-1.9.0 >=app-emacs/with-editor-2.5.11 )
"
src_prepare() {
+ default
+
use elibc_Darwin || return
# use coreutils'
sed -i -e 's/openssl base64/base64/g' src/platform/darwin.sh || die
@@ -38,7 +47,7 @@ src_prepare() {
}
src_compile() {
- :;
+ use emacs && elisp-compile contrib/emacs/*.el
}
src_install() {
@@ -51,7 +60,7 @@ src_install() {
WITH_FISHCOMP=$(usex fish-completion)
use dmenu && dobin contrib/dmenu/passmenu
if use emacs; then
- elisp-install ${PN} contrib/emacs/*.el
+ elisp-install ${PN} contrib/emacs/*.{el,elc}
elisp-site-file-install "${FILESDIR}/50${PN}-gentoo.el"
fi
if use importers; then