summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorConrad Kostecki <conrad@kostecki.com>2019-09-20 09:30:34 +0200
committerJoonas Niilola <juippis@gentoo.org>2019-09-20 17:38:00 +0300
commit7f44e80622ecdde9ec3728e9701a071450cd68f6 (patch)
tree778c45f0c885f9ec6c3dac1f2f3bceb03b6a9cae
parentnet-wireless/unifi: bump to 5.11.47 (diff)
downloadgentoo-7f44e80622ecdde9ec3728e9701a071450cd68f6.tar.gz
gentoo-7f44e80622ecdde9ec3728e9701a071450cd68f6.tar.bz2
gentoo-7f44e80622ecdde9ec3728e9701a071450cd68f6.zip
sys-apps/cpuid: bump to version 20180519
Also bumped to EAPI=7 and corrected license. Closes: https://bugs.gentoo.org/645080 Package-Manager: Portage-2.3.76, Repoman-2.3.17 Signed-off-by: Conrad Kostecki <conrad@kostecki.com> Signed-off-by: Joonas Niilola <juippis@gentoo.org>
-rw-r--r--sys-apps/cpuid/Manifest1
-rw-r--r--sys-apps/cpuid/cpuid-20180519.ebuild36
-rw-r--r--sys-apps/cpuid/files/cpuid-20180519-add-spec-ctrl-output.patch10
-rw-r--r--sys-apps/cpuid/files/cpuid-20180519-makefile.patch46
-rw-r--r--sys-apps/cpuid/metadata.xml13
5 files changed, 106 insertions, 0 deletions
diff --git a/sys-apps/cpuid/Manifest b/sys-apps/cpuid/Manifest
index 07dfe7c7e94f..c6e29c18901a 100644
--- a/sys-apps/cpuid/Manifest
+++ b/sys-apps/cpuid/Manifest
@@ -1,2 +1,3 @@
DIST cpuid-20170122.src.tar.gz 80046 BLAKE2B 4c6c6719f57b446c92c5636a35aac883497d457719c67acb61db75ce99c46edee368d63e790b6b21ea334293aaed221374229e334cefcc65ea8b05c8ae40d172 SHA512 0e057980c71a0e078254e6b7535747bdf368278932c39943cf7dfafe08443af07297a2b41518499937a710fe6950ba89377cabaada5f6332932650d4d17c1430
DIST cpuid-20180419.src.tar.gz 82301 BLAKE2B 6905c0946fb9a930c67718067923c8c238031539c95704664160efde8563b0f56aadf3132abc9833310846802f97330edff833b47c006a4f46fec49358b56e31 SHA512 c8e30e45df7be5bdbff7e449b447b4542326a112f563c114c67cc80764070f3f3815ff4f80ceb57360828061bc9fd5f2f24f8e53ae4db47781f36db32141c951
+DIST cpuid-20180519.src.tar.gz 84784 BLAKE2B 87098145a378081d296f0473f9106e7c5b6654c2bd63d385dc27e293079adf3a527801fa644000ede53228e087e9e9afdf807a3c8d9cc8eb93826f01a5a89e9a SHA512 565738c41777669e750a2ef2e122ed0568de5ac8cc2584fa5047ba66d42eb5c3324b283bda25605e055d85402a4e2d109bc6d033ccd34243caab728465792669
diff --git a/sys-apps/cpuid/cpuid-20180519.ebuild b/sys-apps/cpuid/cpuid-20180519.ebuild
new file mode 100644
index 000000000000..045dbac2f81e
--- /dev/null
+++ b/sys-apps/cpuid/cpuid-20180519.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit toolchain-funcs
+
+DESCRIPTION="Linux tool to dump x86 CPUID information about the CPUs"
+HOMEPAGE="http://www.etallen.com/cpuid.html"
+SRC_URI="http://www.etallen.com/${PN}/${P}.src.tar.gz"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+BDEPEND="dev-lang/perl"
+DEPEND="app-arch/gzip"
+
+DOCS=( "ChangeLog" "FUTURE" )
+
+PATCHES=(
+ "${FILESDIR}/${P}-add-spec-ctrl-output.patch"
+ "${FILESDIR}/${P}-makefile.patch"
+)
+
+src_prepare() {
+ default
+
+ tc-export CC
+}
+
+src_install() {
+ emake BUILDROOT="${ED}" install
+
+ einstalldocs
+}
diff --git a/sys-apps/cpuid/files/cpuid-20180519-add-spec-ctrl-output.patch b/sys-apps/cpuid/files/cpuid-20180519-add-spec-ctrl-output.patch
new file mode 100644
index 000000000000..7cb078fe7eca
--- /dev/null
+++ b/sys-apps/cpuid/files/cpuid-20180519-add-spec-ctrl-output.patch
@@ -0,0 +1,10 @@
+--- a/cpuid.c 2018-05-19 14:09:29.000000000 +0200
++++ b/cpuid.c 2019-08-08 21:53:03.000000000 +0200
+@@ -4249,6 +4249,7 @@
+ { "fast short REP MOV" , 4, 4, bools },
+ { "PCONFIG" , 18, 18, bools },
+ { "CET_IBT: CET indirect branch tracking" , 20, 20, bools },
++ { "SPEC_CTRL: Speculation Control" , 26, 26, bools },
+ };
+ print_names(value, names, LENGTH(names, named_item),
+ /* max_len => */ 40);
diff --git a/sys-apps/cpuid/files/cpuid-20180519-makefile.patch b/sys-apps/cpuid/files/cpuid-20180519-makefile.patch
new file mode 100644
index 000000000000..e140c322fb19
--- /dev/null
+++ b/sys-apps/cpuid/files/cpuid-20180519-makefile.patch
@@ -0,0 +1,46 @@
+--- a/Makefile 2018-05-19 14:15:37.000000000 +0200
++++ b/Makefile 2019-08-08 21:43:09.000000000 +0200
+@@ -1,4 +1,4 @@
+-CFLAGS+=-g
++CFLAGS+=
+ CPPFLAGS?=
+ LDFLAGS?=
+ ifneq (,$(findstring arch=i386,$(CFLAGS)))
+@@ -36,7 +36,7 @@
+
+ BUILDROOT=
+
+-default: $(PROG) $(PROG).man.gz cpuinfo2cpuid cpuinfo2cpuid.man.gz
++default: $(PROG) cpuinfo2cpuid cpuinfo2cpuid.man
+
+ $(PROG): cpuid.c Makefile
+ $(CC) $(CFL) $(LDFLAGS) -o $@ cpuid.c
+@@ -50,11 +50,11 @@
+ cpuinfo2cpuid.man.gz: cpuinfo2cpuid.man
+ gzip < $< > $@
+
+-install: $(PROG) $(PROG).man.gz cpuinfo2cpuid cpuinfo2cpuid.man.gz
+- install -D -s -m 755 $(PROG) $(BUILDROOT)/usr/bin/$(PROG)
+- install -D -m 444 $(PROG).man.gz $(BUILDROOT)/usr/share/man/man1/$(PROG).1.gz
++install: $(PROG) cpuinfo2cpuid
++ install -D -m 755 $(PROG) $(BUILDROOT)/usr/bin/$(PROG)
++ install -D -m 444 $(PROG).man $(BUILDROOT)/usr/share/man/man1/$(PROG).1
+ install -D -m 755 cpuinfo2cpuid $(BUILDROOT)/usr/bin/cpuinfo2cpuid
+- install -D -m 444 cpuinfo2cpuid.man.gz $(BUILDROOT)/usr/share/man/man1/cpuinfo2cpuid.1.gz
++ install -D -m 444 cpuinfo2cpuid.man $(BUILDROOT)/usr/share/man/man1/cpuinfo2cpuid.1
+
+ clean:
+ rm -f $(PROG) $(PROG).i386 $(PROG).x86_64
+@@ -71,10 +71,10 @@
+ # Todd's Development rules
+
+ $(PROG).i386: cpuid.c Makefile
+- $(CC) -m32 -Wl,--hash-style=both $(CFL) $(LDFLAGS) -o $@ cpuid.c
++ $(CC) -m32 $(CFL) -o $@ cpuid.c
+
+ $(PROG).x86_64: cpuid.c Makefile
+- $(CC) -m64 $(CFL) $(LDFLAGS) -o $@ cpuid.c
++ $(CC) -m64 $(CFL) -o $@ cpuid.c
+
+ todd: $(PROG).i386 $(PROG).x86_64
+ rm -f ~/.bin/execs/i586/$(PROG)
diff --git a/sys-apps/cpuid/metadata.xml b/sys-apps/cpuid/metadata.xml
index 15fd2f3a22be..2cd77ae0f5fc 100644
--- a/sys-apps/cpuid/metadata.xml
+++ b/sys-apps/cpuid/metadata.xml
@@ -5,4 +5,17 @@
<email>johu@gentoo.org</email>
<name>Johannes Huber</name>
</maintainer>
+ <maintainer type="person">
+ <email>ck+gentoo@bl4ckb0x.de</email>
+ <name>Conrad Kostecki</name>
+ </maintainer>
+ <maintainer type="project">
+ <email>proxy-maint@gentoo.org</email>
+ <name>Proxy Maintainers</name>
+ </maintainer>
+ <longdescription>
+ CPUID dumps detailed information about the CPUs gathered from the CPUID instruction,
+ and also determines the exact model of CPUs. It supports Intel, AMD, and VIA CPUs,
+ as well as older Transmeta, Cyrix, UMC, NexGen, Rise, and SiS CPUs.
+ </longdescription>
</pkgmetadata>