summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-03-20 06:08:39 +0100
committerMichał Górny <mgorny@gentoo.org>2023-03-20 06:36:12 +0100
commit7f56346886d65f9bf61626438875f4096233e0b6 (patch)
tree556fb6de93bc1f003555ab57b08313cacb762b21
parentdev-python/moto: Bump to 4.1.5 (diff)
downloadgentoo-7f563468.tar.gz
gentoo-7f563468.tar.bz2
gentoo-7f563468.zip
dev-python/tzlocal: Bump to 4.3
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/tzlocal/Manifest1
-rw-r--r--dev-python/tzlocal/tzlocal-4.3.ebuild37
2 files changed, 38 insertions, 0 deletions
diff --git a/dev-python/tzlocal/Manifest b/dev-python/tzlocal/Manifest
index 92426930bfc5..1393e87eefec 100644
--- a/dev-python/tzlocal/Manifest
+++ b/dev-python/tzlocal/Manifest
@@ -1 +1,2 @@
DIST tzlocal-4.2.gh.tar.gz 23649 BLAKE2B 8b50f13854543a3ba5506bf7562ef0f3a7e7b5a20c7af037dd6eece0af16ead2b762b652b9bee0aaeede73178137293773e428a347e78ae7df999be609a34e3b SHA512 574c2f886fa6d1f2973e1ce817bd3347a77bd3beb0535bf5ba93e028e31388987f3f55369bd5a4a4a86c72af226256cdd7803f5bbe3ca6ce891b5adefdce776e
+DIST tzlocal-4.3.gh.tar.gz 24147 BLAKE2B 41ed6338b97f1f6c4a5cb64b82f6a93c4e68f275c2d593c774592998a7c63d1c8470fcd5babc13679092da4f92edeb798bfe80186628cb6c34b7fa595a21daf7 SHA512 b93541951c90ef59a0d9b224c75170a0857723ee0f50782980a78a003b1040b7ceef3bbadd2cabde2a8599cecdd7644ccd1431eb8e4d33cd9e4e9d980c048736
diff --git a/dev-python/tzlocal/tzlocal-4.3.ebuild b/dev-python/tzlocal/tzlocal-4.3.ebuild
new file mode 100644
index 000000000000..710a1143a1b7
--- /dev/null
+++ b/dev-python/tzlocal/tzlocal-4.3.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{9..11} pypy3 )
+
+inherit distutils-r1
+
+DESCRIPTION="tzinfo object for the local timezone"
+HOMEPAGE="
+ https://github.com/regebro/tzlocal/
+ https://pypi.org/project/tzlocal/
+"
+SRC_URI="
+ https://github.com/regebro/tzlocal/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+
+RDEPEND="
+ dev-python/pytz_deprecation_shim[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep '
+ dev-python/backports-zoneinfo[${PYTHON_USEDEP}]
+ ' 3.8)
+"
+BDEPEND="
+ test? (
+ dev-python/pytest-mock[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest