summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorConrad Kostecki <conikost@gentoo.org>2022-09-14 23:51:18 +0200
committerConrad Kostecki <conikost@gentoo.org>2022-09-14 23:51:18 +0200
commit7f5dd14d315e8fef5f430baa336aeb7c17c66532 (patch)
treee7b3b8cf76c57fbbe395a9e2336da4cb3115baa5
parentapp-benchmarks/stress-ng: drop 0.14.03 (diff)
downloadgentoo-7f5dd14d315e8fef5f430baa336aeb7c17c66532.tar.gz
gentoo-7f5dd14d315e8fef5f430baa336aeb7c17c66532.tar.bz2
gentoo-7f5dd14d315e8fef5f430baa336aeb7c17c66532.zip
www-apps/phpsysinfo: add 3.4.2
Signed-off-by: Conrad Kostecki <conikost@gentoo.org>
-rw-r--r--www-apps/phpsysinfo/Manifest1
-rw-r--r--www-apps/phpsysinfo/phpsysinfo-3.4.2.ebuild52
2 files changed, 53 insertions, 0 deletions
diff --git a/www-apps/phpsysinfo/Manifest b/www-apps/phpsysinfo/Manifest
index 179c0c25856c..5ffc194c31df 100644
--- a/www-apps/phpsysinfo/Manifest
+++ b/www-apps/phpsysinfo/Manifest
@@ -1 +1,2 @@
DIST phpsysinfo-3.4.1.tar.gz 980537 BLAKE2B f0924e2855bb682cc6a5be62d35e1a04463e3fdbad75e8f7ee43d0f9cf4ede53091d7495d68a10a3521f6eb3b8460d3458443b840aeee705d5a74fa87b3addf3 SHA512 5e8c82ba95c9f6b4d8dddfdaabbfb676a0c63913a6cd65d6b74ffbe6369830d98cc67c8192cf06c6eaefc8689d1c40b4e1917ea21a1ecd8df7977847e3ede24c
+DIST phpsysinfo-3.4.2.tar.gz 1018093 BLAKE2B 148111015d2ba0751f4001d8b00ac30ca0c82eb21d6f44eb42b309a50d343d2aa765da032ecd2e018ecf420dfb32fbe78b0a4a06fd248a86c388a9dcf0c60014 SHA512 b375319cc54e7291089db8f938fae92a9245bc95318116159d34fcfa33464063eaf5b911a928c3d48adbfcb98d9b4431e85052b76c4f3a03a0ddc7f14557db39
diff --git a/www-apps/phpsysinfo/phpsysinfo-3.4.2.ebuild b/www-apps/phpsysinfo/phpsysinfo-3.4.2.ebuild
new file mode 100644
index 000000000000..1e77cfc58a5e
--- /dev/null
+++ b/www-apps/phpsysinfo/phpsysinfo-3.4.2.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit optfeature webapp
+
+DESCRIPTION="A customizable PHP script that displays information about your system nicely"
+HOMEPAGE="https://phpsysinfo.github.io/phpsysinfo/"
+SRC_URI="https://github.com/rk4an/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2+"
+KEYWORDS="~amd64 ~hppa ~ppc ~ppc64 ~x86"
+RDEPEND="
+ dev-lang/php[simplexml,xml,xsl(+),xslt(+),unicode]
+ virtual/httpd-php
+"
+
+need_httpd_cgi
+
+src_install() {
+ webapp_src_preinst
+
+ dodoc CHANGELOG.md README*
+ rm CHANGELOG.md COPYING README* .gitignore || die
+
+ mv phpsysinfo.ini{.new,} || die
+ insinto "${MY_HTDOCSDIR}"
+ doins -r .
+
+ webapp_configfile "${MY_HTDOCSDIR}"/phpsysinfo.ini
+
+ webapp_src_install
+}
+
+pkg_postinst() {
+ optfeature "showing disk temperatures." app-admin/hddtemp
+ optfeature "showing system uptime." app-misc/uptimed
+ optfeature "showing snmp statistics." net-analyzer/net-snmp
+ optfeature "showing iptables rules." net-firewall/iptables
+ optfeature "showing ipmi sensors." sys-apps/ipmitool
+ optfeature "showing ipmi sensors." sys-apps/ipmiutil
+ optfeature "showing system sensors." sys-apps/lm-sensors
+ optfeature "showing s.m.a.r.t. health." sys-apps/smartmontools
+ optfeature "showing lsi raid controller health." sys-block/megactl
+ optfeature "showing fake raid statistics." sys-fs/dmraid
+ optfeature "showing software raid statistics." sys-fs/mdadm
+ optfeature "showing quota information." sys-fs/quota
+ optfeature "showing ipmi sensors." sys-libs/freeipmi
+ optfeature "showing apc ups statistics." sys-power/apcupsd
+ optfeature "showing ups statistics." sys-power/nut
+}