summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-01-28 11:10:14 +0100
committerMichał Górny <mgorny@gentoo.org>2021-01-28 11:58:02 +0100
commit7f6a775d281e36b474dcf988b6d1e95050cdba6f (patch)
treeb8c0734f5fecbf76aaa864477d54e47b4b997bec
parentdev-python/snakeoil: Modernize (diff)
downloadgentoo-7f6a775d.tar.gz
gentoo-7f6a775d.tar.bz2
gentoo-7f6a775d.zip
sys-apps/pkgcore: Modernize
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--sys-apps/pkgcore/pkgcore-0.11.0.ebuild11
-rw-r--r--sys-apps/pkgcore/pkgcore-9999.ebuild13
2 files changed, 7 insertions, 17 deletions
diff --git a/sys-apps/pkgcore/pkgcore-0.11.0.ebuild b/sys-apps/pkgcore/pkgcore-0.11.0.ebuild
index 783660fe4b78..2998f6377a3f 100644
--- a/sys-apps/pkgcore/pkgcore-0.11.0.ebuild
+++ b/sys-apps/pkgcore/pkgcore-0.11.0.ebuild
@@ -1,7 +1,7 @@
# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
+EAPI=7
PYTHON_COMPAT=( python3_{8..9} )
DISTUTILS_IN_SOURCE_BUILD=1
inherit distutils-r1
@@ -19,8 +19,6 @@ HOMEPAGE="https://github.com/pkgcore/pkgcore"
LICENSE="BSD MIT"
SLOT="0"
-IUSE="test"
-RESTRICT="!test? ( test )"
RDEPEND="dev-python/lxml[${PYTHON_USEDEP}]"
if [[ ${PV} == *9999 ]]; then
@@ -28,17 +26,14 @@ if [[ ${PV} == *9999 ]]; then
else
RDEPEND+=" >=dev-python/snakeoil-0.9.0[${PYTHON_USEDEP}]"
fi
-DEPEND="${RDEPEND}
- dev-python/setuptools[${PYTHON_USEDEP}]
+BDEPEND="
test? (
dev-python/pytest[${PYTHON_USEDEP}]
dev-vcs/git
)
"
-python_test() {
- esetup.py test
-}
+distutils_enable_tests setup.py
python_install_all() {
local DOCS=( NEWS.rst )
diff --git a/sys-apps/pkgcore/pkgcore-9999.ebuild b/sys-apps/pkgcore/pkgcore-9999.ebuild
index 5a984c9250dd..2998f6377a3f 100644
--- a/sys-apps/pkgcore/pkgcore-9999.ebuild
+++ b/sys-apps/pkgcore/pkgcore-9999.ebuild
@@ -1,7 +1,7 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
+EAPI=7
PYTHON_COMPAT=( python3_{8..9} )
DISTUTILS_IN_SOURCE_BUILD=1
inherit distutils-r1
@@ -19,8 +19,6 @@ HOMEPAGE="https://github.com/pkgcore/pkgcore"
LICENSE="BSD MIT"
SLOT="0"
-IUSE="test"
-RESTRICT="!test? ( test )"
RDEPEND="dev-python/lxml[${PYTHON_USEDEP}]"
if [[ ${PV} == *9999 ]]; then
@@ -28,17 +26,14 @@ if [[ ${PV} == *9999 ]]; then
else
RDEPEND+=" >=dev-python/snakeoil-0.9.0[${PYTHON_USEDEP}]"
fi
-DEPEND="${RDEPEND}
- dev-python/setuptools[${PYTHON_USEDEP}]
+BDEPEND="
test? (
dev-python/pytest[${PYTHON_USEDEP}]
dev-vcs/git
)
"
-python_test() {
- esetup.py test
-}
+distutils_enable_tests setup.py
python_install_all() {
local DOCS=( NEWS.rst )