summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarco Genasci <fedeliallalinea@gmail.com>2022-01-20 07:42:16 +0100
committerSam James <sam@gentoo.org>2022-01-20 12:31:13 +0000
commit7f7653c57cf5f7d60c9d5c97c7d36887e3600f25 (patch)
tree7bc81ecf5cdfee308882fc0eb721e0ce63047dda
parentdev-cpp/tbb: fix undefined __TBB_machine_fetchadd4 (diff)
downloadgentoo-7f7653c57cf5f7d60c9d5c97c7d36887e3600f25.tar.gz
gentoo-7f7653c57cf5f7d60c9d5c97c7d36887e3600f25.tar.bz2
gentoo-7f7653c57cf5f7d60c9d5c97c7d36887e3600f25.zip
dev-db/ocp: fix AR direct call
Closes: https://bugs.gentoo.org/831291 Package-Manager: Portage-3.0.28, Repoman-3.0.3 Signed-off-by: Marco Genasci <fedeliallalinea@gmail.com> Closes: https://github.com/gentoo/gentoo/pull/23879 Signed-off-by: Sam James <sam@gentoo.org>
-rw-r--r--dev-db/ocp/ocp-0.3.ebuild11
-rw-r--r--dev-db/ocp/ocp-9999.ebuild11
2 files changed, 16 insertions, 6 deletions
diff --git a/dev-db/ocp/ocp-0.3.ebuild b/dev-db/ocp/ocp-0.3.ebuild
index 5c6591bf5df3..47e7110d55b1 100644
--- a/dev-db/ocp/ocp-0.3.ebuild
+++ b/dev-db/ocp/ocp-0.3.ebuild
@@ -1,7 +1,7 @@
-# Copyright 1999-2017 Gentoo Foundation
+# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=7
+EAPI=8
DESCRIPTION="Oracle copy tool"
HOMEPAGE="https://github.com/maxsatula/ocp"
@@ -9,10 +9,11 @@ HOMEPAGE="https://github.com/maxsatula/ocp"
if [[ ${PV} == *9999 ]]; then
EGIT_REPO_URI="https://github.com/maxsatula/ocp.git"
EGIT_BRANCH="develop"
- inherit git-r3 autotools
+ inherit git-r3 autotools toolchain-funcs
else
SRC_URI="https://github.com/maxsatula/ocp/releases/download/v${PV}/${P}.tar.gz"
KEYWORDS="~amd64 ~x86"
+ inherit toolchain-funcs
fi
LICENSE="GPL-2"
@@ -27,6 +28,10 @@ DEPEND="
dev-db/oracle-instantclient[sdk]
${RDEPEND}"
+src_compile() {
+ emake AR="$(tc-getAR)"
+}
+
src_prepare() {
default
diff --git a/dev-db/ocp/ocp-9999.ebuild b/dev-db/ocp/ocp-9999.ebuild
index 5c6591bf5df3..47e7110d55b1 100644
--- a/dev-db/ocp/ocp-9999.ebuild
+++ b/dev-db/ocp/ocp-9999.ebuild
@@ -1,7 +1,7 @@
-# Copyright 1999-2017 Gentoo Foundation
+# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=7
+EAPI=8
DESCRIPTION="Oracle copy tool"
HOMEPAGE="https://github.com/maxsatula/ocp"
@@ -9,10 +9,11 @@ HOMEPAGE="https://github.com/maxsatula/ocp"
if [[ ${PV} == *9999 ]]; then
EGIT_REPO_URI="https://github.com/maxsatula/ocp.git"
EGIT_BRANCH="develop"
- inherit git-r3 autotools
+ inherit git-r3 autotools toolchain-funcs
else
SRC_URI="https://github.com/maxsatula/ocp/releases/download/v${PV}/${P}.tar.gz"
KEYWORDS="~amd64 ~x86"
+ inherit toolchain-funcs
fi
LICENSE="GPL-2"
@@ -27,6 +28,10 @@ DEPEND="
dev-db/oracle-instantclient[sdk]
${RDEPEND}"
+src_compile() {
+ emake AR="$(tc-getAR)"
+}
+
src_prepare() {
default