summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2023-12-08 07:42:58 +0000
committerSam James <sam@gentoo.org>2023-12-08 07:43:25 +0000
commit7f8ab7568599ba4335a09e3167be8d676911ffe0 (patch)
tree96b35c700df267608dc30d8ff1bd79052ce9986a
parentdev-ruby/redcloth: drop 4.3.2-r4 (diff)
downloadgentoo-7f8ab7568599ba4335a09e3167be8d676911ffe0.tar.gz
gentoo-7f8ab7568599ba4335a09e3167be8d676911ffe0.tar.bz2
gentoo-7f8ab7568599ba4335a09e3167be8d676911ffe0.zip
dev-python/pypy3_10-exe: workaround C warnings for now
Upstream are working on it and nearly have it fixed, but the patches are large and not worth backporting until it's completely fixed at least. Add a workaround for now :( Bug: https://foss.heptapod.net/pypy/pypy/-/issues/4042 Bug: https://bugs.gentoo.org/918971 Signed-off-by: Sam James <sam@gentoo.org>
-rw-r--r--dev-python/pypy3_10-exe/pypy3_10-exe-7.3.13_p3.ebuild6
1 files changed, 5 insertions, 1 deletions
diff --git a/dev-python/pypy3_10-exe/pypy3_10-exe-7.3.13_p3.ebuild b/dev-python/pypy3_10-exe/pypy3_10-exe-7.3.13_p3.ebuild
index faf6b8a1e385..9eec2da0971d 100644
--- a/dev-python/pypy3_10-exe/pypy3_10-exe-7.3.13_p3.ebuild
+++ b/dev-python/pypy3_10-exe/pypy3_10-exe-7.3.13_p3.ebuild
@@ -3,7 +3,7 @@
EAPI=8
-inherit check-reqs pax-utils toolchain-funcs
+inherit check-reqs flag-o-matic pax-utils toolchain-funcs
PYPY_PV=${PV%_p*}
PYVER=3.10
@@ -70,6 +70,10 @@ src_prepare() {
src_configure() {
tc-export CC
+ # Yes, yuck, but it's being worked on upstream (bug #918971).
+ # https://foss.heptapod.net/pypy/pypy/-/issues/4042
+ append-flags $(test-flags-CC -Wno-error=incompatible-pointer-types)
+
local jit_backend
if use jit; then
jit_backend='--jit-backend='