summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-10-19 07:57:03 +0200
committerMichał Górny <mgorny@gentoo.org>2021-10-19 09:22:17 +0200
commit7f8f684dac8ab48f7978c8f3386ed8e7cd36e11e (patch)
treeaa8aa0b2ec9a53e37d4c2b0a8182cb0f0bb7af42
parentdev-python/indexed_gzip: Bump to 1.6.4 (diff)
downloadgentoo-7f8f684dac8ab48f7978c8f3386ed8e7cd36e11e.tar.gz
gentoo-7f8f684dac8ab48f7978c8f3386ed8e7cd36e11e.tar.bz2
gentoo-7f8f684dac8ab48f7978c8f3386ed8e7cd36e11e.zip
dev-python/authheaders: Bump to 0.14.1
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/authheaders/Manifest1
-rw-r--r--dev-python/authheaders/authheaders-0.14.1.ebuild24
2 files changed, 25 insertions, 0 deletions
diff --git a/dev-python/authheaders/Manifest b/dev-python/authheaders/Manifest
index b9469cb65f50..261e073795c5 100644
--- a/dev-python/authheaders/Manifest
+++ b/dev-python/authheaders/Manifest
@@ -1 +1,2 @@
DIST authheaders-0.13.0.tar.gz 93319 BLAKE2B b4370a9cf3d6a5e9772be97d07ac24d1d4a97e24df07d65f74b22bbe4c85c8cc8d4a0e933b2c84b4b159aa7bd7572530e3784118e17f3b5caf8a4365e2bbdbaa SHA512 dfaccd9dedea8bebc22b831c481c733590e11a3483e42b45f0b6329bdaa98eec0644faf8da8b92c56c2d48a43eec9c52f8ea9a3c67ae841c46a7085cf0572177
+DIST authheaders-0.14.1.tar.gz 101412 BLAKE2B 5ab6ff508123ae6f58eb4297dcd04fe3518244c0f423ecbc292948c437eac4d7ade7eceeaf4f4165625904489d494331d37c18b9dd4052a01e22c799df6c47fe SHA512 842881a6d2c3d192664960a9d1954f6e2c267cc6b07d7567f019869d07c1e40fc12275c381e90ea94559bd43a9d2e183d35e80d0ee9a861e80519a98daf2a699
diff --git a/dev-python/authheaders/authheaders-0.14.1.ebuild b/dev-python/authheaders/authheaders-0.14.1.ebuild
new file mode 100644
index 000000000000..f5022f6b4a2a
--- /dev/null
+++ b/dev-python/authheaders/authheaders-0.14.1.ebuild
@@ -0,0 +1,24 @@
+# Copyright 2019-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..10} )
+inherit distutils-r1
+
+DESCRIPTION="A library wrapping email authentication header verification and generation."
+HOMEPAGE="https://github.com/ValiMail/authentication-headers"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86"
+
+RDEPEND="
+ >=dev-python/authres-1.0.1[${PYTHON_USEDEP}]
+ dev-python/dkimpy[${PYTHON_USEDEP}]
+ dev-python/dnspython[${PYTHON_USEDEP}]
+ >=dev-python/publicsuffix-2.20190205[${PYTHON_USEDEP}]
+"
+
+distutils_enable_tests pytest