summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarek Szuba <marecki@gentoo.org>2022-01-03 17:37:17 +0000
committerMarek Szuba <marecki@gentoo.org>2022-01-03 17:48:13 +0000
commit7f94d7c9bc4621fef179bff47ce602b959cc1263 (patch)
tree4cc81eb8f496d134c523b023c9c9fb1b9cb2277e
parentdev-lang/gnat-gpl: try for another cet fix (diff)
downloadgentoo-7f94d7c9.tar.gz
gentoo-7f94d7c9.tar.bz2
gentoo-7f94d7c9.zip
net-misc/youtube-dl: add 2021.12.17
Signed-off-by: Marek Szuba <marecki@gentoo.org>
-rw-r--r--net-misc/youtube-dl/Manifest1
-rw-r--r--net-misc/youtube-dl/youtube-dl-2021.12.17.ebuild74
2 files changed, 75 insertions, 0 deletions
diff --git a/net-misc/youtube-dl/Manifest b/net-misc/youtube-dl/Manifest
index dcf1041ec7b5..86bc013deba6 100644
--- a/net-misc/youtube-dl/Manifest
+++ b/net-misc/youtube-dl/Manifest
@@ -1 +1,2 @@
DIST youtube-dl-2021.06.06.tar.gz 3336227 BLAKE2B f30252927ddd79062995ec78d45854e1723fe561ca34777fb0a337750bf09c76da8c205af63869c68c6bc09bfe8f6de1d3f5ee240914ae871bb7920076d8d16c SHA512 7b4d453723d03c3fde46451277d5c44be01469ed1b414ce94e782d6228c132c982835805207222862d0d7b8ba162157196f976400fd15cea7ea513e3595aeea3
+DIST youtube-dl-2021.12.17.tar.gz 3332299 BLAKE2B 5c798ad1f54f06cc42fd9a538536310e1084a02ec96969ff8e85ef0c6487ef54f34d58858512ade8b279929d8ebb9dda48175302fa23af9833c2301daa1d49c2 SHA512 bfc8280703b08f66e1108e9ebd9ab4689f064ac7cef03bd3d1fd2bc64928570e4376e389c9bc188eafdbcd74444cfc8aeccc83ee362ad4f478910efef3573ddb
diff --git a/net-misc/youtube-dl/youtube-dl-2021.12.17.ebuild b/net-misc/youtube-dl/youtube-dl-2021.12.17.ebuild
new file mode 100644
index 000000000000..110a9df0641e
--- /dev/null
+++ b/net-misc/youtube-dl/youtube-dl-2021.12.17.ebuild
@@ -0,0 +1,74 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..10} )
+
+inherit bash-completion-r1 distutils-r1 readme.gentoo-r1
+
+DESCRIPTION="Download videos from YouTube.com (and more sites...)"
+HOMEPAGE="https://youtube-dl.org/ https://github.com/ytdl-org/youtube-dl/"
+SRC_URI="https://youtube-dl.org/downloads/${PV}/${P}.tar.gz"
+S=${WORKDIR}/${PN}
+
+LICENSE="public-domain"
+KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-solaris"
+SLOT="0"
+
+RDEPEND="
+ dev-python/pycryptodome[${PYTHON_USEDEP}]
+"
+
+distutils_enable_tests nose
+
+src_prepare() {
+ sed -i -e '/flake8/d' Makefile || die
+ distutils-r1_src_prepare
+}
+
+python_test() {
+ emake offlinetest
+}
+
+python_install_all() {
+ doman youtube-dl.1
+
+ newbashcomp youtube-dl.bash-completion youtube-dl
+
+ insinto /usr/share/zsh/site-functions
+ newins youtube-dl.zsh _youtube-dl
+
+ insinto /usr/share/fish/vendor_completions.d
+ doins youtube-dl.fish
+
+ distutils-r1_python_install_all
+
+ rm -r "${ED}"/usr/etc || die
+ rm -r "${ED}"/usr/share/doc/youtube_dl || die
+}
+
+pkg_postinst() {
+ if ! has_version media-video/ffmpeg; then
+ elog "${PN} works fine on its own on most sites. However, if you want"
+ elog "to convert video/audio, you'll need media-video/ffmpeg."
+ elog "On some sites - most notably YouTube - videos can be retrieved in"
+ elog "a higher quality format without sound. ${PN} will detect whether"
+ elog "ffmpeg is present and automatically pick the best option."
+ fi
+ if ! has_version media-video/rtmpdump; then
+ elog
+ elog "Videos or video formats streamed via RTMP protocol can only be"
+ elog "downloaded when media-video/rtmpdump is installed."
+ fi
+ if ! has_version media-video/mplayer && ! has_version media-video/mpv; then
+ elog
+ elog "Downloading MMS and RTSP videos requires either media-video/mplayer"
+ elog "or media-video/mpv to be installed."
+ fi
+ if ! has_version media-video/atomicparsley; then
+ elog
+ elog "Install media-video/atomicparsley if you want ${PN} to embed thumbnails"
+ elog "from the metadata into the resulting MP4/M4A files."
+ fi
+}