summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-03-08 05:26:25 +0100
committerMichał Górny <mgorny@gentoo.org>2024-03-08 06:40:18 +0100
commit7f9c7703929108f0bf0d4cb4b2848c8fc36cdd27 (patch)
tree5d529c5386f79af97e1ef7a4f65f5664411be6af
parentdev-python/botocore: Bump to 1.34.58 (diff)
downloadgentoo-7f9c7703.tar.gz
gentoo-7f9c7703.tar.bz2
gentoo-7f9c7703.zip
dev-python/boto3: Bump to 1.34.58
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/boto3/Manifest1
-rw-r--r--dev-python/boto3/boto3-1.34.58.ebuild58
2 files changed, 59 insertions, 0 deletions
diff --git a/dev-python/boto3/Manifest b/dev-python/boto3/Manifest
index bfa5fcdea9da..74ec829974f7 100644
--- a/dev-python/boto3/Manifest
+++ b/dev-python/boto3/Manifest
@@ -4,3 +4,4 @@ DIST boto3-1.34.54.gh.tar.gz 779564 BLAKE2B f61a74f6a317af6f180edb047e8c37e55c2d
DIST boto3-1.34.55.gh.tar.gz 779897 BLAKE2B 9ca34cb517a0117e91945658ce67d8bc16569931846ef3cf61157a988ee3a6935b8da7581be39304c93bb3a7ae089925abce95e8dfbf4369910d3bb02d232dbe SHA512 9cc45a125817ea1a442c72ba2759e8189dad3a3538f236afa980a3a8203e1ff85d8341b1f9c59bacd066b3b01a1e3a715d3deec42dfbe1846859229517a51e8c
DIST boto3-1.34.56.gh.tar.gz 780044 BLAKE2B d0600fe852787835a74d48582238e8421aa83aa99413037ca03c89d1fb083e591d5b5cac35c94929c2de26f3ad58a97d3e74d70d264daa89cdaffafcc91530ba SHA512 f692371fae8dedfd6bb3dbba1d9ed5a713d0d498d57f8c911caa110cf9ad70466199060271656213299d936b0d9e9b693871967575921cb8ddaee78e23c4ffe6
DIST boto3-1.34.57.gh.tar.gz 780600 BLAKE2B 80592c3877baeea889da4e8346489610337fbefaf8432e41338f4534b7db4d6bebaffc0472fe06ce5c49b9eec108cd18ab12e6ec458ef76ae834d655a0dc35c5 SHA512 c980dd20a470a911634f63cef61ccbf993d8815414edf820b0abdb60bcf0d802d54c3d23ebe0023ba84bbc255e2d6eaf277b872495a97feef1d6a4d0a5d34c77
+DIST boto3-1.34.58.gh.tar.gz 781455 BLAKE2B c0327eb97170554866c7970b6f513ce979f265ba337040ff338babaffe2515532ea1e8eaee4b237243bf481d71f470cf2f1d945126541f02bb35c4935e7a8306 SHA512 c93bf820c17df80a833cc4b89f1afa6611336d93e5fb13d0d32201334354c48012186f45e864d8f983b46cda3dc1d36d90fe2bc2e122918506824764ddc369fb
diff --git a/dev-python/boto3/boto3-1.34.58.ebuild b/dev-python/boto3/boto3-1.34.58.ebuild
new file mode 100644
index 000000000000..b64e7191fd19
--- /dev/null
+++ b/dev-python/boto3/boto3-1.34.58.ebuild
@@ -0,0 +1,58 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..12} )
+
+inherit distutils-r1
+
+DESCRIPTION="The AWS SDK for Python"
+HOMEPAGE="
+ https://github.com/boto/boto3/
+ https://pypi.org/project/boto3/
+"
+SRC_URI="
+ https://github.com/boto/boto3/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~riscv ~sparc ~x86 ~amd64-linux ~x86-linux"
+
+RDEPEND="
+ >=dev-python/botocore-${PV}[${PYTHON_USEDEP}]
+ >=dev-python/jmespath-0.7.1[${PYTHON_USEDEP}]
+ >=dev-python/s3transfer-0.10.0[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/mock[${PYTHON_USEDEP}]
+ )
+"
+
+EPYTEST_XDIST=1
+distutils_enable_tests pytest
+
+python_prepare_all() {
+ # don't lock versions to narrow ranges
+ sed -e '/botocore/ d' \
+ -e '/jmespath/ d' \
+ -e '/s3transfer/ d' \
+ -i setup.py || die
+
+ # do not rely on bundled deps in botocore (sic!)
+ find -name '*.py' -exec sed -i \
+ -e 's:from botocore[.]vendored import:import:' \
+ -e 's:from botocore[.]vendored[.]:from :' \
+ {} + || die
+
+ distutils-r1_python_prepare_all
+}
+
+python_test() {
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ epytest tests/{functional,unit}
+}