summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-02-21 07:21:13 +0100
committerMichał Górny <mgorny@gentoo.org>2023-02-21 08:37:23 +0100
commit7f9f108587e73fe1000a623900abc38285dc9fb8 (patch)
treed43288960012a7d6ada4d3bebb66ee6adc097fdf
parentdev-python/ensurepip-setuptools: Bump to 67.3.3 (diff)
downloadgentoo-7f9f108587e73fe1000a623900abc38285dc9fb8.tar.gz
gentoo-7f9f108587e73fe1000a623900abc38285dc9fb8.tar.bz2
gentoo-7f9f108587e73fe1000a623900abc38285dc9fb8.zip
dev-python/pywlroots: Bump to 0.16.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/pywlroots/Manifest1
-rw-r--r--dev-python/pywlroots/pywlroots-0.16.0.ebuild44
2 files changed, 45 insertions, 0 deletions
diff --git a/dev-python/pywlroots/Manifest b/dev-python/pywlroots/Manifest
index 42da54f56046..18ae46dfa639 100644
--- a/dev-python/pywlroots/Manifest
+++ b/dev-python/pywlroots/Manifest
@@ -1 +1,2 @@
DIST pywlroots-0.15.24.gh.tar.gz 85570 BLAKE2B 0c7ba0be6159152488785298028bb1feec20e2380357060a850dab417b3fb1fccb4a9e6cc6564d2b7f124bf4fc454789549267e9036b0b4559e5fcd4c6f06196 SHA512 b29b76cf18a65b2ef19d15ecf018a9ba44119d60ee61435967d17f06d5f7544d2117f2e9a81574734c71591a237b00c8584a5cc6d6adb928f39f11170f21ee94
+DIST pywlroots-0.16.0.gh.tar.gz 90064 BLAKE2B a9be36d0bf7462bbe3a7a2d9cece1e25d87440467b91059060c28e183236f21753d7bb2b14ce7775cf07c9ce170928ebff5ae8987b24b281aac7fd1c55a8291b SHA512 c28a2822a0494b9f90186a8033dd3f8d769ca0aba808f3574dfc3891b76e3ac560596379ecaa3e8822c4c253003c60899a5e36e283a002a20440209b59f90406
diff --git a/dev-python/pywlroots/pywlroots-0.16.0.ebuild b/dev-python/pywlroots/pywlroots-0.16.0.ebuild
new file mode 100644
index 000000000000..b802883e934e
--- /dev/null
+++ b/dev-python/pywlroots/pywlroots-0.16.0.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{9..11} )
+
+inherit distutils-r1
+
+DESCRIPTION="Python binding to the wlroots library using cffi"
+HOMEPAGE="
+ https://github.com/flacjacket/pywlroots/
+ https://pypi.org/project/pywlroots/
+"
+SRC_URI="
+ https://github.com/flacjacket/pywlroots/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~riscv ~x86"
+
+# See README for wlroots dep
+DEPEND="
+ >=dev-python/pywayland-0.4.14[${PYTHON_USEDEP}]
+ >=dev-python/xkbcommon-0.2[${PYTHON_USEDEP}]
+ =gui-libs/wlroots-$(ver_cut 1-2)*:=
+"
+RDEPEND="
+ ${DEPEND}
+"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-0.15.24-no-import-version-check.patch
+)
+
+distutils_enable_tests pytest
+
+python_test() {
+ rm -rf wlroots || die
+ epytest
+}