summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAgostino Sarubbo <ago@gentoo.org>2021-02-01 12:48:48 +0100
committerAgostino Sarubbo <ago@gentoo.org>2021-02-01 12:48:48 +0100
commit7f9fde45f3b83058d07d193c4fbd962aa2b4a4b1 (patch)
treec95289fc7d4e205c11198bce843a6ccf5c39e4d2
parentnet-im/zoom: Remove old (diff)
downloadgentoo-7f9fde45.tar.gz
gentoo-7f9fde45.tar.bz2
gentoo-7f9fde45.zip
sys-kernel/git-sources: Automated version bump to 5.11_rc6.
Package-Manager: Portage-3.0.9, Repoman-3.0.2 Signed-off-by: Agostino Sarubbo <ago@gentoo.org>
-rw-r--r--sys-kernel/git-sources/Manifest1
-rw-r--r--sys-kernel/git-sources/git-sources-5.11_rc6.ebuild40
2 files changed, 41 insertions, 0 deletions
diff --git a/sys-kernel/git-sources/Manifest b/sys-kernel/git-sources/Manifest
index 0ccba9bc20f7..9450337a1fd4 100644
--- a/sys-kernel/git-sources/Manifest
+++ b/sys-kernel/git-sources/Manifest
@@ -4,3 +4,4 @@ DIST patch-5.11-rc2.patch 74560270 BLAKE2B 1e4ac4ce26e20aa6b48c88af114f6303c6d89
DIST patch-5.11-rc3.patch 75045235 BLAKE2B d159e9e4bedcf6838e0b81462b53445955e59edd266e25cd001d163af36ad56de06dae5496e14663db860805825402959189ce15a80bdb561134d78ff5616b5d SHA512 5fd19e81144ebf489d5a6833b95a21f94c8b0f8d66e85d1c94acdeba008f8705367e03c411c80a61c4c0df30ddfbadcb65ba835014dad6e79c130b756fe518df
DIST patch-5.11-rc4.patch 75392493 BLAKE2B efc6b837641883d1ed7e165d5ba08a36ec85c3bfce49f4f8a0ed09d39df6ecf5844908c13a0bd2792c3dd2a57073dae211934f681482d3a04c0a3589a0776f68 SHA512 072cca3d9bc343b791278258102186646fb46f4808680c71cbe55ba3574448711aaa85b34e8f664a354d69d1665759c196ed37e23f1c0285851b0d2538ff173d
DIST patch-5.11-rc5.patch 75678864 BLAKE2B 8f8afe6935e2d9616981a87c753cc517772f9b0e29d027518fda903f2bd068b0c376ccd668bab489b155875589962211a430880d44945d1faa6d53bd06b5deb2 SHA512 7665e1bd8c58567af774a85065c28a8ded29520eaca4b6ff367ab99a6ce26091e1097949baf23455b5d20e04b9214410dea3d3812b81e91701f6eb40a6d52df8
+DIST patch-5.11-rc6.patch 75970283 BLAKE2B b19ab87b876e41d1efb64d7d542e5493765843fae37a8a9fd1a0e8e4f74a59925a576ad0319dd5ca9133d4a5c6a6080a0e65100dd253b6236dd9b50dbcf2c7e1 SHA512 7096fd281ce60fff3b03244d87fbef06c3b684e95162d19093abcaeb6eb6e0a10e47035f093be90d5760d5dedfcd7a95ccb4009118a7fbc2518ced6aee1a1158
diff --git a/sys-kernel/git-sources/git-sources-5.11_rc6.ebuild b/sys-kernel/git-sources/git-sources-5.11_rc6.ebuild
new file mode 100644
index 000000000000..d3797acbcee8
--- /dev/null
+++ b/sys-kernel/git-sources/git-sources-5.11_rc6.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="6"
+UNIPATCH_STRICTORDER="yes"
+K_NOUSENAME="yes"
+K_NOSETEXTRAVERSION="yes"
+K_NOUSEPR="yes"
+K_SECURITY_UNSUPPORTED="1"
+K_BASE_VER="5.10"
+K_EXP_GENPATCHES_NOUSE="1"
+K_FROM_GIT="yes"
+ETYPE="sources"
+CKV="${PVR/-r/-git}"
+
+# only use this if it's not an _rc/_pre release
+[ "${PV/_pre}" == "${PV}" ] && [ "${PV/_rc}" == "${PV}" ] && OKV="${PV}"
+inherit kernel-2
+detect_version
+
+DESCRIPTION="The very latest -git version of the Linux kernel"
+HOMEPAGE="https://www.kernel.org"
+SRC_URI="${KERNEL_URI}"
+
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~s390 ~sparc ~x86"
+IUSE=""
+
+K_EXTRAEINFO="This kernel is not supported by Gentoo due to its unstable and
+experimental nature. If you have any issues, try a matching vanilla-sources
+ebuild -- if the problem is not there, please contact the upstream kernel
+developers at https://bugzilla.kernel.org and on the linux-kernel mailing list to
+report the problem so it can be fixed in time for the next kernel release."
+
+RDEPEND=""
+DEPEND="${RDEPEND}
+ >=sys-devel/patch-2.7.5"
+
+pkg_postinst() {
+ postinst_sources
+}