summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArthur Zamarin <arthurzam@gentoo.org>2022-09-02 17:36:45 +0300
committerArthur Zamarin <arthurzam@gentoo.org>2022-09-02 18:17:07 +0300
commit7fccd4dfa8cbd67407e8b087b36ffd1cfac5c397 (patch)
tree445a0b734686f42b55de0ae8ec50f9adcd534cd4
parentapp-editors/vscode: add 1.71.0 (diff)
downloadgentoo-7fccd4df.tar.gz
gentoo-7fccd4df.tar.bz2
gentoo-7fccd4df.zip
app-editors/vscodium: add 1.71.0.22245
Signed-off-by: Arthur Zamarin <arthurzam@gentoo.org>
-rw-r--r--app-editors/vscodium/Manifest3
-rw-r--r--app-editors/vscodium/vscodium-1.71.0.22245.ebuild118
2 files changed, 121 insertions, 0 deletions
diff --git a/app-editors/vscodium/Manifest b/app-editors/vscodium/Manifest
index fe01b04b6043..c71d035d082c 100644
--- a/app-editors/vscodium/Manifest
+++ b/app-editors/vscodium/Manifest
@@ -4,3 +4,6 @@ DIST vscodium-1.70.1.22229-arm64.tar.gz 117342125 BLAKE2B c924b7b9af67613d61ae7a
DIST vscodium-1.70.2.22230-amd64.tar.gz 119462089 BLAKE2B 85bbf6638cea72e66b795e4fe33b8fa2815bc05d1feb98d549e6999b09fe4b0f4b1718423b35714e35724c4645a4136df529d7e43a8be83c810ac156b63a52fb SHA512 0830645e671bb9ebdef7c7abba5c3cdf934468621bfe2537ccd10fba64c1278fde381373fe0fc99484dfd9c382b72298695d5d89702414705c29ed270a41a3f4
DIST vscodium-1.70.2.22230-arm.tar.gz 101302938 BLAKE2B c062a33ed58b3d322266ae0ce9825c3aa126f5f8feff4e9c53dc5fc5fcb94b43ec61c0b9cd814f222c74426740734b7570e88c7d54bc11e9bcfd12b0cc761186 SHA512 dea101d8ef45912ee5fd39cb57e90dba9079bc466ddcd8828fcf91ac1d2f792e158d72592a3a657a328e2f4130bfd80e5b084c5457ba32221adee1045f07fdc9
DIST vscodium-1.70.2.22230-arm64.tar.gz 117323455 BLAKE2B 9e2706c5e99f2ed0343ac8b036d519f8adef56c5cd9f8bd219a80cd6d20c49b6d62a4e31d283329daa6147462d6ef526a9f86faaaf017f6a903e7a7a9b392256 SHA512 ed766d2e15e70ae639bb9f42d4877a6f2c0f4984f1a8693c895452b4043dd00a617f5b3739941bd3142332a677cb569383156c7a20d35a072e3177eb5a3457a0
+DIST vscodium-1.71.0.22245-amd64.tar.gz 119418373 BLAKE2B aecb45c00e67d0b6a62560797f02c34f521660fb67526cb77943113c99d8b39b2ac97b12d1b9b8fad85654b4dfa59fb9a5e28f13ddf2deae71e18e0fcfcf92bd SHA512 a284a17e56a09e29b4a1ad6aec3e4e68bc6d6a8d92f0d6744bdc2f708c0acbe4393c9724c4c2eb6256c7198518d48cd0fde3237424bec020887f1b0e28742276
+DIST vscodium-1.71.0.22245-arm.tar.gz 101458849 BLAKE2B 008b95419df2e1e02876b7b7c8bfe567b3291eccca7de418ab899716163a68b536febd6329119f4532017e20c274d479e788a3d3d5bb8d1b3af92fc96afe42f0 SHA512 0700d85e8db1733d3d80ddeaca68132bdeccd7dfc89cda923103739db9d00305087a6544639d4ed802c75eeb2887a998f1b4154d7d0be4db5d11da40e34325be
+DIST vscodium-1.71.0.22245-arm64.tar.gz 112480037 BLAKE2B 730fe3e6564c7c72ddd9bbcc8e13f2ceb298eeb598267d38858660c5e99a0e490916b335096e59bda4cea278d19b00b54cd91f32e7933a7853ee32a6de631361 SHA512 b545b77e7e95ea5b7022310ec8fa50ed290aa7002f0f6c925a10f28eba07cf20ae18ada3f7b37f6aa1ebcc4a2eea76246ef4c511c12b8fa952f3ecadda92ff8f
diff --git a/app-editors/vscodium/vscodium-1.71.0.22245.ebuild b/app-editors/vscodium/vscodium-1.71.0.22245.ebuild
new file mode 100644
index 000000000000..dc168f81f50b
--- /dev/null
+++ b/app-editors/vscodium/vscodium-1.71.0.22245.ebuild
@@ -0,0 +1,118 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit desktop pax-utils xdg optfeature
+
+DESCRIPTION="A community-driven, freely-licensed binary distribution of Microsoft's VSCode"
+HOMEPAGE="https://vscodium.com/"
+SRC_URI="
+ amd64? ( https://github.com/VSCodium/${PN}/releases/download/${PV}/VSCodium-linux-x64-${PV}.tar.gz -> ${P}-amd64.tar.gz )
+ arm? ( https://github.com/VSCodium/${PN}/releases/download/${PV}/VSCodium-linux-armhf-${PV}.tar.gz -> ${P}-arm.tar.gz )
+ arm64? ( https://github.com/VSCodium/${PN}/releases/download/${PV}/VSCodium-linux-arm64-${PV}.tar.gz -> ${P}-arm64.tar.gz )
+"
+
+RESTRICT="strip bindist"
+
+LICENSE="
+ Apache-2.0
+ BSD
+ BSD-1
+ BSD-2
+ BSD-4
+ CC-BY-4.0
+ ISC
+ LGPL-2.1+
+ MIT
+ MPL-2.0
+ openssl
+ PYTHON
+ TextMate-bundle
+ Unlicense
+ UoI-NCSA
+ W3C
+"
+SLOT="0"
+KEYWORDS="-* ~amd64 ~arm ~arm64"
+IUSE=""
+
+RDEPEND="
+ app-accessibility/at-spi2-atk:2
+ app-accessibility/at-spi2-core:2
+ app-crypt/libsecret[crypt]
+ dev-libs/atk
+ dev-libs/expat
+ dev-libs/glib:2
+ dev-libs/nspr
+ dev-libs/nss
+ media-libs/alsa-lib
+ media-libs/mesa
+ sys-apps/util-linux
+ sys-apps/dbus
+ x11-libs/cairo
+ x11-libs/gdk-pixbuf:2
+ x11-libs/gtk+:3
+ x11-libs/libdrm
+ x11-libs/libX11
+ x11-libs/libxcb
+ x11-libs/libXcomposite
+ x11-libs/libXdamage
+ x11-libs/libXext
+ x11-libs/libXfixes
+ x11-libs/libxkbcommon
+ x11-libs/libxkbfile
+ x11-libs/libXrandr
+ x11-libs/libxshmfence
+ x11-libs/pango
+"
+
+QA_PREBUILT="
+ /opt/vscodium/chrome_crashpad_handler
+ /opt/vscodium/chrome-sandbox
+ /opt/vscodium/codium
+ /opt/vscodium/libEGL.so
+ /opt/vscodium/libffmpeg.so
+ /opt/vscodium/libGLESv2.so
+ /opt/vscodium/libvk_swiftshader.so
+ /opt/vscodium/libvulkan.so*
+ /opt/vscodium/resources/app/extensions/*
+ /opt/vscodium/resources/app/node_modules.asar.unpacked/*
+ /opt/vscodium/swiftshader/libEGL.so
+ /opt/vscodium/swiftshader/libGLESv2.so
+"
+
+S="${WORKDIR}"
+
+src_install() {
+ # Cleanup
+ rm "${S}/resources/app/LICENSE.txt" || die
+
+ # Disable update server
+ sed -i "/updateUrl/d" "${S}"/resources/app/product.json || die
+
+ # Install
+ pax-mark m codium
+ insinto "/opt/${PN}"
+ doins -r *
+ fperms +x /opt/${PN}/{,bin/}codium
+ fperms +x /opt/${PN}/chrome_crashpad_handler
+ fperms 4711 /opt/${PN}/chrome-sandbox
+ fperms 755 /opt/${PN}/resources/app/extensions/git/dist/{askpass,git-editor}{,-empty}.sh
+ fperms -R +x /opt/${PN}/resources/app/out/vs/base/node
+ fperms +x /opt/${PN}/resources/app/node_modules.asar.unpacked/@vscode/ripgrep/bin/rg
+ dosym "../../opt/${PN}/bin/codium" "usr/bin/vscodium"
+ dosym "../../opt/${PN}/bin/codium" "usr/bin/codium"
+ domenu "${FILESDIR}/vscodium.desktop"
+ domenu "${FILESDIR}/vscodium-url-handler.desktop"
+ domenu "${FILESDIR}/vscodium-wayland.desktop"
+ domenu "${FILESDIR}/vscodium-url-handler-wayland.desktop"
+ newicon "resources/app/resources/linux/code.png" "vscodium.png"
+}
+
+pkg_postinst() {
+ xdg_pkg_postinst
+ elog "When compared to the regular VSCode, VSCodium has a few quirks"
+ elog "More information at: https://github.com/VSCodium/vscodium/blob/master/DOCS.md"
+ optfeature "keyring support inside vscode" "gnome-base/gnome-keyring"
+}