summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2018-01-30 23:50:44 +0100
committerAndreas Sturmlechner <asturm@gentoo.org>2018-01-31 00:21:04 +0100
commit7fdb1976e5254305f2663a280b5508889fa0ff93 (patch)
treee26bc78c51eeb97488fdd97c6d9f7d2bacb6e06f
parentapp-doc/diveintopython: remove invalid KEYWORDS. (diff)
downloadgentoo-7fdb1976e5254305f2663a280b5508889fa0ff93.tar.gz
gentoo-7fdb1976e5254305f2663a280b5508889fa0ff93.tar.bz2
gentoo-7fdb1976e5254305f2663a280b5508889fa0ff93.zip
net-analyzer/linkchecker: Sync w/ 9.3.1 ebuild, drop USE=X
Package-Manager: Portage-2.3.21, Repoman-2.3.6
-rw-r--r--net-analyzer/linkchecker/linkchecker-9999.ebuild51
1 files changed, 13 insertions, 38 deletions
diff --git a/net-analyzer/linkchecker/linkchecker-9999.ebuild b/net-analyzer/linkchecker/linkchecker-9999.ebuild
index 82cfea75b987..bf89b20f35c2 100644
--- a/net-analyzer/linkchecker/linkchecker-9999.ebuild
+++ b/net-analyzer/linkchecker/linkchecker-9999.ebuild
@@ -1,48 +1,33 @@
-# Copyright 1999-2017 Gentoo Foundation
+# Copyright 1999-2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-EAPI=5
+EAPI=6
PYTHON_COMPAT=( python2_7 )
PYTHON_REQ_USE="sqlite?"
+EGIT_REPO_URI="https://github.com/linkcheck/linkchecker.git"
inherit bash-completion-r1 distutils-r1 eutils git-r3 multilib
-MY_P="${P/linkchecker/LinkChecker}"
-
DESCRIPTION="Check websites for broken links"
-HOMEPAGE="https://wummel.github.com/linkchecker/ https://pypi.python.org/pypi/linkchecker/"
+HOMEPAGE="https://github.com/linkcheck/linkchecker"
SRC_URI=""
-EGIT_REPO_URI="https://github.com/wummel/linkchecker.git"
LICENSE="GPL-2"
SLOT="0"
KEYWORDS=""
-IUSE="gnome sqlite X"
+IUSE="gnome sqlite"
RDEPEND="
virtual/python-dnspython[${PYTHON_USEDEP}]
gnome? ( dev-python/pygtk:2[${PYTHON_USEDEP}] )
- X? (
- dev-python/PyQt4[X,help,${PYTHON_USEDEP}]
- dev-python/qscintilla-python[qt4(+),${PYTHON_USEDEP}]
- )"
-DEPEND="
- X? (
- dev-qt/qthelp:4
- dev-python/markdown2[${PYTHON_USEDEP}]
- )"
+"
+DEPEND=""
RESTRICT="test"
python_prepare_all() {
- local PATCHES=(
- "${FILESDIR}"/${PN}-9.2-unbundle.patch
- "${FILESDIR}"/${PN}-9.3-bash-completion.patch
- "${FILESDIR}"/${PN}-9.3-desktop.patch
- )
-
- emake -C doc/html
+ local PATCHES=( "${FILESDIR}"/${PN}-9.3-bash-completion.patch )
distutils-r1_python_prepare_all
}
@@ -52,26 +37,16 @@ python_install_all() {
doc/upgrading.txt
doc/python3.txt
doc/changelog.txt
- doc/development.txt
+ doc/development.mdwn
)
distutils-r1_python_install_all
- if ! use X; then
- delete_gui() {
- rm -rf \
- "${ED}"/usr/bin/linkchecker-gui* \
- "${ED}"/$(python_get_sitedir)/linkcheck/gui* || die
- }
- python_foreach_impl delete_gui
- rm -f "${ED}"/usr/share/applications/linkchecker*.desktop || die
- fi
-
- rm -f "${ED}"/usr/share/applications/linkchecker.desktop || die
- newicon doc/html/logo64x64.png ${PN}.png
+ rm "${ED}"/usr/share/applications/linkchecker.desktop || die
- docinto html
- dodoc doc/html/*
newbashcomp config/linkchecker-completion ${PN}
+}
+
+pkg_postinst() {
optfeature "bash-completion support" dev-python/argcomplete[${PYTHON_USEDEP}]
optfeature "Virus scanning" app-antivirus/clamav
optfeature "Geo IP support" dev-python/geoip-python[${PYTHON_USEDEP}]