summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2020-12-07 17:10:58 +0000
committerSam James <sam@gentoo.org>2020-12-07 17:10:58 +0000
commit8021512569b236c2ceb62156c206c133b8f17bf0 (patch)
tree35b812dcd30a164fd6fb1c1de3c0495fe9c7d170
parentprofiles/prefix/darwin/macos/11.0: unmask new bash, readline (diff)
downloadgentoo-80215125.tar.gz
gentoo-80215125.tar.bz2
gentoo-80215125.zip
media-libs/raspberrypi-userland: cleanup old
Package-Manager: Portage-3.0.9, Repoman-3.0.2 Signed-off-by: Sam James <sam@gentoo.org>
-rw-r--r--media-libs/raspberrypi-userland/Manifest1
-rw-r--r--media-libs/raspberrypi-userland/raspberrypi-userland-0_pre20160424.ebuild109
2 files changed, 0 insertions, 110 deletions
diff --git a/media-libs/raspberrypi-userland/Manifest b/media-libs/raspberrypi-userland/Manifest
index 29025c84702d..14ea7065276c 100644
--- a/media-libs/raspberrypi-userland/Manifest
+++ b/media-libs/raspberrypi-userland/Manifest
@@ -1,2 +1 @@
-DIST raspberrypi-userland-0_pre20160424.tar.gz 32933952 BLAKE2B 4a2d40200a6a4d673be277a0958f768342a2777c28b14b4c7fcac1dbc9c59f2ef2485234f11fbd228aea6bbcf4982a3fd1d4825268af60be91665ea6fee6922d SHA512 04a71837b1247ecbbe479b3b09b5705638a9e576dc99a1ab2200727509195a4a2f2a9b184e3c23ce3933a3236b260afc8bd2b75bc218567b386445bdd8208a5b
DIST raspberrypi-userland-0_pre20201022.tar.gz 32958590 BLAKE2B 01733a24822d80c5bf9aa3e0feefc3e9437390a465d7a4184d0a9c6a68446e91515d3d6d398ff516d9fd1bdcd4a885512d358a4ed1d24d9b94bdc72d81db84d3 SHA512 1813224068b8a8e569c874a8ffb354f1ac86e95b482caaad18b9703a187baaea60f1f87dfbb0c7e4b3cb2eb875abbcc82aedba410646a3c1df0208bd73aaf9f9
diff --git a/media-libs/raspberrypi-userland/raspberrypi-userland-0_pre20160424.ebuild b/media-libs/raspberrypi-userland/raspberrypi-userland-0_pre20160424.ebuild
deleted file mode 100644
index ddbbd294d3a3..000000000000
--- a/media-libs/raspberrypi-userland/raspberrypi-userland-0_pre20160424.ebuild
+++ /dev/null
@@ -1,109 +0,0 @@
-# Copyright 1999-2017 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=5
-
-inherit cmake-utils
-
-DESCRIPTION="Raspberry Pi userspace tools and libraries"
-HOMEPAGE="https://github.com/raspberrypi/userland"
-
-if [[ ${PV} == 9999* ]]; then
- inherit git-2
- EGIT_REPO_URI="https://github.com/${PN/-//}.git"
- SRC_URI=""
-else
- GIT_COMMIT="dff5760"
- SRC_URI="https://github.com/raspberrypi/userland/tarball/${GIT_COMMIT} -> ${P}.tar.gz"
- KEYWORDS="arm"
- S="${WORKDIR}/raspberrypi-userland-${GIT_COMMIT}"
-fi
-
-RDEPEND="
- !media-libs/raspberrypi-userland-bin
- wayland? ( dev-libs/wayland )"
-
-DEPEND="
- ${RDEPEND}
- wayland? ( virtual/pkgconfig )"
-
-IUSE="examples wayland"
-LICENSE="BSD"
-SLOT="0"
-
-# TODO:
-# * port vcfiled init script
-# * stuff is still installed to hardcoded /opt/vc location, investigate whether
-# anything else depends on it being there
-# * live ebuild
-
-src_unpack() {
- if [[ ${PV} == 9999* ]]; then
- git-2_src_unpack
- else
- default
- fi
-}
-
-src_prepare() {
- # init script for Debian, not useful on Gentoo
- sed -i "/DESTINATION \/etc\/init.d/,+2d" interface/vmcs_host/linux/vcfiled/CMakeLists.txt || die
-
- # wayland egl support
- epatch "${FILESDIR}"/next-resource-handle.patch
-}
-
-src_install() {
- cmake-utils_src_install
-
- # provide OpenGL ES v1 according to https://github.com/raspberrypi/firmware/issues/78
- dosym libGLESv2.so /opt/vc/lib/libGLESv1_CM.so
-
- doenvd "${FILESDIR}"/04${PN}
-
- insinto /lib/udev/rules.d
- doins "${FILESDIR}"/92-local-vchiq-permissions.rules
-
- # enable dynamic switching of the GL implementation
- dodir /usr/lib/opengl
- dosym ../../../opt/vc /usr/lib/opengl/${PN}
-
- # tell eselect opengl that we do not have libGL
- touch "${ED}"/opt/vc/.gles-only || die
-
- insinto /opt/vc/lib/pkgconfig
- doins "${FILESDIR}"/bcm_host.pc
- doins "${FILESDIR}"/egl.pc
- doins "${FILESDIR}"/glesv2.pc
- if use wayland; then
- # Missing wayland-egl version from the patch; claim 9.0 (a mesa version) for now, so gst-plugins-bad wayland-egl check is happy
- sed -i -e 's/Version: /Version: 9.0/' "${ED}/opt/vc/lib/pkgconfig/wayland-egl.pc" || die
- doins "${ED}"/opt/vc/lib/pkgconfig/wayland-egl.pc # Maybe move?
- fi
-
- # some #include instructions are wrong so we need to fix them
- einfo "Fixing #include \"vcos_platform_types.h\""
- for file in $(grep -l "#include \"vcos_platform_types.h\"" "${D}"/opt/vc/include/* -r); do
- einfo " Fixing file ${file}"
- sed -i "s%#include \"vcos_platform_types.h\"%#include \"interface/vcos/pthreads/vcos_platform_types.h\"%g" ${file} || die
- done
-
- einfo "Fixing #include \"vcos_platform.h\""
- for file in $(grep -l "#include \"vcos_platform.h\"" "${D}"/opt/vc/include/* -r); do
- einfo " Fixing file ${file}"
- sed -i "s%#include \"vcos_platform.h\"%#include \"interface/vcos/pthreads/vcos_platform.h\"%g" ${file} || die
- done
-
- einfo "Fixing #include \"vchost_config.h\""
- for file in $(grep -l "#include \"vchost_config.h\"" "${D}"/opt/vc/include/* -r); do
- einfo " Fixing file ${file}"
- sed -i "s%#include \"vchost_config.h\"%#include \"interface/vmcs_host/linux/vchost_config.h\"%g" ${file} || die
- done
-
- if use examples; then
- dodir /usr/share/doc/${PF}/examples
- mv "${D}"/opt/vc/src/hello_pi "${D}"/usr/share/doc/${PF}/examples/ || die
- fi
-
- rm -rfv "${D}"/opt/vc/src || die
-}