summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2021-11-10 11:44:48 +0100
committerAndreas Sturmlechner <asturm@gentoo.org>2021-11-10 11:44:48 +0100
commit8034036cc6039af965de8da3d0439c88e407371b (patch)
tree1a285c7e25742b292183d0402c07b7bef7952795
parentdev-libs/hidapi: ebuild enhancements for 0.11.0 (diff)
downloadgentoo-8034036cc6039af965de8da3d0439c88e407371b.tar.gz
gentoo-8034036cc6039af965de8da3d0439c88e407371b.tar.bz2
gentoo-8034036cc6039af965de8da3d0439c88e407371b.zip
media-gfx/exiv2: Cleanup vulnerable 0.27.4-r2
Bug: https://bugs.gentoo.org/807346 Package-Manager: Portage-3.0.28, Repoman-3.0.3 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
-rw-r--r--media-gfx/exiv2/Manifest1
-rw-r--r--media-gfx/exiv2/exiv2-0.27.4-r2.ebuild116
-rw-r--r--media-gfx/exiv2/files/exiv2-0.27.4-gtest-1.11.patch32
3 files changed, 0 insertions, 149 deletions
diff --git a/media-gfx/exiv2/Manifest b/media-gfx/exiv2/Manifest
index 88b7a7c4f8d5..a9c896be4e08 100644
--- a/media-gfx/exiv2/Manifest
+++ b/media-gfx/exiv2/Manifest
@@ -1,2 +1 @@
-DIST exiv2-0.27.4-Source.tar.gz 32055837 BLAKE2B 9c31c08fafb38895fa7812a8c7a195335e80a6b9c15f7b5f3750f5ab30903c4c3bbf9aee5a7293a7d437d15a49a9cb7b45a3133cbb36ee62081efae0dd67b61a SHA512 f6798baafb36a54ba5bc65c2d28d4f4469e298582c90b417eb437b5dbda8e11963fb3314e8419717b3815ee8c3a68955cddc79e45351d9f2c165a0b73eb7b7be
DIST exiv2-0.27.5-Source.tar.gz 32720608 BLAKE2B 803cb853fd049b28d309952c2332589a8544ff90c16fc1a588b6f1a2d4ae5e96da7ae746cf2247954ac54e155b84e0ad1f4f2d89f22d07e7bbd34038f0e292a5 SHA512 0f2d2dfbc976052a428dfeb597225d3ea3c725f584d05b99316bd4aa9cbf0ba5e1e37bcde71f9041975cf003b4fdb578c559adb144268d784bfd64494f451491
diff --git a/media-gfx/exiv2/exiv2-0.27.4-r2.ebuild b/media-gfx/exiv2/exiv2-0.27.4-r2.ebuild
deleted file mode 100644
index 7acbc098873b..000000000000
--- a/media-gfx/exiv2/exiv2-0.27.4-r2.ebuild
+++ /dev/null
@@ -1,116 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-if [[ ${PV} = *9999 ]]; then
- EGIT_REPO_URI="https://github.com/Exiv2/exiv2.git"
- inherit git-r3
-else
- SRC_URI="https://exiv2.org/builds/${P}-Source.tar.gz"
- KEYWORDS="~alpha amd64 arm arm64 ~hppa ~ia64 ~mips ppc ppc64 ~riscv ~s390 sparc x86 ~amd64-linux ~x86-linux ~x64-solaris ~x86-solaris"
- S="${WORKDIR}/${P}-Source"
-fi
-
-CMAKE_ECLASS=cmake
-PYTHON_COMPAT=( python3_{7,8,9} )
-inherit cmake-multilib python-any-r1
-
-DESCRIPTION="EXIF, IPTC and XMP metadata C++ library and command line utility"
-HOMEPAGE="https://www.exiv2.org/"
-
-LICENSE="GPL-2"
-SLOT="0/27"
-IUSE="+bmff doc examples nls +png test webready +xmp"
-RESTRICT="!test? ( test )"
-
-BDEPEND="
- doc? (
- ${PYTHON_DEPS}
- app-doc/doxygen
- dev-libs/libxslt
- media-gfx/graphviz
- virtual/pkgconfig
- )
- nls? ( sys-devel/gettext )
-"
-RDEPEND="
- >=virtual/libiconv-0-r1[${MULTILIB_USEDEP}]
- nls? ( >=virtual/libintl-0-r1[${MULTILIB_USEDEP}] )
- png? ( sys-libs/zlib[${MULTILIB_USEDEP}] )
- webready? (
- >net-libs/libssh-0.9.1[sftp,${MULTILIB_USEDEP}]
- net-misc/curl[${MULTILIB_USEDEP}]
- )
- xmp? ( dev-libs/expat[${MULTILIB_USEDEP}] )
-"
-DEPEND="${DEPEND}
- test? ( dev-cpp/gtest )"
-
-DOCS=( README.md doc/ChangeLog doc/cmd.txt )
-
-PATCHES=(
- "${FILESDIR}"/${PN}-0.27.4-gtest-1.11.patch
-)
-
-pkg_setup() {
- use doc && python-any-r1_pkg_setup
-}
-
-src_prepare() {
- # FIXME @upstream:
- einfo "Converting doc/cmd.txt to UTF-8"
- iconv -f LATIN1 -t UTF-8 doc/cmd.txt > doc/cmd.txt.tmp || die
- mv -f doc/cmd.txt.tmp doc/cmd.txt || die
-
- cmake_src_prepare
-
- sed -e "/^include.*compilerFlags/s/^/#DONT /" -i CMakeLists.txt || die
-}
-
-multilib_src_configure() {
- local mycmakeargs=(
- -DCMAKE_CXX_STANDARD=14
- -DEXIV2_BUILD_SAMPLES=NO
- -DEXIV2_ENABLE_NLS=$(usex nls)
- -DEXIV2_ENABLE_PNG=$(usex png)
- -DEXIV2_ENABLE_CURL=$(usex webready)
- -DEXIV2_ENABLE_SSH=$(usex webready)
- -DEXIV2_ENABLE_WEBREADY=$(usex webready)
- -DEXIV2_ENABLE_XMP=$(usex xmp)
- -DEXIV2_ENABLE_BMFF=$(usex bmff)
- $(multilib_is_native_abi || echo -DEXIV2_BUILD_EXIV2_COMMAND=NO)
- $(multilib_is_native_abi && echo -DEXIV2_BUILD_DOC=$(usex doc))
- $(multilib_is_native_abi && echo -DEXIV2_BUILD_UNIT_TESTS=$(usex test))
- -DCMAKE_INSTALL_DOCDIR="${EPREFIX}"/usr/share/doc/${PF}/html
- )
-
- cmake_src_configure
-}
-
-multilib_src_compile() {
- cmake_src_compile
-
- if multilib_is_native_abi; then
- use doc && eninja doc
- fi
-}
-
-multilib_src_test() {
- if multilib_is_native_abi; then
- cd "${BUILD_DIR}"/bin || die
- ./unit_tests || die "Failed to run tests"
- fi
-}
-
-multilib_src_install_all() {
- use xmp && DOCS+=( doc/{COPYING-XMPSDK,README-XMP,cmdxmp.txt} )
-
- einstalldocs
- find "${D}" -name '*.la' -delete || die
-
- if use examples; then
- docinto examples
- dodoc samples/*.cpp
- fi
-}
diff --git a/media-gfx/exiv2/files/exiv2-0.27.4-gtest-1.11.patch b/media-gfx/exiv2/files/exiv2-0.27.4-gtest-1.11.patch
deleted file mode 100644
index bb368d367cb7..000000000000
--- a/media-gfx/exiv2/files/exiv2-0.27.4-gtest-1.11.patch
+++ /dev/null
@@ -1,32 +0,0 @@
-https://github.com/Exiv2/exiv2/pull/1722
-
-From f01805f68eb19f56b0415a50a1128cbbdd82bff4 Mon Sep 17 00:00:00 2001
-From: Antonio Rojas <arojas@archlinux.org>
-Date: Fri, 18 Jun 2021 18:53:46 +0200
-Subject: [PATCH] Fix build with gtest 1.11
-
-INSTANTIATE_TYPED_TEST_CASE_P requires a non-empty prefix now
----
- unitTests/test_slice.cpp | 6 +++---
- 1 file changed, 3 insertions(+), 3 deletions(-)
-
-diff --git a/unitTests/test_slice.cpp b/unitTests/test_slice.cpp
-index ccf80d98d..59171cfcf 100644
---- a/unitTests/test_slice.cpp
-+++ b/unitTests/test_slice.cpp
-@@ -440,12 +440,12 @@ REGISTER_TYPED_TEST_CASE_P(slice, atAccess, iteratorAccess, constructionFailsFro
- constMethodsPreserveConst);
-
- typedef ::testing::Types<const std::vector<int>, std::vector<int>, int*, const int*> test_types_t;
--INSTANTIATE_TYPED_TEST_CASE_P(, slice, test_types_t);
-+INSTANTIATE_TYPED_TEST_CASE_P(slice, slice, test_types_t);
-
- REGISTER_TYPED_TEST_CASE_P(mutableSlice, iterators, at);
- typedef ::testing::Types<std::vector<int>, int*> mut_test_types_t;
--INSTANTIATE_TYPED_TEST_CASE_P(, mutableSlice, mut_test_types_t);
-+INSTANTIATE_TYPED_TEST_CASE_P(slice, mutableSlice, mut_test_types_t);
-
- REGISTER_TYPED_TEST_CASE_P(dataBufSlice, successfulConstruction, failedConstruction);
- typedef ::testing::Types<DataBuf&, const DataBuf&> data_buf_types_t;
--INSTANTIATE_TYPED_TEST_CASE_P(, dataBufSlice, data_buf_types_t);
-+INSTANTIATE_TYPED_TEST_CASE_P(slice, dataBufSlice, data_buf_types_t);