summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorYiyang Wu <xgreenlandforwyy@gmail.com>2023-03-19 23:25:18 +0800
committerBenda Xu <heroxbd@gentoo.org>2023-04-06 00:09:29 +0800
commit8039d6fb841d9bf4841574000b43c12ff9d30f37 (patch)
treefc4ffec669c1875e53b25ee1268147153361c307
parentprofiles/package.mask: mask remaining abrt packages (diff)
downloadgentoo-8039d6fb841d9bf4841574000b43c12ff9d30f37.tar.gz
gentoo-8039d6fb841d9bf4841574000b43c12ff9d30f37.tar.bz2
gentoo-8039d6fb841d9bf4841574000b43c12ff9d30f37.zip
dev-util/hip: fix HIP_CLANG_PATH detection in FindHIP.cmake
Signed-off-by: Yiyang Wu <xgreenlandforwyy@gmail.com> Signed-off-by: Benda Xu <heroxbd@gentoo.org> Closes: https://github.com/gentoo/gentoo/pull/29973
-rw-r--r--dev-util/hip/files/hip-5.4.3-fix-HIP_CLANG_PATH-detection.patch26
-rw-r--r--dev-util/hip/hip-5.3.3-r3.ebuild1
-rw-r--r--dev-util/hip/hip-5.4.3.ebuild1
3 files changed, 28 insertions, 0 deletions
diff --git a/dev-util/hip/files/hip-5.4.3-fix-HIP_CLANG_PATH-detection.patch b/dev-util/hip/files/hip-5.4.3-fix-HIP_CLANG_PATH-detection.patch
new file mode 100644
index 000000000000..28277d9d880c
--- /dev/null
+++ b/dev-util/hip/files/hip-5.4.3-fix-HIP_CLANG_PATH-detection.patch
@@ -0,0 +1,26 @@
+From 03a7fd2937c146142fa95d22a0ee10df40442788 Mon Sep 17 00:00:00 2001
+From: Yiyang Wu <xgreenlandforwyy@gmail.com>
+Date: Sun, 19 Mar 2023 22:32:01 +0800
+Subject: [PATCH] FindHIP.cmake: fix HIP_CLANG_PATH detection via
+ HIP_CLANG_INSTALL_DIR
+
+---
+ cmake/FindHIP.cmake | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/cmake/FindHIP.cmake b/cmake/FindHIP.cmake
+index 109c9f65..5dc4c632 100644
+--- a/cmake/FindHIP.cmake
++++ b/cmake/FindHIP.cmake
+@@ -255,7 +255,7 @@ elseif("${HIP_COMPILER}" STREQUAL "clang")
+ if("x${HIP_CLANG_PATH}" STREQUAL "x")
+ # IF HIP_CLANG_INSTALL_DIR is Found
+ if( HIP_CLANG_INSTALL_DIR )
+- set(HIP_CLANG_PATH ${HIP_CLANG_INSTALL_DIR})
++ set(HIP_CLANG_PATH "${HIP_CLANG_INSTALL_DIR}/bin")
+ else() # IF HIP_CLANG_INSTALL_DIR is not found
+ if(DEFINED ENV{HIP_CLANG_PATH})
+ set(HIP_CLANG_PATH $ENV{HIP_CLANG_PATH})
+--
+2.40.0
+
diff --git a/dev-util/hip/hip-5.3.3-r3.ebuild b/dev-util/hip/hip-5.3.3-r3.ebuild
index e73675209ae1..c03da0d6effc 100644
--- a/dev-util/hip/hip-5.3.3-r3.ebuild
+++ b/dev-util/hip/hip-5.3.3-r3.ebuild
@@ -81,6 +81,7 @@ src_prepare() {
eapply "${FILESDIR}/0001-SWDEV-344620-hipcc-fails-to-parse-version-of-clang-i.patch"
eapply "${FILESDIR}/0002-SWDEV-355608-Remove-clang-include-path-2996.patch"
eapply "${FILESDIR}/0003-SWDEV-352878-Removed-relative-path-based-CLANG-inclu.patch"
+ eapply "${FILESDIR}/${PN}-5.4.3-fix-HIP_CLANG_PATH-detection.patch"
# Setting HSA_PATH to "/usr" results in setting "-isystem /usr/include"
# which makes "stdlib.h" not found when using "#include_next" in header files;
sed -e "/FLAGS .= \" -isystem \$HSA_PATH/d" \
diff --git a/dev-util/hip/hip-5.4.3.ebuild b/dev-util/hip/hip-5.4.3.ebuild
index 417b2b6c3290..7798aab3e444 100644
--- a/dev-util/hip/hip-5.4.3.ebuild
+++ b/dev-util/hip/hip-5.4.3.ebuild
@@ -81,6 +81,7 @@ src_prepare() {
eapply "${FILESDIR}/${PN}-5.4.3-clang-version.patch"
eapply "${FILESDIR}/${PN}-5.4.3-clang-include.patch"
eapply "${FILESDIR}/0003-SWDEV-352878-Removed-relative-path-based-CLANG-inclu.patch"
+ eapply "${FILESDIR}/${PN}-5.4.3-fix-HIP_CLANG_PATH-detection.patch"
# Setting HSA_PATH to "/usr" results in setting "-isystem /usr/include"
# which makes "stdlib.h" not found when using "#include_next" in header files;