summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorWim Muskee <wimmuskee@gmail.com>2019-12-08 08:41:37 +0100
committerMatthew Thode <prometheanfire@gentoo.org>2019-12-08 02:31:46 -0600
commit8061e8cef8739d47c1f1dfe910ccce833ed8586c (patch)
tree69de2cbebaa790d404150fba80fa6af97e5397e1
parentapp-admin/augeas: fix MissingTestRestrict (diff)
downloadgentoo-8061e8cef8739d47c1f1dfe910ccce833ed8586c.tar.gz
gentoo-8061e8cef8739d47c1f1dfe910ccce833ed8586c.tar.bz2
gentoo-8061e8cef8739d47c1f1dfe910ccce833ed8586c.zip
dev-python/fasteners: fix MissingTestRestrict
Signed-off-by: Wim Muskee <wimmuskee@gmail.com> Signed-off-by: Matthew Thode <prometheanfire@gentoo.org>
-rw-r--r--dev-python/fasteners/fasteners-0.14.1-r1.ebuild3
-rw-r--r--dev-python/fasteners/fasteners-0.14.1.ebuild1
2 files changed, 3 insertions, 1 deletions
diff --git a/dev-python/fasteners/fasteners-0.14.1-r1.ebuild b/dev-python/fasteners/fasteners-0.14.1-r1.ebuild
index 3f62ea4e6d5e..156cb0c19361 100644
--- a/dev-python/fasteners/fasteners-0.14.1-r1.ebuild
+++ b/dev-python/fasteners/fasteners-0.14.1-r1.ebuild
@@ -2,7 +2,7 @@
# Distributed under the terms of the GNU General Public License v2
EAPI=7
-PYTHON_COMPAT=( python2_7 python3_{5,6,7,7} pypy )
+PYTHON_COMPAT=( python2_7 python3_{5,6,7} pypy )
inherit distutils-r1
@@ -14,6 +14,7 @@ LICENSE="Apache-2.0"
SLOT="0"
KEYWORDS="amd64 ~arm arm64 ~x86 ~amd64-linux ~x86-linux"
IUSE="test"
+RESTRICT="!test? ( test )"
RDEPEND="
>=dev-python/monotonic-0.1[${PYTHON_USEDEP}]
diff --git a/dev-python/fasteners/fasteners-0.14.1.ebuild b/dev-python/fasteners/fasteners-0.14.1.ebuild
index c722a8f6fbf9..ef49731e5f0b 100644
--- a/dev-python/fasteners/fasteners-0.14.1.ebuild
+++ b/dev-python/fasteners/fasteners-0.14.1.ebuild
@@ -15,6 +15,7 @@ LICENSE="Apache-2.0"
SLOT="0"
KEYWORDS="amd64 ~arm ~arm64 x86 ~amd64-linux ~x86-linux"
IUSE="test"
+RESTRICT="!test? ( test )"
RDEPEND="
>=dev-python/monotonic-0.1[${PYTHON_USEDEP}]