summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-08-10 04:44:03 +0200
committerMichał Górny <mgorny@gentoo.org>2023-08-10 04:53:09 +0200
commit8067019563b5ab178361e3ab303bec641fe5e4eb (patch)
treefb30fa204c43db5558ff603a582c9cecda963aec
parentdev-python/sphinxcontrib-qthelp: Bump to 1.0.5 (diff)
downloadgentoo-8067019563b5ab178361e3ab303bec641fe5e4eb.tar.gz
gentoo-8067019563b5ab178361e3ab303bec641fe5e4eb.tar.bz2
gentoo-8067019563b5ab178361e3ab303bec641fe5e4eb.zip
dev-python/sphinxcontrib-serializinghtml: Bump to 1.1.7
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/sphinxcontrib-serializinghtml/Manifest1
-rw-r--r--dev-python/sphinxcontrib-serializinghtml/sphinxcontrib-serializinghtml-1.1.7.ebuild29
2 files changed, 30 insertions, 0 deletions
diff --git a/dev-python/sphinxcontrib-serializinghtml/Manifest b/dev-python/sphinxcontrib-serializinghtml/Manifest
index e5aa47f5e17e..03ab4274f71a 100644
--- a/dev-python/sphinxcontrib-serializinghtml/Manifest
+++ b/dev-python/sphinxcontrib-serializinghtml/Manifest
@@ -1 +1,2 @@
DIST sphinxcontrib-serializinghtml-1.1.5.tar.gz 21019 BLAKE2B e2da8b1e1300a327b8d508ce98e7c0d3eff1e0cea28cd874df4fbd9ed0bd4de6c17e107e622ec72e00bb237025ae26b2c5aaa33b2156cee2fad7c8f8d2c65ed5 SHA512 c5aabe4d29fd0455c269f8054089fdd61e1de5c35aa407740fc3baae4cfb3235d9fd5515c0489b0becd12abc8f18d0f42aa169ed315c00f30ba87e64ce851667
+DIST sphinxcontrib_serializinghtml-1.1.7.tar.gz 15313 BLAKE2B 6453e5b24be17ed10ab2c9567cac273af9941f94850388b4ef61e2114e1e1f6fd5e6fd63306107c55df068d9b4f784c6c282d8f8fba7d4b772272f6c9fa39bee SHA512 a4a3ff0b7d7ef8b9eb4e179a494b58d3358cd94837db40c19350ceb1810d9917dca8a116d624d2a679399221fc4fc06ad161d6a2735525cc43bec9826e605af9
diff --git a/dev-python/sphinxcontrib-serializinghtml/sphinxcontrib-serializinghtml-1.1.7.ebuild b/dev-python/sphinxcontrib-serializinghtml/sphinxcontrib-serializinghtml-1.1.7.ebuild
new file mode 100644
index 000000000000..dd43a2698134
--- /dev/null
+++ b/dev-python/sphinxcontrib-serializinghtml/sphinxcontrib-serializinghtml-1.1.7.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=flit
+PYTHON_COMPAT=( python3_{10..12} pypy3 )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Sphinx extension which outputs outputs serialized HTML files"
+HOMEPAGE="
+ https://www.sphinx-doc.org/
+ https://github.com/sphinx-doc/sphinxcontrib-serializinghtml/
+ https://pypi.org/project/sphinxcontrib-serializinghtml/
+"
+
+LICENSE="BSD-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x64-solaris"
+
+PDEPEND="
+ >=dev-python/sphinx-5[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? ( ${PDEPEND} )
+"
+
+distutils_enable_tests pytest