summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArthur Zamarin <arthurzam@gentoo.org>2022-06-06 21:51:44 +0300
committerArthur Zamarin <arthurzam@gentoo.org>2022-06-06 21:56:33 +0300
commit806f7aad1ced846fa65c223a9ff3d0551eae1f89 (patch)
treea41eba51ff1ea4e445a777b006837d428f8bd347
parentdev-python/PyPDF2: add 2.1.0 (diff)
downloadgentoo-806f7aad.tar.gz
gentoo-806f7aad.tar.bz2
gentoo-806f7aad.zip
dev-python/mypy: add 0.961
Signed-off-by: Arthur Zamarin <arthurzam@gentoo.org>
-rw-r--r--dev-python/mypy/Manifest1
-rw-r--r--dev-python/mypy/mypy-0.961.ebuild62
2 files changed, 63 insertions, 0 deletions
diff --git a/dev-python/mypy/Manifest b/dev-python/mypy/Manifest
index c52a506d1736..9666a5900758 100644
--- a/dev-python/mypy/Manifest
+++ b/dev-python/mypy/Manifest
@@ -1,3 +1,4 @@
DIST mypy-0.942.tar.gz 2701940 BLAKE2B 5501466e57b4afb8825e6c804cbdc270c79ff457c39f2e5834f4b68df70263c05b2b9abb08fe58202ee65f5e22d2291f39fcb1fc47168416134538c5f6e12ab3 SHA512 79b83587eefad10d7d20d3bfd8484a9e8b2d363e68c1e5ffaa3a82ca8b8f8d9183036ea46695a634f9156911d6f918af684ac636105b37b3a5d0e958f5d661f4
DIST mypy-0.950.tar.gz 2746164 BLAKE2B 8466012fd3622f5e730acef774115ac84ff8c6f5488213a450de63d5acc790f937b7c69a1b05b46deef6fe8f81a13ed8e85f83c6c22cce9abdbb73b2ecf4179c SHA512 949d1dade3f225bbef0934fff040f7d5aec47039f554a669ca491d6cb46d56de3fcae0186864cdcaf5dec1347bc3af453218520536a0afa77e89a5c0e4640500
DIST mypy-0.960.tar.gz 2767017 BLAKE2B 54ca4b9ffeef1f9211569ae8daee3ae201bfc6239eb9530dd5b7bb53983b0f9d343951dc49e4c4cd257660491be3805d7b8a3b5621dd25f1b7726f522a1c74df SHA512 1caa5ea5d87631a00acabd712053193aac4ed2f475760da90e395d64c44092797e45a4793a5fa2dc05458e9d2411b5cde14811c8a5112376c00baf9792df923f
+DIST mypy-0.961.gh.tar.gz 2767264 BLAKE2B 333e860f2416d065fd26f29f818e88c25f223c8f558bd174280ccfbe856c823253095830cc9cc44dd453b3661583d7626e5679ce1e44479b62ed75139051a9a2 SHA512 f7f57d38777256a45c950a45e832b6f1b9465a6663056472a9b32dc8c1d38b4d28ed856f4de12202de5910eeb6197a22073e12924a1e3f58d5631aaa938c0f2a
diff --git a/dev-python/mypy/mypy-0.961.ebuild b/dev-python/mypy/mypy-0.961.ebuild
new file mode 100644
index 000000000000..b704d0fda712
--- /dev/null
+++ b/dev-python/mypy/mypy-0.961.ebuild
@@ -0,0 +1,62 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..10} )
+
+inherit distutils-r1 multiprocessing
+
+DESCRIPTION="Optional static typing for Python"
+HOMEPAGE="
+ http://www.mypy-lang.org/
+ https://github.com/python/mypy/
+ https://pypi.org/project/mypy/
+"
+SRC_URI="
+ https://github.com/python/mypy/archive/v${PV}.tar.gz -> ${P}.gh.tar.gz
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+
+# stubgen collides with this package: https://bugs.gentoo.org/585594
+RDEPEND="
+ !dev-util/stubgen
+ >=dev-python/psutil-4[${PYTHON_USEDEP}]
+ >=dev-python/typed-ast-1.4.0[${PYTHON_USEDEP}]
+ <dev-python/typed-ast-1.5.0[${PYTHON_USEDEP}]
+ >=dev-python/typing-extensions-3.7.4[${PYTHON_USEDEP}]
+ >=dev-python/mypy_extensions-0.4.3[${PYTHON_USEDEP}]
+ <dev-python/mypy_extensions-0.5.0[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep '
+ dev-python/tomli[${PYTHON_USEDEP}]
+ ' 3.8 3.9 3.10)
+"
+BDEPEND="
+ test? (
+ >=dev-python/attrs-18.0[${PYTHON_USEDEP}]
+ >=dev-python/lxml-4.4.0[${PYTHON_USEDEP}]
+ >=dev-python/pytest-6.1.0[${PYTHON_USEDEP}]
+ >=dev-python/pytest-xdist-1.18[${PYTHON_USEDEP}]
+ >=dev-python/py-1.5.2[${PYTHON_USEDEP}]
+ >=dev-python/typed-ast-1.4.0[${PYTHON_USEDEP}]
+ >=dev-python/virtualenv-16.0.0[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_sphinx docs/source \
+ dev-python/sphinx_rtd_theme
+distutils_enable_tests pytest
+
+# this requires packaging a lot of type stubs
+export MYPY_USE_MYPYC=0
+
+python_test() {
+ # Some mypy/test/testcmdline.py::PythonCmdlineSuite tests
+ # fail with high COLUMNS values
+ local -x COLUMNS=80
+ epytest -n "$(makeopts_jobs)"
+}