summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-03-11 05:00:23 +0100
committerMichał Górny <mgorny@gentoo.org>2024-03-11 05:08:43 +0100
commit807721d53c819b72267f64030719fe9a3ac60cb1 (patch)
tree56c7695c2bb5dd96fd0c82db78a6f6e7d31e2254
parentdev-python/pyrate-limiter: Bump to 3.3.0 (diff)
downloadgentoo-807721d53c819b72267f64030719fe9a3ac60cb1.tar.gz
gentoo-807721d53c819b72267f64030719fe9a3ac60cb1.tar.bz2
gentoo-807721d53c819b72267f64030719fe9a3ac60cb1.zip
dev-python/owslib: Bump to 0.30.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/owslib/Manifest1
-rw-r--r--dev-python/owslib/owslib-0.30.0.ebuild65
2 files changed, 66 insertions, 0 deletions
diff --git a/dev-python/owslib/Manifest b/dev-python/owslib/Manifest
index 04b2be6cd3b3..451ebca9f8ab 100644
--- a/dev-python/owslib/Manifest
+++ b/dev-python/owslib/Manifest
@@ -1 +1,2 @@
DIST OWSLib-0.29.3.gh.tar.gz 994453 BLAKE2B 442dc832b94bfdc383b9d932de957696f9abb4d3843c856b07cf56a47c42291c6d7ff8b8713bb123d296c780e44efbfa08ba94ba2ee747dc7a2f4de0508a5f0f SHA512 2aa63ae18830d724f2cb46647ed867c5b74b2858a93df2500160b5cd58b25b0fb39bfc2d5bcda58bfe3b229bac5ea68acf9abdc746971e2eb5198875f00e6f4d
+DIST OWSLib-0.30.0.gh.tar.gz 995826 BLAKE2B 58066b461794d424e646cd148f1c0379c22c17bee144611e4bda71c8410f2d4dbd172e5cad14ff1e33fc3e2a7293985c943eace6284d1830a2533abbe95ecf27 SHA512 2fdad8ac282d78181e2b7953f22db063f760c2f61682967c7d99ac8e12d62345168db978d9599a4093005f520968d4e97fc588f9a9b7d81a87894b08028d42d8
diff --git a/dev-python/owslib/owslib-0.30.0.ebuild b/dev-python/owslib/owslib-0.30.0.ebuild
new file mode 100644
index 000000000000..633e22c2ec54
--- /dev/null
+++ b/dev-python/owslib/owslib-0.30.0.ebuild
@@ -0,0 +1,65 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..12} )
+
+inherit distutils-r1
+
+MY_P=OWSLib-${PV}
+DESCRIPTION="Library for client programming with Open Geospatial Consortium web service"
+HOMEPAGE="
+ https://geopython.github.io/OWSLib/
+ https://github.com/geopython/owslib/
+ https://pypi.org/project/OWSLib/
+"
+SRC_URI="
+ https://github.com/geopython/${PN}/archive/${PV}.tar.gz
+ -> ${MY_P}.gh.tar.gz
+"
+S=${WORKDIR}/${MY_P}
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+RESTRICT="test"
+PROPERTIES="test_network"
+
+RDEPEND="
+ dev-python/lxml[${PYTHON_USEDEP}]
+ dev-python/python-dateutil[${PYTHON_USEDEP}]
+ dev-python/pytz[${PYTHON_USEDEP}]
+ dev-python/pyyaml[${PYTHON_USEDEP}]
+ dev-python/requests[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/pillow[${PYTHON_USEDEP}]
+ )
+"
+
+EPYTEST_XDIST=1
+distutils_enable_tests pytest
+
+EPYTEST_DESELECT=(
+ # connection errors
+ tests/test_wfs_generic.py::test_xmlfilter_wfs_110
+ tests/test_wfs_generic.py::test_xmlfilter_wfs_200
+ tests/test_ogcapi_records_pycsw.py::test_ogcapi_records_pycsw
+ tests/test_opensearch_pycsw.py::test_opensearch_creodias
+ tests/test_ows_interfaces.py::test_ows_interfaces_csw
+ tests/test_csw3_pycsw.py::test_csw_pycsw
+ tests/test_csw_pycsw.py::test_csw_pycsw
+ tests/test_csw_pycsw_skip_caps.py::test_csw_pycsw_skip_caps
+ # different output from remote service, sigh
+ tests/test_ogcapi_processes_pygeoapi.py::test_ogcapi_processes_pygeoapi
+ # TODO
+ tests/test_remote_metadata.py::TestOffline::test_wfs_{110,200}_remotemd_parse_{all,single}
+ tests/test_remote_metadata.py::TestOffline::test_wms_130_remotemd_parse_{all,single}
+)
+
+python_test() {
+ epytest -o addopts=
+}