summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2018-04-03 19:39:06 +0200
committerMichał Górny <mgorny@gentoo.org>2018-04-03 21:39:16 +0200
commit807880d444fb48efe1f91503b9de511cd868efe0 (patch)
tree0b98595cb1fcd954fb55825bd561a83f2d3d31e2
parentdev-python/unidecode: Drop maintainership. (diff)
downloadgentoo-807880d4.tar.gz
gentoo-807880d4.tar.bz2
gentoo-807880d4.zip
sys-libs/compiler-rt: Fix calling lit with llvm-6+ macros
-rw-r--r--sys-libs/compiler-rt/compiler-rt-5.0.1.ebuild12
1 files changed, 10 insertions, 2 deletions
diff --git a/sys-libs/compiler-rt/compiler-rt-5.0.1.ebuild b/sys-libs/compiler-rt/compiler-rt-5.0.1.ebuild
index b4861d13427b..76c9139801b1 100644
--- a/sys-libs/compiler-rt/compiler-rt-5.0.1.ebuild
+++ b/sys-libs/compiler-rt/compiler-rt-5.0.1.ebuild
@@ -85,9 +85,17 @@ src_configure() {
fi
if use test; then
- mycmakeargs+=(
- -DLIT_COMMAND="${EPREFIX}/usr/bin/lit"
+ if has_version '>=sys-devel/llvm-6'; then
+ mycmakeargs+=(
+ -DLLVM_EXTERNAL_LIT="${EPREFIX}/usr/bin/lit"
+ )
+ else
+ mycmakeargs+=(
+ -DLIT_COMMAND="${EPREFIX}"/usr/bin/lit
+ )
+ fi
+ mycmakeargs+=(
-DCOMPILER_RT_TEST_COMPILER="${EPREFIX}/usr/lib/llvm/${CLANG_SLOT}/bin/clang"
-DCOMPILER_RT_TEST_CXX_COMPILER="${EPREFIX}/usr/lib/llvm/${CLANG_SLOT}/bin/clang++"
)