summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLars Wendler <polynomial-c@gentoo.org>2019-03-24 22:39:23 +0100
committerLars Wendler <polynomial-c@gentoo.org>2019-03-24 22:40:49 +0100
commit8081ea9be17ec027df0fcf16b428b5050284f6a7 (patch)
treed6ea10778a43ba3916caeafcaf51fe881a1e9c68
parentapp-editors/nano: Bump to version 4.0 (diff)
downloadgentoo-8081ea9b.tar.gz
gentoo-8081ea9b.tar.bz2
gentoo-8081ea9b.zip
app-editors/nano: Synced live ebuild.
Package-Manager: Portage-2.3.62, Repoman-2.3.12 Signed-off-by: Lars Wendler <polynomial-c@gentoo.org>
-rw-r--r--app-editors/nano/nano-9999.ebuild17
1 files changed, 7 insertions, 10 deletions
diff --git a/app-editors/nano/nano-9999.ebuild b/app-editors/nano/nano-9999.ebuild
index f4eec8c7c12a..aa130516a9a2 100644
--- a/app-editors/nano/nano-9999.ebuild
+++ b/app-editors/nano/nano-9999.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2018 Gentoo Foundation
+# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
@@ -9,7 +9,7 @@ if [[ ${PV} == "9999" ]] ; then
inherit git-r3 autotools
else
MY_P="${PN}-${PV/_}"
- SRC_URI="https://www.nano-editor.org/dist/v${PV:0:3}/${MY_P}.tar.gz"
+ SRC_URI="https://www.nano-editor.org/dist/v${PV:0:1}/${MY_P}.tar.gz"
KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~ppc-aix ~amd64-fbsd ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~m68k-mint ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
fi
@@ -27,10 +27,11 @@ LIB_DEPEND=">=sys-libs/ncurses-5.9-r1:0=[unicode?]
!ncurses? ( slang? ( sys-libs/slang[static-libs(+)] ) )"
RDEPEND="!static? ( ${LIB_DEPEND//\[static-libs(+)]} )"
DEPEND="${RDEPEND}
+ static? ( ${LIB_DEPEND} )"
+BDEPEND="
nls? ( sys-devel/gettext )
virtual/pkgconfig
- static? ( ${LIB_DEPEND} )"
-
+"
src_prepare() {
default
if [[ ${PV} == "9999" ]] ; then
@@ -46,7 +47,6 @@ src_configure() {
$(use_enable !minimal color)
$(use_enable !minimal multibuffer)
$(use_enable !minimal nanorc)
- --disable-wrapping-as-root
$(use_enable magic libmagic)
$(use_enable spell speller)
$(use_enable justify)
@@ -56,16 +56,13 @@ src_configure() {
$(use_enable minimal tiny)
$(usex ncurses --without-slang $(use_with slang))
)
- case ${CHOST} in
- *-gnu*|*-uclibc*) myconf+=( "--with-wordbounds" ) ;; #467848
- esac
econf "${myconf[@]}"
}
src_install() {
default
# don't use "${ED}" here or things break (#654534)
- rm -r "${D%/}"/trash || die
+ rm -r "${D}"/trash || die
dodoc doc/sample.nanorc
docinto html
@@ -76,7 +73,7 @@ src_install() {
# Enable colorization by default.
sed -i \
-e '/^# include /s:# *::' \
- "${ED%/}"/etc/nanorc || die
+ "${ED}"/etc/nanorc || die
fi
dosym ../../bin/nano /usr/bin/nano