summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick McLean <patrick.mclean@sony.com>2019-12-03 11:10:17 -0800
committerPatrick McLean <chutzpah@gentoo.org>2019-12-03 11:13:39 -0800
commit80a58571d612199110847b79431f4a263097e5bf (patch)
tree9bfbfe847898ab55d2b30dd7a9cfff698e9e0096
parentdev-python/characteristic-14.3.0-r3: revbump, fix tests, add py38 (diff)
downloadgentoo-80a58571.tar.gz
gentoo-80a58571.tar.bz2
gentoo-80a58571.zip
dev-python/characteristic: Add RESTRICT="!test? ( test )"
Copyright: Sony Interactive Entertainment Inc. Package-Manager: Portage-2.3.80, Repoman-2.3.19 Signed-off-by: Patrick McLean <chutzpah@gentoo.org>
-rw-r--r--dev-python/characteristic/characteristic-14.3.0-r1.ebuild2
-rw-r--r--dev-python/characteristic/characteristic-14.3.0-r2.ebuild2
2 files changed, 4 insertions, 0 deletions
diff --git a/dev-python/characteristic/characteristic-14.3.0-r1.ebuild b/dev-python/characteristic/characteristic-14.3.0-r1.ebuild
index a3a39944ebe7..ca90563a2e66 100644
--- a/dev-python/characteristic/characteristic-14.3.0-r1.ebuild
+++ b/dev-python/characteristic/characteristic-14.3.0-r1.ebuild
@@ -22,6 +22,8 @@ DEPEND="
test? ( dev-python/pytest[${PYTHON_USEDEP}] )
doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )"
+RESTRICT="!test? ( test )"
+
python_prepare_all() {
# Prevent un-needed download during build
sed -e "/^ 'sphinx.ext.intersphinx',/d" -i docs/conf.py || die
diff --git a/dev-python/characteristic/characteristic-14.3.0-r2.ebuild b/dev-python/characteristic/characteristic-14.3.0-r2.ebuild
index 6a8425596f9d..d11fc76b6bd1 100644
--- a/dev-python/characteristic/characteristic-14.3.0-r2.ebuild
+++ b/dev-python/characteristic/characteristic-14.3.0-r2.ebuild
@@ -22,6 +22,8 @@ DEPEND="
test? ( dev-python/pytest[${PYTHON_USEDEP}] )
doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )"
+RESTRICT="!test? ( test )"
+
python_prepare_all() {
# Prevent un-needed download during build
sed -e "/^ 'sphinx.ext.intersphinx',/d" -i docs/conf.py || die