summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-10-16 21:30:15 +0200
committerMichał Górny <mgorny@gentoo.org>2021-10-16 21:30:15 +0200
commit80a882b3af5d271464bafbef92ba66c125485af5 (patch)
treed76746eb46d8992939f22a0d1a8821434bbf295d
parentdev-python/lunr: Bump to 0.6.1 (diff)
downloadgentoo-80a882b3.tar.gz
gentoo-80a882b3.tar.bz2
gentoo-80a882b3.zip
dev-python/pyjwt: Bump to 2.3.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/pyjwt/Manifest1
-rw-r--r--dev-python/pyjwt/pyjwt-2.3.0.ebuild29
2 files changed, 30 insertions, 0 deletions
diff --git a/dev-python/pyjwt/Manifest b/dev-python/pyjwt/Manifest
index 2bb4d7ca4ee3..6fc93fb5fbaf 100644
--- a/dev-python/pyjwt/Manifest
+++ b/dev-python/pyjwt/Manifest
@@ -1,3 +1,4 @@
DIST PyJWT-1.7.1.tar.gz 41979 BLAKE2B 5604b309838b2dfb2f95e18e291c43703954664aa8acb7439072f002c1c8a1e49ff2c21d907be77a4d2f86e695ec71970d550aad2541252ac85bd7133e300b28 SHA512 70cd38127b6848933992c8b88303725ef71bfb430ad42eb63247e549b0bdab2a194137349d43ab02a1c97212dbc89f447ee3f0c5403dd14632b8b4b6b9235fc4
DIST PyJWT-2.1.0.tar.gz 60092 BLAKE2B 59bde5f73558c74c964136ce0e8e9b5db6b76d226805fdb8aa8f201f00dceed0036693aa9295fa0ebac03c8fdac29a28f2aa79c697155c0ca744d1549e9bb47a SHA512 d701919c6cf06acb45cb0762a4ab7cc5e6ea247fbc0de80d0efdd1fc4b966c0d27c7400869858bbdc457b200586635aeefa8a38b85db818df6a8713f9bda8ab8
DIST PyJWT-2.2.0.tar.gz 62200 BLAKE2B d527442cfafb8b540062f879e7c4a4f15acd9d88ff472764cfc077a220f42bd56e13d2aca9660008a118a9232071a45157c684f95987771c38cc631ee4745961 SHA512 e1cd8ba4fbde2adc906e18b04a925101f28091b4b23e39a1335ca6b933ab63132d07b2a4865399216ada17285b09f03bcf7fd1a12c238e7d4f15e7c9c1e32c75
+DIST PyJWT-2.3.0.tar.gz 62279 BLAKE2B 0f4cea0cee2461e5f829b2bba40fb6d2646d5bccaa8e6b2d26ba7379386a64dc9f5204ea607edec98fc0102facf3cc5595e5e97523e9a567e0cf0b072542a3f5 SHA512 c6a1d8c3ce87d2122aa4ce4e19c5d2683aeffae6fb29b20fa17e2dfb1a07faf721beb8ca390d3acdeb85a1476025ca5af4fcdb1019f84c8c1bf229246a7aafe3
diff --git a/dev-python/pyjwt/pyjwt-2.3.0.ebuild b/dev-python/pyjwt/pyjwt-2.3.0.ebuild
new file mode 100644
index 000000000000..df78ba88b34c
--- /dev/null
+++ b/dev-python/pyjwt/pyjwt-2.3.0.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..10} )
+inherit distutils-r1 optfeature
+
+MY_PN="PyJWT"
+DESCRIPTION="JSON Web Token implementation in Python"
+HOMEPAGE="https://github.com/jpadilla/pyjwt/ https://pypi.org/project/PyJWT/"
+SRC_URI="mirror://pypi/${MY_PN:0:1}/${MY_PN}/${MY_PN}-${PV}.tar.gz"
+S="${WORKDIR}"/${MY_PN}-${PV}
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~riscv ~sparc ~x86 ~amd64-linux ~x86-linux"
+
+RDEPEND="!dev-python/python-jwt"
+BDEPEND="
+ test? (
+ >=dev-python/cryptography-3.3.1[${PYTHON_USEDEP}]
+ )"
+
+distutils_enable_tests pytest
+
+pkg_postinst() {
+ optfeature "cryptography" dev-python/cryptography
+}