summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJaco Kroon <jaco@uls.co.za>2021-11-11 15:29:02 +0200
committerSam James <sam@gentoo.org>2021-11-12 01:21:21 +0000
commit80b0cd235fabed1caaf20c3718818a39b08f90ec (patch)
tree50b4d787c27474e4471f60304b35bf99ceea81fb
parentdev-perl/X11-Protocol-Other: Version 31, required by newer clusterssh. (diff)
downloadgentoo-80b0cd235fabed1caaf20c3718818a39b08f90ec.tar.gz
gentoo-80b0cd235fabed1caaf20c3718818a39b08f90ec.tar.bz2
gentoo-80b0cd235fabed1caaf20c3718818a39b08f90ec.zip
net-misc/clusterssh: Bump to 4.16.
About versioning: https://wiki.gentoo.org/wiki/Project:Perl/Version-Scheme Right, so with clusterssh using X.YY_ZZ, it's impossible to go larger than 99 already. As such, the benefit of using 4.160 (and then using DIST_VERSION to wangle that back to 4.16 doesn't make sense for me). Currently there is no third digit here, so in a future version I'll set it up to double op on the versions, eg, 5.0 will likely be 5.00 upstream, and 5.0.1 or 4.16.1 will be 5.00_01 or 4.16.01 upstream (which can be dealt with smartly using sprintf constructing DIST_VERSION). Closes: https://bugs.gentoo.org/598420 Closes: https://bugs.gentoo.org/819306 Closes: https://bugs.gentoo.org/775947 Bug: https://bugs.gentoo.org/768105 Package-Manager: Portage-3.0.28, Repoman-3.0.3 Signed-off-by: Jaco Kroon <jaco@uls.co.za> Signed-off-by: Sam James <sam@gentoo.org>
-rw-r--r--net-misc/clusterssh/Manifest1
-rw-r--r--net-misc/clusterssh/clusterssh-4.16.ebuild48
2 files changed, 49 insertions, 0 deletions
diff --git a/net-misc/clusterssh/Manifest b/net-misc/clusterssh/Manifest
index d260acf128db..6a17d252e441 100644
--- a/net-misc/clusterssh/Manifest
+++ b/net-misc/clusterssh/Manifest
@@ -1,2 +1,3 @@
DIST App-ClusterSSH-4.01_05.tar.gz 71502 BLAKE2B f9e1f9de36173c766a382660e34adee3005a64550a90cafe59101fd3f4b66307990e254334fb270398c9e36a9d27657a27e7348b1223a7ccef04181f8c88809b SHA512 4b63b91684c981a28871e5264502c66435b531ae3c4bad2eab2571f8b237d43e5f45ed93d036e7497c713f2982a110d93a3055ae0004d4f33e7786df9aa56ff8
DIST App-ClusterSSH-4.03_06.tar.gz 81476 BLAKE2B 6b513cb86fd4827eb510dd26ded9aa2d45ac1fe484dc10b8cb841c8b1fb50c7f279cbc6a63e817acbbf66e4aea5faa4f32cc612c387d018bf09abb18919fd7d6 SHA512 87dff4c0445436c10929bcf30a9295deb6ddacca16939091fdab0cf67765c77706745ce8e738145ea6c67ec06093567b7668e4387a72b48018f8e173da5709b4
+DIST App-ClusterSSH-4.16.tar.gz 96151 BLAKE2B c0b4ee36f42cb26853c264686fa6084133e0a75f9dba6e7233e341a2dedbb3c41642dd255bf6fa01b7285c9c3edd43485d3014b6d41957d6476382dcd00866a2 SHA512 3d4fc2aa681ea815020375bb3bb0f9a070e1638c5a4e38b1b279c58f9644a568bb687e0e611919afa48a32b44ff4e25cd5661c7d1330978f851bc506282f020e
diff --git a/net-misc/clusterssh/clusterssh-4.16.ebuild b/net-misc/clusterssh/clusterssh-4.16.ebuild
new file mode 100644
index 000000000000..df1418c856a5
--- /dev/null
+++ b/net-misc/clusterssh/clusterssh-4.16.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DIST_AUTHOR="DUNCS"
+DIST_NAME="App-ClusterSSH"
+#DIST_VERSION="$(ver_cut 1-2)"
+
+#die "|$(ver_cut 1-2)_$(ver_cut 3)|"
+inherit perl-module
+
+DESCRIPTION="Concurrent Multi-Server Terminal Access"
+HOMEPAGE="https://github.com/duncs/clusterssh"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ dev-perl/Config-Simple
+ dev-perl/Exception-Class
+ dev-perl/Readonly
+ dev-perl/Sort-Naturally
+ dev-perl/Test-DistManifest
+ dev-perl/Test-Pod
+ dev-perl/Test-Pod-Coverage
+ dev-perl/Test-Trap
+ dev-perl/Tk
+ dev-perl/Try-Tiny
+ dev-perl/X11-Protocol
+ dev-perl/X11-Protocol-Other
+ dev-perl/XML-Simple
+ x11-apps/xlsfonts
+ x11-terms/xterm
+ "
+BDEPEND="
+ ${RDEPEND}
+ dev-perl/CPAN-Changes
+ dev-perl/File-Slurp
+ dev-perl/File-Which
+ dev-perl/Module-Build
+ dev-perl/Test-Differences
+ dev-perl/Test-Pod"
+
+SRC_TEST="do parallel"