summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarek Szuba <marecki@gentoo.org>2021-04-22 18:31:54 +0200
committerMarek Szuba <marecki@gentoo.org>2021-04-22 18:51:23 +0200
commit80b996105755303e377cedf2bd6ae85ca35791ee (patch)
tree5ed92faa6348bc8f96b856c9cf372e3e35dfa1b3
parentdev-vcs/pre-commit: add 2.12.1 (diff)
downloadgentoo-80b996105755303e377cedf2bd6ae85ca35791ee.tar.gz
gentoo-80b996105755303e377cedf2bd6ae85ca35791ee.tar.bz2
gentoo-80b996105755303e377cedf2bd6ae85ca35791ee.zip
dev-python/pyopencl: add 2021.1.6
Signed-off-by: Marek Szuba <marecki@gentoo.org>
-rw-r--r--dev-python/pyopencl/Manifest1
-rw-r--r--dev-python/pyopencl/pyopencl-2021.1.6.ebuild56
2 files changed, 57 insertions, 0 deletions
diff --git a/dev-python/pyopencl/Manifest b/dev-python/pyopencl/Manifest
index 5d7a2e38fb34..ebb42e37bec1 100644
--- a/dev-python/pyopencl/Manifest
+++ b/dev-python/pyopencl/Manifest
@@ -1 +1,2 @@
DIST pyopencl-2021.1.3.tar.gz 447070 BLAKE2B fcd8c5d06de9c14a7bcf3c3d37f89cb208adf0225cc88a081aefc86aac82a99026183f2c9975f34cd8247f784335e4ba6c0a09164ce01e527123b5c1dd952a76 SHA512 8799e73b3b1596387f619fd997f643228679fb1d9ab5ce6704da9df51922f96229efc98ab6b7a7361234848078b15bc67946a4188f4d17cb8760040b48b346e8
+DIST pyopencl-2021.1.6.tar.gz 448568 BLAKE2B aea3f6f28d3377b0b8aa7b6c726252299039663e9684316f48c5e875be9d25600582a4af931cacda3fa39834c000a00e2d29720ed6a3cca8e46141ee189107a0 SHA512 320b521e9ed05e0c183d0535b81f27355bdb21577a8a8ba254599a9e853cbe6e0ef44ee6e5be742b44fa1e1e5005732643217f327e4b347845ee6c706db5da87
diff --git a/dev-python/pyopencl/pyopencl-2021.1.6.ebuild b/dev-python/pyopencl/pyopencl-2021.1.6.ebuild
new file mode 100644
index 000000000000..a9a305e869f5
--- /dev/null
+++ b/dev-python/pyopencl/pyopencl-2021.1.6.ebuild
@@ -0,0 +1,56 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{7..9} )
+
+inherit distutils-r1
+
+DESCRIPTION="Python wrapper for OpenCL"
+HOMEPAGE="https://mathema.tician.de/software/pyopencl/
+ https://pypi.org/project/pyopencl/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="examples opengl"
+
+COMMON="dev-python/numpy[${PYTHON_USEDEP}]"
+RDEPEND="${COMMON}
+ >=dev-python/appdirs-1.4.0[${PYTHON_USEDEP}]
+ >=dev-python/decorator-3.2.0[${PYTHON_USEDEP}]
+ dev-python/mako[${PYTHON_USEDEP}]
+ >=dev-python/pytools-2017.6[${PYTHON_USEDEP}]
+ >=dev-python/six-1.9.0[${PYTHON_USEDEP}]
+ >=virtual/opencl-2"
+DEPEND="${COMMON}
+ dev-python/pybind11[${PYTHON_USEDEP}]"
+
+# The test suite fails if there are no OpenCL platforms available, and
+# even if there is one (which requires the presence of both an OpenCL
+# runtime *and* hardware supported by it - simply emerging any runtime
+# is not enough) the vast majority of tests end up skipped because by
+# default the portage user hasn't got sufficient privileges to talk
+# to the GPU.
+RESTRICT="test"
+
+python_configure_all() {
+ local myconf=()
+ if use opengl; then
+ myconf+=(--cl-enable-gl)
+ fi
+
+ "${EPYTHON}" configure.py \
+ "${myconf[@]}"
+}
+
+python_install_all() {
+ if use examples; then
+ dodoc -r examples
+ docompress -x /usr/share/doc/${PF}/examples
+ fi
+
+ distutils-r1_python_install_all
+}