summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAaron Bauman <bman@gentoo.org>2018-05-26 14:52:21 -0400
committerAaron Bauman <bman@gentoo.org>2018-05-26 16:31:26 -0400
commit80bdc3c593f7e3a4f881993ce5f329c4ef10bf7a (patch)
treef12e77c8f1c01c8e6a10b381963c24c07142e16c
parentmedia-libs/fnlib: bump EAPI and drop eutils (diff)
downloadgentoo-80bdc3c593f7e3a4f881993ce5f329c4ef10bf7a.tar.gz
gentoo-80bdc3c593f7e3a4f881993ce5f329c4ef10bf7a.tar.bz2
gentoo-80bdc3c593f7e3a4f881993ce5f329c4ef10bf7a.zip
app-shells/pdsh: drop EAPI=2
Package-Manager: Portage-2.3.40, Repoman-2.3.9
-rw-r--r--app-shells/pdsh/pdsh-2.26.ebuild51
1 files changed, 0 insertions, 51 deletions
diff --git a/app-shells/pdsh/pdsh-2.26.ebuild b/app-shells/pdsh/pdsh-2.26.ebuild
deleted file mode 100644
index e67fe3b5f243..000000000000
--- a/app-shells/pdsh/pdsh-2.26.ebuild
+++ /dev/null
@@ -1,51 +0,0 @@
-# Copyright 1999-2017 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI="2"
-
-DESCRIPTION="A high-performance, parallel remote shell utility"
-HOMEPAGE="https://computing.llnl.gov/linux/pdsh.html"
-SRC_URI="mirror://sourceforge/${PN}/${P}.tar.bz2"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE="crypt readline rsh static-libs test"
-
-RDEPEND="crypt? ( net-misc/openssh )
- rsh? ( net-misc/netkit-rsh )
- readline? ( sys-libs/readline )"
-DEPEND="${RDEPEND}
- test? ( dev-util/dejagnu )"
-
-pkg_setup() {
- local m
- local valid_modules=":xcpu:ssh:exec:qshell:genders:nodeupdown:mrsh:mqshell:dshgroups:netgroup:"
-
- PDSH_MODULE_LIST="${PDSH_MODULE_LIST:-netgroup}"
- MODULE_CONFIG=""
- for m in ${PDSH_MODULE_LIST}; do
- if [[ "${valid_modules}" == *:${m}:* ]]; then
- MODULE_CONFIG="${MODULE_CONFIG} --with-${m}"
- fi
- done
-
- elog "Building ${PF} with the following modules:"
- elog " ${PDSH_MODULE_LIST}"
- elog "This list can be changed in /etc/portage/make.conf by setting"
- elog "PDSH_MODULE_LIST=\"module1 module2...\""
-}
-
-src_configure() {
- econf ${MODULE_CONFIG} \
- --with-machines \
- --enable-shared \
- $(use_with crypt ssh) \
- $(use_with rsh) \
- $(use_with readline) \
- $(use_enable static-libs static)
-}
-
-src_install() {
- emake DESTDIR="${D}" install || die "emake install failed"
-}