summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2021-03-04 03:24:31 +0000
committerSam James <sam@gentoo.org>2021-03-04 03:49:21 +0000
commit80eca95fd132352b42da89a0f0bb11862f3a48d3 (patch)
treee65471c364120f32b8ff262b3478f65048aa17bb
parentdev-python/flask-sphinx-themes: update upstream metadata (diff)
downloadgentoo-80eca95fd132352b42da89a0f0bb11862f3a48d3.tar.gz
gentoo-80eca95fd132352b42da89a0f0bb11862f3a48d3.tar.bz2
gentoo-80eca95fd132352b42da89a0f0bb11862f3a48d3.zip
dev-python/flask-restful: add Python 3.9
Signed-off-by: Sam James <sam@gentoo.org>
-rw-r--r--dev-python/flask-restful/flask-restful-0.3.8.ebuild13
1 files changed, 7 insertions, 6 deletions
diff --git a/dev-python/flask-restful/flask-restful-0.3.8.ebuild b/dev-python/flask-restful/flask-restful-0.3.8.ebuild
index 1554dcb94c6d..eea5a35b47ce 100644
--- a/dev-python/flask-restful/flask-restful-0.3.8.ebuild
+++ b/dev-python/flask-restful/flask-restful-0.3.8.ebuild
@@ -1,8 +1,9 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
-PYTHON_COMPAT=( python3_{7,8} )
+
+PYTHON_COMPAT=( python3_{7,8,9} )
inherit distutils-r1
@@ -23,19 +24,19 @@ RDEPEND="
>=dev-python/six-1.3.0[${PYTHON_USEDEP}]
dev-python/pytz[${PYTHON_USEDEP}]
"
-DEPEND="
+BDEPEND="
test? (
dev-python/mock[${PYTHON_USEDEP}]
)
"
-distutils_enable_sphinx docs
-distutils_enable_tests nose
-
PATCHES=(
"${FILESDIR}"/flask-restful-0.3.8-werkzeug.patch
)
+distutils_enable_sphinx docs
+distutils_enable_tests nose
+
python_install_all() {
use examples && dodoc -r examples
local DOCS=( AUTHORS.md CHANGES.md CONTRIBUTING.md README.md )