summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2022-01-09 19:00:09 +0100
committerAndreas Sturmlechner <asturm@gentoo.org>2022-01-09 20:11:07 +0100
commit80ef3604cac64727db2e1380797fc3c60d0529ca (patch)
tree5f96aa178ca5abb266d903d39ae29d7b5441053b
parentapp-containers/flannel: Bump to version 0.16.1 (diff)
downloadgentoo-80ef3604.tar.gz
gentoo-80ef3604.tar.bz2
gentoo-80ef3604.zip
net-libs/wvstreams: Drop hopelessly outdated 9999 ebuild
A single commit was made in 2018 and nothing after that. Package-Manager: Portage-3.0.30, Repoman-3.0.3 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
-rw-r--r--net-libs/wvstreams/files/wvstreams-99999-openssl-ldflags.patch10
-rw-r--r--net-libs/wvstreams/files/wvstreams-99999-soname.patch11
-rw-r--r--net-libs/wvstreams/wvstreams-99999.ebuild93
3 files changed, 0 insertions, 114 deletions
diff --git a/net-libs/wvstreams/files/wvstreams-99999-openssl-ldflags.patch b/net-libs/wvstreams/files/wvstreams-99999-openssl-ldflags.patch
deleted file mode 100644
index 0bf2bc4a7b02..000000000000
--- a/net-libs/wvstreams/files/wvstreams-99999-openssl-ldflags.patch
+++ /dev/null
@@ -1,10 +0,0 @@
---- a/config.ac
-+++ b/config.ac
-@@ -444,7 +444,6 @@
- if test "$with_openssl" != "no"; then
- if test "$with_openssl" != ""; then
- WV_APPEND(CPPFLAGS, [-I$with_openssl/include])
-- WV_APPEND(LDFLAGS, [-L$with_openssl])
- fi
- AC_CHECK_HEADERS(openssl/ssl.h,, [with_openssl=no],
- [#define OPENSSL_NO_KRB5])
diff --git a/net-libs/wvstreams/files/wvstreams-99999-soname.patch b/net-libs/wvstreams/files/wvstreams-99999-soname.patch
deleted file mode 100644
index 9dd0d8ab8260..000000000000
--- a/net-libs/wvstreams/files/wvstreams-99999-soname.patch
+++ /dev/null
@@ -1,11 +0,0 @@
---- a/default.so.do
-+++ b/default.so.do
-@@ -47,7 +47,7 @@
- redo-ifchange "$OUT/$2.a"
- ln -s $2.a "$sofile"
- else
-- $CXX -o "$sofile" -shared \
-+ $CXX -o "$sofile" -shared -Wl,-soname,$sofile \
- $zdefs \
- $LDFLAGS \
- $obj $libdep $libs
diff --git a/net-libs/wvstreams/wvstreams-99999.ebuild b/net-libs/wvstreams/wvstreams-99999.ebuild
deleted file mode 100644
index 11e465328157..000000000000
--- a/net-libs/wvstreams/wvstreams-99999.ebuild
+++ /dev/null
@@ -1,93 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-AT_NOELIBTOOLIZE=yes
-inherit autotools flag-o-matic git-r3 multiprocessing toolchain-funcs out-of-source
-
-DESCRIPTION="A network programming library in C++"
-HOMEPAGE="https://github.com/apenwarr/wvstreams"
-EGIT_REPO_URI="https://github.com/apenwarr/wvstreams"
-
-LICENSE="GPL-2"
-SLOT="0/5.0"
-KEYWORDS=""
-IUSE="+dbus debug doc pam static-libs +zlib"
-
-RDEPEND="
- <dev-libs/openssl-1.1:0=
- sys-libs/readline:0=
- sys-libs/zlib
- virtual/libcrypt:=
- dbus? ( >=sys-apps/dbus-1.4.20 )
- pam? ( sys-libs/pam )
-"
-DEPEND="
- ${RDEPEND}
- dev-util/redo
- virtual/pkgconfig
- doc? ( app-doc/doxygen )
-"
-PATCHES=(
- "${FILESDIR}"/${PN}-99999-openssl-ldflags.patch
- "${FILESDIR}"/${PN}-99999-soname.patch
-)
-
-src_prepare() {
- sed -i -e 's|-pre||g' config.ac || die
-
- default
-
- ln -s config.ac configure.ac || die
- eautoreconf
-}
-
-my_src_configure() {
- append-flags -fno-strict-aliasing
- append-flags -fno-tree-dce -fno-optimize-sibling-calls #421375
-
- tc-export AR CC CXX
-
- econf \
- $(use_enable debug) \
- $(use_with dbus) \
- $(use_with pam) \
- $(use_with zlib) \
- --cache-file="${BUILD_DIR}"/config.cache \
- --disable-optimization \
- --localstatedir=/var \
- --without-qt \
- --without-valgrind
-}
-
-my_src_compile() {
- redo -j$(makeopts_jobs) || die
-
- if use doc; then
- doxygen "${S}"/Doxyfile || die
- fi
-}
-
-my_src_test() {
- redo -j$(makeopts_jobs) test || die
-}
-
-my_src_install() {
- DESTDIR="${D}" redo -j$(makeopts_jobs) install || die
-
- local lib
- for lib in $(find "${BUILD_DIR}" -name '*.so' -type l | grep -v libwvstatic); do
- insinto /usr/$(get_libdir)/pkgconfig
- doins "${BUILD_DIR}"/pkgconfig/$(basename ${lib/.so}).pc
- done
-
- if use doc; then
- #the list of files is too big for dohtml -r Docs/doxy-html/*
- docinto html
- dodoc -r Docs/doxy-html/*
- fi
-
- if ! use static-libs; then
- find "${D}/usr/$(get_libdir)" -name '*.a' -delete || die
- fi
-}