summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlfredo Tupone <tupone@gentoo.org>2023-01-19 22:27:31 +0100
committerAlfredo Tupone <tupone@gentoo.org>2023-01-19 22:27:31 +0100
commit80f5f8abeb68bcc476e590bcfa1395eec11dc04d (patch)
tree4bed067ac9dc6d774dfe3994b6f1076ef19c7374
parentdev-ml/camlidl: fix compilation order (diff)
downloadgentoo-80f5f8abeb68bcc476e590bcfa1395eec11dc04d.tar.gz
gentoo-80f5f8abeb68bcc476e590bcfa1395eec11dc04d.tar.bz2
gentoo-80f5f8abeb68bcc476e590bcfa1395eec11dc04d.zip
dev-ml/camlidl: add 1.11
Signed-off-by: Alfredo Tupone <tupone@gentoo.org>
-rw-r--r--dev-ml/camlidl/Manifest1
-rw-r--r--dev-ml/camlidl/camlidl-1.11.ebuild66
2 files changed, 67 insertions, 0 deletions
diff --git a/dev-ml/camlidl/Manifest b/dev-ml/camlidl/Manifest
index fe60cb01eec5..5a8705c56ec1 100644
--- a/dev-ml/camlidl/Manifest
+++ b/dev-ml/camlidl/Manifest
@@ -1,2 +1,3 @@
DIST camlidl-1.05.tar.gz 100640 BLAKE2B 38cbcebd43ced26c44803608aabdacfbd33734357097a542ee2558223b9699d89cf7be388feba59630b10e4dc3977bffd08c669d3cf676d2136f54a6a8d52aab SHA512 e8857aca818a06f8c861e5f55dddd7e8e3ab1efae51647534460b4f092166709d86c6de1215c792a0489d668d72064ccfb7635e9a6d3854cd5a62f74541a9d18
DIST camlidl109.tar.gz 125697 BLAKE2B c42e418525b9681a0e7042aea46fb581a1ffa93be416a9214325883407a62bcad7e8fd7a20fd997640deb42ddca394605f5569bc8f363721b8955629459ff49e SHA512 6cab1fa6bc2afba9b97874520eed2887c4fd341b59735854b120aa1ec8822710d9ebfadd1fecff56e629d4a1af7ee73befe6440c5462493f8408bdae8519a1fa
+DIST camlidl111.tar.gz 182421 BLAKE2B 5bd4bf2e2eb73f632c5e99a271e13d6a1b4b815476f2a17aaa6a05a4ccf048f4c58b099219e46d36659711f0473dbf91d484d5dcb12ee2e08327afec92a66b66 SHA512 dfd99cb10ee96de4e8a9a2ee86834a33ce10ba362aea93a061c373336db872ddf4017f2601bc47d1662de2f5699e885166dc984a213ff1c4142d41d7c99d7a21
diff --git a/dev-ml/camlidl/camlidl-1.11.ebuild b/dev-ml/camlidl/camlidl-1.11.ebuild
new file mode 100644
index 000000000000..4706e7db2037
--- /dev/null
+++ b/dev-ml/camlidl/camlidl-1.11.ebuild
@@ -0,0 +1,66 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit toolchain-funcs
+
+DESCRIPTION="Stub code generator for OCaml"
+HOMEPAGE="https://github.com/xavierleroy/camlidl"
+SRC_URI="https://github.com/xavierleroy/${PN}/archive/${PN}$(ver_rs 0-1 '').tar.gz"
+
+LICENSE="QPL-1.0 LGPL-2"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~ppc ~x86 ~amd64-linux ~x86-linux"
+
+DEPEND=">=dev-lang/ocaml-3.10.2:=[ocamlopt]"
+RDEPEND="${DEPEND}"
+
+S="${WORKDIR}"/${PN}-${PN}$(ver_rs 0-1 '')
+
+PATCHES=(
+ "${FILESDIR}/nowarn.patch"
+)
+
+src_prepare() {
+ sed -i \
+ -e "s|ar rc|$(tc-getAR) rc|g" \
+ runtime/Makefile.unix \
+ || die
+ default
+}
+
+src_compile() {
+ # Use the UNIX makefile
+ libdir=$(ocamlc -where || die)
+
+ sed -i -e "s|OCAMLLIB=.*|OCAMLLIB=${libdir}|" config/Makefile.unix || die
+ sed -i -e "s|BINDIR=.*|BINDIR=${EPREFIX}/usr/bin|" config/Makefile.unix || die
+ ln -s Makefile.unix config/Makefile || die
+
+ # Make
+ emake depend
+ emake -j1 RANLIB="$(tc-getRANLIB)" CPP="$(tc-getPROG CPP cpp)"
+}
+
+src_test() {
+ einfo "Running tests..."
+ cd tests || die
+ emake CCPP="$(tc-getCXX)" CC="$(tc-getCC)"
+}
+
+src_install() {
+ libdir=$(ocamlc -where || die)
+ dodir "${libdir#${EPREFIX}}"/caml
+
+ dodir /usr/bin
+ dodir /usr/$(get_libdir)/ocaml/stublibs
+ # Install
+ emake BINDIR="${ED}/usr/bin" OCAMLLIB="${D}${libdir}" RANLIB="$(tc-getRANLIB)" install
+
+ # Add package header
+ sed -e "s/@VERSION/${P}/g" "${FILESDIR}/META.camlidl" > "${D}${libdir}/META.camlidl" || die
+
+ # Documentation
+ dodoc README Changes
+}