summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-07-08 08:08:21 +0200
committerMichał Górny <mgorny@gentoo.org>2023-07-08 09:30:03 +0200
commit80fa8eb106d936f6ee24f621a3c121632a0ce75b (patch)
tree7a441a6aed3704f06a0e0bf282a4481d54d5eda6
parentdev-python/async-lru: Bump to 2.0.3 (diff)
downloadgentoo-80fa8eb106d936f6ee24f621a3c121632a0ce75b.tar.gz
gentoo-80fa8eb106d936f6ee24f621a3c121632a0ce75b.tar.bz2
gentoo-80fa8eb106d936f6ee24f621a3c121632a0ce75b.zip
dev-python/importlib-resources: Bump to 6.0.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/importlib-resources/Manifest1
-rw-r--r--dev-python/importlib-resources/importlib-resources-6.0.0.ebuild46
2 files changed, 47 insertions, 0 deletions
diff --git a/dev-python/importlib-resources/Manifest b/dev-python/importlib-resources/Manifest
index 7cd8f9af9983..75ff8b79c797 100644
--- a/dev-python/importlib-resources/Manifest
+++ b/dev-python/importlib-resources/Manifest
@@ -1 +1,2 @@
DIST importlib_resources-5.12.0.tar.gz 39894 BLAKE2B bbae92bd62b54afc0093f8daa8f0fabaf18da7b2c9c578a2e6b6b7cc3207384e4fd037762c4ac8bc862900ac2da112a3b8ae236b1d3ca072c739f2d1ad3edd36 SHA512 00875d82cf3d2103872079ee2882c4000cc65141d97988265721cc6861a64dfe480e5c2191a2b22d0b9b9e42de1fc06d54f6d8eb4f37aaf91a819ee9306dc06f
+DIST importlib_resources-6.0.0.tar.gz 35570 BLAKE2B c71f0dbfe49eebd63c0e56e25f019cb30d9fbddd6e4db8fa739bd44d5c00f429bf732a1e2f2be74ebc051c020c0fc0a678cf8eb6c2b9b52e340abe1a62144aae SHA512 c7475b0be67bf8655998df78d2683a733f20e85eb4b03f04508b3408a8751e0b4a8fcbe695feb83144c9b6de6e4ba93dd3419647d1db2ad8d92ff7dbbf6970c4
diff --git a/dev-python/importlib-resources/importlib-resources-6.0.0.ebuild b/dev-python/importlib-resources/importlib-resources-6.0.0.ebuild
new file mode 100644
index 000000000000..2bf49ea9e1e8
--- /dev/null
+++ b/dev-python/importlib-resources/importlib-resources-6.0.0.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DISTUTILS_USE_PEP517=flit
+# This is a backport of importlib.resources that's present since py3.9.
+# However, the version in 3.9 is buggy, so matplotlib needs it on 3.9
+# as well.
+PYTHON_COMPAT=( pypy3 )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Read resources from Python packages"
+HOMEPAGE="
+ https://github.com/python/importlib_resources/
+ https://pypi.org/project/importlib-resources/
+"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~x64-macos ~x64-solaris"
+
+RDEPEND="
+ $(python_gen_cond_dep '
+ >=dev-python/zipp-3.7.0-r1[${PYTHON_USEDEP}]
+ ' 3.8 3.9)
+"
+
+distutils_enable_tests unittest
+
+src_configure() {
+ grep -q 'build-backend = "setuptools' pyproject.toml ||
+ die "Upstream changed build-backend, recheck"
+ # write a custom pyproject.toml to ease setuptools bootstrap
+ cat > pyproject.toml <<-EOF || die
+ [build-system]
+ requires = ["flit_core >=3.2,<4"]
+ build-backend = "flit_core.buildapi"
+
+ [project]
+ name = "importlib_resources"
+ version = "${PV}"
+ description = "Read resources from Python packages"
+ EOF
+}