summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2018-08-17 23:40:45 +0200
committerAndreas Sturmlechner <asturm@gentoo.org>2018-08-18 00:02:02 +0200
commit80fbdf3ca74c97e0b1435a178cbf5d7b60ade213 (patch)
treeb93a387f3c8283626e5e20eac196a354f19b97c3
parentmedia-sound/musescore: Fix build with Qt 5.11 (diff)
downloadgentoo-80fbdf3c.tar.gz
gentoo-80fbdf3c.tar.bz2
gentoo-80fbdf3c.zip
app-text/goldendict: Fix build with Qt 5.11
Reported-by: Viacheslav Ostroukh <slava@ostroukh.me> Tested-by: Viktor Levin <viklevin2@mail.ru> Closes: https://bugs.gentoo.org/662094 Package-Manager: Portage-2.3.46, Repoman-2.3.10
-rw-r--r--app-text/goldendict/files/goldendict-1.5.0-qt-5.11.patch56
-rw-r--r--app-text/goldendict/goldendict-1.5.0_rc2-r2.ebuild5
2 files changed, 60 insertions, 1 deletions
diff --git a/app-text/goldendict/files/goldendict-1.5.0-qt-5.11.patch b/app-text/goldendict/files/goldendict-1.5.0-qt-5.11.patch
new file mode 100644
index 000000000000..247ec52931b9
--- /dev/null
+++ b/app-text/goldendict/files/goldendict-1.5.0-qt-5.11.patch
@@ -0,0 +1,56 @@
+From 3d4a468b6c8cb154c88cf4592a5845973999dc29 Mon Sep 17 00:00:00 2001
+From: Abs62 <ottomann@yandex.ru>
+Date: Tue, 10 Apr 2018 18:44:43 +0300
+Subject: [PATCH] Qt5: Fix compilation with Qt 5.11 (issue #991)
+
+---
+ fulltextsearch.hh | 1 +
+ initializing.cc | 1 +
+ 2 files changed, 2 insertions(+)
+
+diff --git a/fulltextsearch.hh b/fulltextsearch.hh
+index da7e2943..adf9619f 100644
+--- a/fulltextsearch.hh
++++ b/fulltextsearch.hh
+@@ -6,6 +6,7 @@
+ #include <QRegExp>
+ #include <QAbstractListModel>
+ #include <QList>
++#include <QAction>
+
+ #include "dictionary.hh"
+ #include "ui_fulltextsearch.h"
+diff --git a/initializing.cc b/initializing.cc
+index 0db6909b..59e605d6 100644
+--- a/initializing.cc
++++ b/initializing.cc
+@@ -1,6 +1,7 @@
+ /* This file is (c) 2008-2012 Konstantin Isakov <ikm@goldendict.org>
+ * Part of GoldenDict. Licensed under GPLv3 or later, see the LICENSE file */
+
++#include <QIcon>
+ #include "initializing.hh"
+ #include <QCloseEvent>
+
+From a65967805ab424b299bdfa1d1f9c7ebb8a7fd517 Mon Sep 17 00:00:00 2001
+From: Perfect Gentleman <perfect007gentleman@gmail.com>
+Date: Wed, 11 Apr 2018 00:04:12 +0700
+Subject: [PATCH] Update groups_widgets.hh
+
+fixes https://github.com/goldendict/goldendict/issues/991
+---
+ groups_widgets.hh | 1 +
+ 1 file changed, 1 insertion(+)
+
+diff --git a/groups_widgets.hh b/groups_widgets.hh
+index ce442fa2..2064e3bb 100644
+--- a/groups_widgets.hh
++++ b/groups_widgets.hh
+@@ -8,6 +8,7 @@
+
+ #include <vector>
+
++#include <QAction>
+ #include <QListWidget>
+ #include <QSortFilterProxyModel>
+
diff --git a/app-text/goldendict/goldendict-1.5.0_rc2-r2.ebuild b/app-text/goldendict/goldendict-1.5.0_rc2-r2.ebuild
index 47c7916defc8..e25c25eb0628 100644
--- a/app-text/goldendict/goldendict-1.5.0_rc2-r2.ebuild
+++ b/app-text/goldendict/goldendict-1.5.0_rc2-r2.ebuild
@@ -48,7 +48,10 @@ DEPEND="${RDEPEND}
virtual/pkgconfig
"
-PATCHES=( "${FILESDIR}/${PN}-1.5.0-qtsingleapplication-unbundle.patch" )
+PATCHES=(
+ "${FILESDIR}/${PN}-1.5.0-qtsingleapplication-unbundle.patch"
+ "${FILESDIR}/${PN}-1.5.0-qt-5.11.patch"
+)
S="${WORKDIR}/${PN}-${MY_PV}"