summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2022-12-21 21:57:58 +0000
committerSam James <sam@gentoo.org>2022-12-21 22:25:22 +0000
commit8106ee9f3a672d93bca40a194eac864ab0fc7570 (patch)
tree46483775321c133320ba15f9accde049239a4911
parentapp-misc/countrycodes: add sourceforge upstream metadata (diff)
downloadgentoo-8106ee9f3a672d93bca40a194eac864ab0fc7570.tar.gz
gentoo-8106ee9f3a672d93bca40a194eac864ab0fc7570.tar.bz2
gentoo-8106ee9f3a672d93bca40a194eac864ab0fc7570.zip
dev-util/bear: drop 2.4.4-r1, 3.0.19
Bug: https://bugs.gentoo.org/886011 Signed-off-by: Sam James <sam@gentoo.org>
-rw-r--r--dev-util/bear/Manifest2
-rw-r--r--dev-util/bear/bear-2.4.4-r1.ebuild71
-rw-r--r--dev-util/bear/bear-3.0.19.ebuild91
3 files changed, 0 insertions, 164 deletions
diff --git a/dev-util/bear/Manifest b/dev-util/bear/Manifest
index b33a606156fb..ae15db499318 100644
--- a/dev-util/bear/Manifest
+++ b/dev-util/bear/Manifest
@@ -1,3 +1 @@
-DIST bear-2.4.4.tar.gz 50347 BLAKE2B 73fa332cf97413e55c588f8830806a26c6905299af902c6cf1f39fd576c6261690239c1b502b28b5a2aa24e5ca521c3f1dd58aacd60e00ece4fe1840f5656155 SHA512 4ee3fd5c846149029fe9e4104e2a0d0e318a15215aa80fc5dc376e22ebea510384b02d4d62765495343cab537bacd2b1b0130c00246e081feb4e543761a594e5
-DIST bear-3.0.19.tar.gz 125086 BLAKE2B 0c6a27359e8c88ab0dbaa3f5442a87efeaba4f6a9b8d0912ad026231421e2555a524b194a19972f549600951bc1f6620398c48338f7eac8850ba6c3969f2e6ac SHA512 688766a76cc3bee1dc82478d29d6e8754618f92633c842586fce95f2f1096764902ffd64a6f2f59101e58eba5472bf39ddb178c3dfcd48491fa4eb63d111585c
DIST bear-3.0.20.tar.gz 125393 BLAKE2B 826a774beeb0596038f69b345a3659fe58f897bdb1a63f5faeac1d4242ae3cf4bf346ab82d2f87934d0786e5c0d4e835837b838a62f5a92c28ffe5e6a3d6a900 SHA512 4cf0e648b73fd4c0ac109c4a853e203efccb34ac7373d6c2f3ee3d5089853b791008990df768871dfd1268324bcce97c44657b4c3a2d1383134cba3eaec40bdd
diff --git a/dev-util/bear/bear-2.4.4-r1.ebuild b/dev-util/bear/bear-2.4.4-r1.ebuild
deleted file mode 100644
index 08fbed8fe87a..000000000000
--- a/dev-util/bear/bear-2.4.4-r1.ebuild
+++ /dev/null
@@ -1,71 +0,0 @@
-# Copyright 2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-PYTHON_COMPAT=( python3_{7,8,9,10} )
-
-inherit bash-completion-r1 cmake python-single-r1
-
-DESCRIPTION="Build EAR generates a compilation database for clang tooling"
-HOMEPAGE="https://github.com/rizsotto/Bear"
-SRC_URI="https://github.com/rizsotto/Bear/archive/${PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="GPL-3+"
-SLOT="0"
-KEYWORDS="amd64 ~ppc64 x86"
-IUSE="test"
-
-REQUIRED_USE="${PYTHON_REQUIRED_USE}"
-
-DEPEND="test? (
- app-shells/bash
- $(python_gen_cond_dep '
- dev-python/lit[${PYTHON_USEDEP}]
- ')
-)"
-
-RDEPEND="${PYTHON_DEPS}"
-
-RESTRICT="!test? ( test )"
-
-S="${WORKDIR}/${P^}"
-
-src_configure() {
- local mycmakeargs=( -DUSE_SHELL_COMPLETION=OFF )
- cmake_src_configure
-}
-
-src_compile() {
- cmake_src_compile
- # need to fix it now, before tests are run
- python_fix_shebang "${BUILD_DIR}"/bear/bear
- python_fix_shebang test/functional/tools/cdb_diff.py
-}
-
-src_install() {
- cmake_src_install
- dobashcomp shell-completion/bash/bear
-}
-
-src_test() {
- if has sandbox ${FEATURES}; then
- ewarn "\'FEATURES=sandbox\' detected"
- ewarn "Bear overrides LD_PRELOAD and conflicts with gentoo sandbox"
- ewarn "Skipping tests"
- elif
- has usersandbox ${FEATURES}; then
- ewarn "\'FEATURES=usersandbox\' detected"
- ewarn "Skipping tests"
- elif
- has_version -b 'sys-devel/gcc-config[-native-symlinks]'; then
- ewarn "\'sys-devel/gcc-config[-native-symlinks]\' detected, tests call /usr/bin/cc directly (hardcoded)"
- ewarn "and will fail without generic cc symlink"
- ewarn "Skipping tests"
- else
- einfo "removing unwanted/unsupported/xfail tests"
- rm -v test/functional/cases/{end-to-end/scons.ft,intercept/cuda/successful_build.fts,run_pep8.ft} || die
- einfo "test may use optional tools if found: qmake gfortran"
- cmake_build check
- fi
-}
diff --git a/dev-util/bear/bear-3.0.19.ebuild b/dev-util/bear/bear-3.0.19.ebuild
deleted file mode 100644
index 9ac6d7e10574..000000000000
--- a/dev-util/bear/bear-3.0.19.ebuild
+++ /dev/null
@@ -1,91 +0,0 @@
-# Copyright 2020-2022 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-PYTHON_COMPAT=( python3_{8..11} )
-
-inherit cmake python-any-r1
-
-DESCRIPTION="Build EAR generates a compilation database for clang tooling"
-HOMEPAGE="https://github.com/rizsotto/Bear"
-SRC_URI="https://github.com/rizsotto/Bear/archive/${PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="GPL-3+"
-SLOT="0"
-KEYWORDS="~amd64 ~ppc64 ~riscv ~x86"
-IUSE="test"
-
-RDEPEND="
- >=dev-cpp/nlohmann_json-3.7.3:=
- >=dev-db/sqlite-3.14:=
- <dev-libs/libfmt-9.0.0:=
- dev-libs/protobuf:=
- >=dev-libs/spdlog-1.5
- >=net-libs/grpc-1.26:=
-"
-
-DEPEND="${RDEPEND}
- test? (
- >=dev-cpp/gtest-1.10
- )
-"
-
-BDEPEND="
- virtual/pkgconfig
- test? (
- sys-devel/libtool
- $(python_gen_any_dep '
- dev-python/lit[${PYTHON_USEDEP}]
- ')
- )
-"
-
-RESTRICT="!test? ( test )"
-
-S="${WORKDIR}/${P^}"
-
-pkg_setup() {
- use test && python-any-r1_pkg_setup
-}
-
-src_prepare() {
- cmake_src_prepare
- # Turn off testing before installation
- sed -i 's/TEST_BEFORE_INSTALL/TEST_EXCLUDE_FROM_MAIN/g' CMakeLists.txt || die
-}
-
-src_configure() {
- local mycmakeargs=(
- -DENABLE_UNIT_TESTS="$(usex test ON OFF)"
- -DENABLE_FUNC_TESTS="$(usex test ON OFF)"
- )
- cmake_src_configure
-}
-
-src_test() {
- if has sandbox ${FEATURES}; then
- ewarn "\'FEATURES=sandbox\' detected"
- ewarn "Bear overrides LD_PRELOAD and conflicts with gentoo sandbox"
- ewarn "Skipping tests"
- elif
- has usersandbox ${FEATURES}; then
- ewarn "\'FEATURES=usersandbox\' detected"
- ewarn "Skipping tests"
- elif
- has network-sandbox ${FEATURES}; then
- ewarn "\'FEATURES=network-sandbox\' detected"
- ewarn "Skipping tests"
- elif
- has_version -b 'sys-devel/gcc-config[-native-symlinks]'; then
- ewarn "\'sys-devel/gcc-config[-native-symlinks]\' detected, tests call /usr/bin/cc directly (hardcoded)"
- ewarn "and will fail without generic cc symlink"
- ewarn "Skipping tests"
- else
- einfo "test may use optional tools if found: qmake gfortran valgrind"
- # unit tests
- cmake_run_in "${BUILD_DIR}/subprojects/Build/BearSource" ctest --verbose
- # functional tests
- cmake_run_in "${BUILD_DIR}/subprojects/Build/BearTest" ctest --verbose
- fi
-}