summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2018-05-10 09:43:00 +0200
committerAndreas Sturmlechner <asturm@gentoo.org>2018-05-10 10:01:09 +0200
commit811b41c7bf7417326e393a1157ce6587b9f6f21e (patch)
tree79e049732139eaada94af72947f83b6802db6029
parentdev-util/kdevelop-python: Fix build with Qt 5.11 (diff)
downloadgentoo-811b41c7.tar.gz
gentoo-811b41c7.tar.bz2
gentoo-811b41c7.zip
dev-vcs/kdesvn: Fix build with Qt 5.11
Package-Manager: Portage-2.3.36, Repoman-2.3.9
-rw-r--r--dev-vcs/kdesvn/files/kdesvn-2.0.0-qt-5.11.patch25
-rw-r--r--dev-vcs/kdesvn/kdesvn-2.0.0.ebuild3
2 files changed, 27 insertions, 1 deletions
diff --git a/dev-vcs/kdesvn/files/kdesvn-2.0.0-qt-5.11.patch b/dev-vcs/kdesvn/files/kdesvn-2.0.0-qt-5.11.patch
new file mode 100644
index 000000000000..019d2271001a
--- /dev/null
+++ b/dev-vcs/kdesvn/files/kdesvn-2.0.0-qt-5.11.patch
@@ -0,0 +1,25 @@
+From 605484fd9fc873b9b8d571f398c3cab05c68d860 Mon Sep 17 00:00:00 2001
+From: Luca Beltrame <lbeltrame@kde.org>
+Date: Thu, 10 May 2018 09:28:15 +0200
+Subject: Fix build with Qt 5.11
+
+Some includes added transitively previously now need to be explicitly
+put.
+---
+ src/svnfrontend/blamedisplay.cpp | 1 +
+ 1 file changed, 1 insertion(+)
+
+diff --git a/src/svnfrontend/blamedisplay.cpp b/src/svnfrontend/blamedisplay.cpp
+index 2d87502..5673181 100644
+--- a/src/svnfrontend/blamedisplay.cpp
++++ b/src/svnfrontend/blamedisplay.cpp
+@@ -30,6 +30,7 @@
+ #include <KTextEdit>
+ #include <KTreeWidgetSearchLine>
+
++#include <QAction>
+ #include <QBrush>
+ #include <QFontDatabase>
+ #include <QInputDialog>
+--
+cgit v0.11.2
diff --git a/dev-vcs/kdesvn/kdesvn-2.0.0.ebuild b/dev-vcs/kdesvn/kdesvn-2.0.0.ebuild
index 483633ed6ea6..b89d778a3a1f 100644
--- a/dev-vcs/kdesvn/kdesvn-2.0.0.ebuild
+++ b/dev-vcs/kdesvn/kdesvn-2.0.0.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2017 Gentoo Foundation
+# Copyright 1999-2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
EAPI=6
@@ -53,6 +53,7 @@ RDEPEND="${DEPEND}
PATCHES=(
"${FILESDIR}/${P}-desktop.patch"
"${FILESDIR}/${P}-deps.patch"
+ "${FILESDIR}/${P}-qt-5.11.patch"
)
src_prepare(){