summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-11-23 07:58:46 +0100
committerMichał Górny <mgorny@gentoo.org>2022-11-26 22:12:29 +0100
commit81245c75f8b75958ca76ab28e38f20353219fb0d (patch)
treefba3a32131a3211258a7742c1b7bd82f2eccd492
parentpython-utils-r1.eclass: Disable tavern plugin in epytest (diff)
downloadgentoo-81245c75f8b75958ca76ab28e38f20353219fb0d.tar.gz
gentoo-81245c75f8b75958ca76ab28e38f20353219fb0d.tar.bz2
gentoo-81245c75f8b75958ca76ab28e38f20353219fb0d.zip
dev-python/scipy: Pass -Dblas, -Dlapack via DISTUTILS_ARGS
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/scipy/scipy-1.9.3.ebuild11
-rw-r--r--dev-python/scipy/scipy-1.9.9999.ebuild11
2 files changed, 10 insertions, 12 deletions
diff --git a/dev-python/scipy/scipy-1.9.3.ebuild b/dev-python/scipy/scipy-1.9.3.ebuild
index 18e8c08b3222..7c62ef8bb35f 100644
--- a/dev-python/scipy/scipy-1.9.3.ebuild
+++ b/dev-python/scipy/scipy-1.9.3.ebuild
@@ -62,6 +62,7 @@ RDEPEND="
BDEPEND="
dev-lang/swig
>=dev-python/cython-0.29.18[${PYTHON_USEDEP}]
+ >=dev-python/meson-python-0.11[${PYTHON_USEDEP}]
dev-python/pybind11[${PYTHON_USEDEP}]
>=dev-util/meson-0.62.2
dev-util/patchelf
@@ -70,10 +71,6 @@ BDEPEND="
fortran? ( dev-python/pythran[${PYTHON_USEDEP}] )
test? ( dev-python/pytest-xdist[${PYTHON_USEDEP}] )"
-PATCHES=(
- "${FILESDIR}"/${PN}-1.9.9999-meson-options-lapack.patch
-)
-
EPYTEST_DESELECT=(
linalg/tests/test_decomp.py::TestSchur::test_sort
linalg/tests/test_solvers.py::test_solve_discrete_are
@@ -90,9 +87,11 @@ src_unpack() {
}
python_configure_all() {
- # workaround stupid numpy distutils overrides, indirectly via pythran
- export SETUPTOOLS_USE_DISTUTILS=stdlib
export SCIPY_USE_PYTHRAN=$(usex fortran 1 0)
+ DISTUTILS_ARGS=(
+ -Dblas=blas
+ -Dlapack=lapack
+ )
}
python_test() {
diff --git a/dev-python/scipy/scipy-1.9.9999.ebuild b/dev-python/scipy/scipy-1.9.9999.ebuild
index 6396c461e4e3..b85e9495ebc9 100644
--- a/dev-python/scipy/scipy-1.9.9999.ebuild
+++ b/dev-python/scipy/scipy-1.9.9999.ebuild
@@ -62,6 +62,7 @@ RDEPEND="
BDEPEND="
dev-lang/swig
>=dev-python/cython-0.29.18[${PYTHON_USEDEP}]
+ >=dev-python/meson-python-0.11[${PYTHON_USEDEP}]
dev-python/pybind11[${PYTHON_USEDEP}]
>=dev-util/meson-0.62.2
dev-util/patchelf
@@ -70,10 +71,6 @@ BDEPEND="
fortran? ( dev-python/pythran[${PYTHON_USEDEP}] )
test? ( dev-python/pytest-xdist[${PYTHON_USEDEP}] )"
-PATCHES=(
- "${FILESDIR}"/${PN}-1.9.9999-meson-options-lapack.patch
-)
-
EPYTEST_DESELECT=(
linalg/tests/test_decomp.py::TestSchur::test_sort
linalg/tests/test_solvers.py::test_solve_discrete_are
@@ -90,9 +87,11 @@ src_unpack() {
}
python_configure_all() {
- # workaround stupid numpy distutils overrides, indirectly via pythran
- export SETUPTOOLS_USE_DISTUTILS=stdlib
export SCIPY_USE_PYTHRAN=$(usex fortran 1 0)
+ DISTUTILS_ARGS=(
+ -Dblas=blas
+ -Dlapack=lapack
+ )
}
python_test() {