summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLouis Sautier <sbraz@gentoo.org>2020-10-03 23:39:21 +0200
committerLouis Sautier <sbraz@gentoo.org>2020-10-03 23:40:23 +0200
commit814988a344a0eb0be7583259d6c317786578e80e (patch)
treee3ce93d6c1e9738a4b3e09fd5a865a458c52f4fd
parentsys-cluster/minikube: 1.13.1 bump (diff)
downloadgentoo-814988a3.tar.gz
gentoo-814988a3.tar.bz2
gentoo-814988a3.zip
dev-python/zipp: bump to 3.3.0
Package-Manager: Portage-3.0.8, Repoman-3.0.1 Signed-off-by: Louis Sautier <sbraz@gentoo.org>
-rw-r--r--dev-python/zipp/Manifest1
-rw-r--r--dev-python/zipp/zipp-3.3.0.ebuild40
2 files changed, 41 insertions, 0 deletions
diff --git a/dev-python/zipp/Manifest b/dev-python/zipp/Manifest
index b6230e3f3b68..b5608260e3d3 100644
--- a/dev-python/zipp/Manifest
+++ b/dev-python/zipp/Manifest
@@ -1,2 +1,3 @@
DIST zipp-3.1.0.tar.gz 14808 BLAKE2B fb5524c2619e51c5f8c1b85fa819d1001e6296df6c9d5320c6ab3ec88fa5c932c139161e621d51b2827ef40402bb2492b8b08e470b7333e847495ec690024879 SHA512 bb8dea71eccc4f3b18fc816dae700582c3feb72f346e115bb2d1adc336f121304a285e4d5dad48d15b386b9e137c6e1d1793ef50d22b6bd697812a661817684e
DIST zipp-3.2.0.tar.gz 16238 BLAKE2B d74781639c714342863a0532ac8bbfc4d8cdcd554b9ce2b0edf83dc26ac423231ac85323379b4923308f2319c828aca2e0bcd4bd136845e7026b09e1e16e108e SHA512 fc0c8a9f1fbbcdd0f70c536e7498605e0a338dd99abd65f16b360cb16f96c7860d422ce2b55f7b2c1bfd7e5c5b5ca3bf818a48bae19bfbf190d91d4778aed31a
+DIST zipp-3.3.0.tar.gz 16796 BLAKE2B 4d6acbca82e7da97f0634a47306d157fc3bc9cd37875c95fa449cd08ac7c9ad266c43cfeec373a6d866fc21ccb7ced9049552cc9cc816e471bbe5f7ffd43a4df SHA512 af43451d908dca5971625dade20fa8038713a2c4d2c3ddb1690199832d44b8515124276193bb514883cfba70b32360b450a64a2ed1d8537dc71f243ef57e9d92
diff --git a/dev-python/zipp/zipp-3.3.0.ebuild b/dev-python/zipp/zipp-3.3.0.ebuild
new file mode 100644
index 000000000000..46fb971a3bc6
--- /dev/null
+++ b/dev-python/zipp/zipp-3.3.0.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( pypy3 python3_{6..9} )
+
+inherit distutils-r1
+
+DESCRIPTION="Backport of pathlib-compatible object wrapper for zip files"
+HOMEPAGE="https://github.com/jaraco/zipp"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+
+BDEPEND="
+ dev-python/toml[${PYTHON_USEDEP}]
+ >=dev-python/setuptools_scm-3.4.2[${PYTHON_USEDEP}]
+ test? ( dev-python/jaraco-itertools[${PYTHON_USEDEP}] )
+"
+
+distutils_enable_sphinx docs \
+ ">=dev-python/jaraco-packaging-3.2" \
+ ">=dev-python/rst-linker-1.9"
+distutils_enable_tests pytest
+
+python_prepare_all() {
+ # Skip a potentially flaky performance test
+ sed -i -e '/^import func_timeout\|^ *@func_timeout\.func_set_timeout/d' \
+ -e 's/test_implied_dirs_performance/_&/' test_zipp.py || die
+ distutils-r1_python_prepare_all
+}
+
+python_test() {
+ # Ignoring zipp.py from ${S} avoids ImportPathMismatchError with Python < 3.8
+ # by ensuring only zipp from ${BUILD_DIR} is loaded
+ pytest --ignore zipp.py -vv || die "Tests fail with ${EPYTHON}"
+}