summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJames Le Cuirot <chewi@gentoo.org>2022-07-16 23:42:52 +0100
committerJames Le Cuirot <chewi@gentoo.org>2022-07-16 23:42:52 +0100
commit8177cb30fa35a7e9a2d917399cc658266c2cd72f (patch)
tree71473ad9c77994bdcf2f6ea0c5e2e2dba6e46bec
parentdev-util/patchelf: Version bump to 0.15.0 (diff)
downloadgentoo-8177cb30fa35a7e9a2d917399cc658266c2cd72f.tar.gz
gentoo-8177cb30fa35a7e9a2d917399cc658266c2cd72f.tar.bz2
gentoo-8177cb30fa35a7e9a2d917399cc658266c2cd72f.zip
dev-util/patchelf: Actually add the 0.15.0 ebuild
Signed-off-by: James Le Cuirot <chewi@gentoo.org>
-rw-r--r--dev-util/patchelf/patchelf-0.15.0.ebuild24
1 files changed, 24 insertions, 0 deletions
diff --git a/dev-util/patchelf/patchelf-0.15.0.ebuild b/dev-util/patchelf/patchelf-0.15.0.ebuild
new file mode 100644
index 000000000000..05802ed8d121
--- /dev/null
+++ b/dev-util/patchelf/patchelf-0.15.0.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit autotools
+
+DESCRIPTION="Small utility to modify the dynamic linker and RPATH of ELF executables"
+HOMEPAGE="https://github.com/NixOS/patchelf"
+SRC_URI="https://github.com/NixOS/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux"
+LICENSE="GPL-3"
+
+src_prepare() {
+ default
+ rm src/elf.h || die
+
+ sed -i \
+ -e 's:-Werror::g' \
+ configure.ac || die
+
+ eautoreconf
+}