summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2024-01-29 23:18:05 +0100
committerAndreas Sturmlechner <asturm@gentoo.org>2024-03-08 00:44:30 +0100
commit817fdd67ef41f9e4aa180476515b0e27cedad93a (patch)
tree697e118964715897ff5067fe8c7e8f853fedfdd3
parentdev-libs/crossguid: Re-add 0_pre20150817 for now (diff)
downloadgentoo-817fdd67.tar.gz
gentoo-817fdd67.tar.bz2
gentoo-817fdd67.zip
media-libs/taglib: add 2.0
Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
-rw-r--r--media-libs/taglib/Manifest1
-rw-r--r--media-libs/taglib/taglib-2.0.ebuild58
2 files changed, 59 insertions, 0 deletions
diff --git a/media-libs/taglib/Manifest b/media-libs/taglib/Manifest
index eaaab49e2e20..28be72ecd6de 100644
--- a/media-libs/taglib/Manifest
+++ b/media-libs/taglib/Manifest
@@ -1 +1,2 @@
DIST taglib-1.13.1.tar.gz 1372618 BLAKE2B 36cf9b59ded95c9996d04a86055a36a7b74a2a01c13f75826d4907abca0b982c5f9b0e4bcd6648707013108f8eaf424ab95f07c383130452aa169e2cab33f466 SHA512 986231ee62caa975afead7e94630d58acaac25a38bc33d4493d51bd635d79336e81bba60586d7355ebc0670e31f28d32da3ecceaf33292e4bc240c64bf00f35b
+DIST taglib-2.0.tar.gz 1429934 BLAKE2B a6743c6da473e78487bb3569f01ff944c8e48ee85d40a710c98b55e302ba9bda8a428ab2bdef82f9f84c1eac4e4285adfb33d551924253bb0fc998c7b30c7c77 SHA512 099d02b2eab033f5702a8cb03e70752d7523c6f8c2f3eebdd0bcd939eafbdca3f2a6c82452983904b5822cfa45f2707ed866c3419508df9d43bf5c0b3a476f6c
diff --git a/media-libs/taglib/taglib-2.0.ebuild b/media-libs/taglib/taglib-2.0.ebuild
new file mode 100644
index 000000000000..7d5f338625fe
--- /dev/null
+++ b/media-libs/taglib/taglib-2.0.ebuild
@@ -0,0 +1,58 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit cmake-multilib
+
+DESCRIPTION="Library for reading and editing audio meta data"
+HOMEPAGE="https://taglib.github.io/"
+SRC_URI="https://github.com/${PN}/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="LGPL-2.1 MPL-1.1"
+SLOT="0"
+# KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~mips ~ppc ~ppc64 ~riscv ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos"
+IUSE="doc examples test"
+
+RESTRICT="!test? ( test )"
+
+RDEPEND=">=sys-libs/zlib-1.2.8-r1[${MULTILIB_USEDEP}]"
+DEPEND="${RDEPEND}
+ test? ( >=dev-util/cppunit-1.13.2[${MULTILIB_USEDEP}] )
+"
+BDEPEND="
+ virtual/pkgconfig
+ doc? ( app-text/doxygen[dot] )
+"
+
+MULTILIB_CHOST_TOOLS=(
+ /usr/bin/taglib-config
+)
+
+multilib_src_configure() {
+ local mycmakeargs=(
+ -DBUILD_EXAMPLES=$(multilib_native_usex examples)
+ -DBUILD_TESTING=$(usex test)
+ )
+ cmake_src_configure
+}
+
+multilib_src_compile() {
+ cmake_src_compile
+
+ if multilib_is_native_abi; then
+ use doc && cmake_build docs
+ fi
+}
+
+multilib_src_test() {
+ eninja check
+}
+
+multilib_src_install() {
+ cmake_src_install
+
+ if multilib_is_native_abi && use doc; then
+ HTML_DOCS=( "${BUILD_DIR}"/doc/html/. )
+ fi
+}