summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArthur Zamarin <arthurzam@gentoo.org>2022-05-13 14:01:39 +0300
committerArthur Zamarin <arthurzam@gentoo.org>2022-05-13 14:01:39 +0300
commit81a234d64fa874387cc10baa108f49a92d705f4f (patch)
tree520f1917cd191742c628f63c6fd348d193c1dea4
parentdev-python/kaitaistruct: enable py3.11 (diff)
downloadgentoo-81a234d64fa874387cc10baa108f49a92d705f4f.tar.gz
gentoo-81a234d64fa874387cc10baa108f49a92d705f4f.tar.bz2
gentoo-81a234d64fa874387cc10baa108f49a92d705f4f.zip
dev-python/keep: EAPI=8, PEP517
Signed-off-by: Arthur Zamarin <arthurzam@gentoo.org>
-rw-r--r--dev-python/keep/keep-2.10.1-r1.ebuild23
1 files changed, 23 insertions, 0 deletions
diff --git a/dev-python/keep/keep-2.10.1-r1.ebuild b/dev-python/keep/keep-2.10.1-r1.ebuild
new file mode 100644
index 000000000000..21a90fc5f50b
--- /dev/null
+++ b/dev-python/keep/keep-2.10.1-r1.ebuild
@@ -0,0 +1,23 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..9} )
+inherit distutils-r1
+
+DESCRIPTION="Personal shell command keeper and snippets manager"
+HOMEPAGE="https://pypi.org/project/keep/ https://github.com/orkohunter/keep"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ dev-python/click[${PYTHON_USEDEP}]
+ dev-python/PyGithub[${PYTHON_USEDEP}]
+ dev-python/requests[${PYTHON_USEDEP}]
+ dev-python/terminaltables[${PYTHON_USEDEP}]
+"