summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-08-19 13:56:49 +0200
committerMichał Górny <mgorny@gentoo.org>2021-08-19 13:56:49 +0200
commit81a6d1132180ca41f8eb32b28c382f8d965cada3 (patch)
tree456f4635ea93e38bb9adaec475b44120341baff5
parentdev-python/eventlet: ppc64 stable wrt bug #794325 (diff)
downloadgentoo-81a6d1132180ca41f8eb32b28c382f8d965cada3.tar.gz
gentoo-81a6d1132180ca41f8eb32b28c382f8d965cada3.tar.bz2
gentoo-81a6d1132180ca41f8eb32b28c382f8d965cada3.zip
dev-python/cffi: Remove old
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/cffi/Manifest1
-rw-r--r--dev-python/cffi/cffi-1.14.5.ebuild53
2 files changed, 0 insertions, 54 deletions
diff --git a/dev-python/cffi/Manifest b/dev-python/cffi/Manifest
index 1fb2acd163b5..6eeb020fec86 100644
--- a/dev-python/cffi/Manifest
+++ b/dev-python/cffi/Manifest
@@ -1,2 +1 @@
-DIST cffi-1.14.5.tar.gz 475055 BLAKE2B d8a1f83aace8329216f5d36b2e8a27f62803fe9ad12c2d29aa1b3f730d1beb8bad0f50e17102c8673471a7bef57b0755157c4e1bf1a50779ed20b1cfcbb2043a SHA512 7428b3f6e4ee9f3b91011e43304dd63e5cc48479120ae58298c646c1ec1f5c24525d5f08655a7fed70c5fad7ae0c2e0539e512b5fa49d2bc57669c4ab703cc2a
DIST cffi-1.14.6.tar.gz 475744 BLAKE2B 46e3f1f61746f659c066d83fdb07b83c289eda68056c6f9e364ea6f30cd56c190e4fdb35586c064b2402483704a7c1e9399d7f30cb49a78eec21797146da36f2 SHA512 30a8b25b74921a90a1fa96d05de1f25437d0fbbf73b7de0bb9ce22dfcaccbd78376b605525fe970212221d3e598357a9b1da420bfbd1a3e513263ed2b789e813
diff --git a/dev-python/cffi/cffi-1.14.5.ebuild b/dev-python/cffi/cffi-1.14.5.ebuild
deleted file mode 100644
index d329f87995f8..000000000000
--- a/dev-python/cffi/cffi-1.14.5.ebuild
+++ /dev/null
@@ -1,53 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-# DO NOT ADD pypy to PYTHON_COMPAT
-# pypy bundles a modified version of cffi. Use python_gen_cond_dep instead.
-PYTHON_COMPAT=( python3_{7..10} )
-
-inherit distutils-r1 toolchain-funcs
-
-DESCRIPTION="Foreign Function Interface for Python calling C code"
-HOMEPAGE="https://cffi.readthedocs.io/ https://pypi.org/project/cffi/"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-
-LICENSE="MIT"
-SLOT="0/${PV}"
-KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ~m68k ~mips ppc ppc64 ~riscv ~s390 sparc x86 ~x64-cygwin ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
-IUSE="test"
-RESTRICT="!test? ( test )"
-
-DEPEND="dev-libs/libffi:="
-RDEPEND="${DEPEND}
- dev-python/pycparser[${PYTHON_USEDEP}]"
-BDEPEND="${RDEPEND}
- virtual/pkgconfig
- test? ( dev-python/pytest[${PYTHON_USEDEP}] )"
-
-distutils_enable_sphinx doc/source
-
-PATCHES=(
- "${FILESDIR}"/cffi-1.14.0-darwin-no-brew.patch
-)
-
-src_prepare() {
- if [[ ${CHOST} == *darwin* ]] ; then
- # Don't obsessively try to find libffi
- sed -i -e "s/.*\-iwithsysroot\/usr\/include\/ffi.*/\tpass/" setup.py || die
- fi
- distutils-r1_src_prepare
-}
-
-src_configure() {
- tc-export PKG_CONFIG
-}
-
-python_test() {
- "${EPYTHON}" -c "import _cffi_backend as backend" || die
- epytest \
- --ignore testing/test_zintegration.py \
- --ignore testing/embedding \
- c/ testing/
-}