summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2023-03-13 21:23:21 +0000
committerSam James <sam@gentoo.org>2023-03-13 21:23:33 +0000
commit81aa9d9a0ee5f9f33fb9ab1f591c79f1fb134ffd (patch)
treeec205c07737d1015fa2790783a29141d067f1c8c
parentnet-misc/whois: add 5.5.16 (diff)
downloadgentoo-81aa9d9a0ee5f9f33fb9ab1f591c79f1fb134ffd.tar.gz
gentoo-81aa9d9a0ee5f9f33fb9ab1f591c79f1fb134ffd.tar.bz2
gentoo-81aa9d9a0ee5f9f33fb9ab1f591c79f1fb134ffd.zip
app-shells/gentoo-bashcomp: add 20230313
Bug: https://bugs.gentoo.org/730624 Bug: https://bugs.gentoo.org/870373 Bug: https://bugs.gentoo.org/834038 Signed-off-by: Sam James <sam@gentoo.org>
-rw-r--r--app-shells/gentoo-bashcomp/Manifest1
-rw-r--r--app-shells/gentoo-bashcomp/gentoo-bashcomp-20230313.ebuild21
2 files changed, 22 insertions, 0 deletions
diff --git a/app-shells/gentoo-bashcomp/Manifest b/app-shells/gentoo-bashcomp/Manifest
index fb85b8f9d37d..780576961c42 100644
--- a/app-shells/gentoo-bashcomp/Manifest
+++ b/app-shells/gentoo-bashcomp/Manifest
@@ -1 +1,2 @@
DIST gentoo-bashcomp-20190211.tar.bz2 21508 BLAKE2B 410994819f62b0bd105ca398c335d76993fd694b8e7f56c761b94fc1e2f6e90f2010f2f2a88febd71ac0c5643fc0e923c60151fbf9411e8a553b5917d6bcd8db SHA512 4b0a5e79f90ee8122fa8d0a7224fee6472b1762a0dda680ea1c0e8d4069760be9b6472e052b1b166a389c0e779816b98715386dbc62a3574e7ad851b2567a070
+DIST gentoo-bashcomp-20230313.tar.bz2 21536 BLAKE2B 5dc47aecf68fc19c177026582d98b441d09a15bf0f9e618533c62a37b7986ab6d619f2873b58697f484830bbe88e7697755bb7ee14fb8c55be12e7296e1acfec SHA512 482bf1444e76da544bfbab727f9016abcc82ed4283e31e7ad1e1d302cfe67edfc55cdc37871ae53c09e4e3ce5a5e20dd5f8994ec60e1698076bc81659a2fa3b0
diff --git a/app-shells/gentoo-bashcomp/gentoo-bashcomp-20230313.ebuild b/app-shells/gentoo-bashcomp/gentoo-bashcomp-20230313.ebuild
new file mode 100644
index 000000000000..eb5aaaeec783
--- /dev/null
+++ b/app-shells/gentoo-bashcomp/gentoo-bashcomp-20230313.ebuild
@@ -0,0 +1,21 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit bash-completion-r1
+
+DESCRIPTION="Gentoo-specific bash command-line completions (emerge, ebuild, equery, etc)"
+HOMEPAGE="https://gitweb.gentoo.org/proj/gentoo-bashcomp.git/"
+SRC_URI="https://gitweb.gentoo.org/proj/${PN}.git/snapshot/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~sparc-solaris ~sparc64-solaris"
+
+src_install() {
+ emake DESTDIR="${D}" install \
+ completionsdir="$(get_bashcompdir)" \
+ helpersdir="$(get_bashhelpersdir)" \
+ compatdir="${EPREFIX}/etc/bash_completion.d"
+}