summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLouis Sautier <sautier.louis@gmail.com>2016-02-29 01:29:12 +0100
committerLouis Sautier <sautier.louis@gmail.com>2016-02-29 11:57:59 +0100
commit81ac8d63d85a056c750648357a99f1dcb42de71d (patch)
tree55b3b8903ed9ce517604ca2cff27a623094de983
parentdev-libs/squareball: first release. updated live ebuild (diff)
downloadgentoo-81ac8d63.tar.gz
gentoo-81ac8d63.tar.bz2
gentoo-81ac8d63.zip
dev-python/irc: bump to 14.1, EAPI=6
Replaced banned EXAMPLES with manual doins Package-Manager: portage-2.2.27
-rw-r--r--dev-python/irc/Manifest1
-rw-r--r--dev-python/irc/irc-14.1.ebuild54
2 files changed, 55 insertions, 0 deletions
diff --git a/dev-python/irc/Manifest b/dev-python/irc/Manifest
index d899cfb86a4c..9dd9faff65fd 100644
--- a/dev-python/irc/Manifest
+++ b/dev-python/irc/Manifest
@@ -1,3 +1,4 @@
DIST irc-11.0.1.zip 120409 SHA256 25d818003780fd6d62e93d3ff32580e74c0e527c6290ae14b47af50b58339233 SHA512 fca2fe653d921c9ec65dfb2b072c16658d88d4a22ae91568b1eaf722a90179920808db157f587afe6de0055af3a04a528eb9022122e539150e5635f05b58f466 WHIRLPOOL dd9b9e8624e6bd86d27fead1f3006a2b80832d236ad21f50c147c07a27b2cc4933d68efd951dece44398dbc0299b73ba7a98e4eff2061d0e3a8a01833518113b
DIST irc-13.3.1.tar.gz 81931 SHA256 be4b57f2fb296f0e83fe2bcfd91e886b13423d8cf4ebaf2b8077b8efa9783bee SHA512 fd82712a8446dbccdd50ba75e0ec0f45f0b327ff35e4fa172fe4a1fe92ca8dbb81afecc0aa0b3ba14b2864e7d78ce0b03496bde64181d66ebd3c4a7670e20fd9 WHIRLPOOL 7baa08a978980baf09257886b4c89e62abce9439082197549e9ffdda9acb7711fec4c2464f2c811b5c70803e43c663957bf2b38f50cfc5ec8fbbbdac8309b1fa
DIST irc-14.0.tar.gz 82116 SHA256 e953bce286139c42de9a973db970dbf79de04817c74de0486a30b2bdc4350ba2 SHA512 6928f66bf994800e06a2f00b43bba23f36ce9bdde066ecf602d01c19cee5c79ec0a75fd858d6bb0446676681118025ebdda2312374eaf481437247b0c63b20c4 WHIRLPOOL e4af44e9269291219fb66d62b575b19a54f67b7d9cde79b7225f6bd071545488b399409c5fd0153e2dd16a3a853cc2bbeedf23c3c634097bb69ac741052c2ee9
+DIST irc-14.1.tar.gz 83206 SHA256 a85a9ed6e54b4078a76172241102f722e2860864b761206f0aadedd0a3dd66b1 SHA512 42f4638a73cea53d381a815d9dcf956919c79c984979ddee3ff40a047fae81f2e8dcc80745cd98d18b67b068a7c6cb4a13a14d945c95683fcfdabbf9e46558c1 WHIRLPOOL 41efb39bebb69c946e4432ef129bfd363a811558d19bd3d9f8fb107ddfe1d2689ea0eb34b73f0aadb7921cde8badcc42075c020352c367fb2f4cb05022322c21
diff --git a/dev-python/irc/irc-14.1.ebuild b/dev-python/irc/irc-14.1.ebuild
new file mode 100644
index 000000000000..042dbfefde9d
--- /dev/null
+++ b/dev-python/irc/irc-14.1.ebuild
@@ -0,0 +1,54 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+PYTHON_COMPAT=( python{2_7,3_4,3_5} )
+
+inherit distutils-r1
+
+DESCRIPTION="IRC client framework written in Python"
+HOMEPAGE="https://github.com/jaraco/irc"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc examples test"
+
+RDEPEND="
+ dev-python/six[${PYTHON_USEDEP}]
+ dev-python/jaraco-collections[${PYTHON_USEDEP}]
+ dev-python/jaraco-text[${PYTHON_USEDEP}]
+ dev-python/jaraco-itertools[${PYTHON_USEDEP}]
+ dev-python/jaraco-logging[${PYTHON_USEDEP}]
+ >=dev-python/jaraco-functools-1.5[${PYTHON_USEDEP}]
+ dev-python/pytz[${PYTHON_USEDEP}]
+"
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
+ >=dev-python/setuptools_scm-1.9[${PYTHON_USEDEP}]
+ test? (
+ ${RDEPEND}
+ >=dev-python/pytest-2.8[${PYTHON_USEDEP}]
+ dev-python/pytest-runner[${PYTHON_USEDEP}]
+ dev-python/backports-unittest-mock[${PYTHON_USEDEP}]
+ )
+"
+
+python_compile_all() {
+ use doc && esetup.py build_sphinx
+}
+
+python_test() {
+ py.test || die "Tests failed with ${EPYTHON}"
+}
+
+python_install_all() {
+ if use examples; then
+ insinto "/usr/share/doc/${PF}"
+ docompress -x "/usr/share/doc/${PF}/scripts"
+ doins -r scripts
+ fi
+ use doc && local HTML_DOCS=( "${BUILD_DIR}"/sphinx/html/. )
+ distutils-r1_python_install_all
+}