summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArsen Arsenović <arsen@aarsen.me>2022-09-18 21:09:13 +0200
committerSam James <sam@gentoo.org>2022-09-20 20:31:58 +0100
commit81c8e794315833732c1e89eb18734b50b90c5276 (patch)
treeb30710aa7526e3e5ad7d7beb0339767e587f665d
parentmedia-libs/fcft: add 3.1.5 (diff)
downloadgentoo-81c8e794.tar.gz
gentoo-81c8e794.tar.bz2
gentoo-81c8e794.zip
www-servers/gatling: add patches for Clang 16
Closes: https://bugs.gentoo.org/871495 Signed-off-by: Arsen Arsenović <arsen@aarsen.me> Signed-off-by: Sam James <sam@gentoo.org>
-rw-r--r--www-servers/gatling/files/gatling-0.16-r4-0001-try-alloca-socket-fix-Wimplicit-int.patch41
-rw-r--r--www-servers/gatling/gatling-0.16-r4.ebuild64
2 files changed, 105 insertions, 0 deletions
diff --git a/www-servers/gatling/files/gatling-0.16-r4-0001-try-alloca-socket-fix-Wimplicit-int.patch b/www-servers/gatling/files/gatling-0.16-r4-0001-try-alloca-socket-fix-Wimplicit-int.patch
new file mode 100644
index 000000000000..4b22b7a5c13d
--- /dev/null
+++ b/www-servers/gatling/files/gatling-0.16-r4-0001-try-alloca-socket-fix-Wimplicit-int.patch
@@ -0,0 +1,41 @@
+From d1a28da112988112a37feb9050733717bfc176df Mon Sep 17 00:00:00 2001
+From: =?UTF-8?q?Arsen=20Arsenovi=C4=87?= <arsen@aarsen.me>
+Date: Sun, 18 Sep 2022 19:48:16 +0200
+Subject: [PATCH] try{alloca,socket}: fix -Wimplicit-int
+
+This warning becomes fatal with Clang 16.
+---
+https://bugs.gentoo.org/871495
+ tryalloca.c | 2 +-
+ trysocket.c | 2 +-
+ 2 files changed, 2 insertions(+), 2 deletions(-)
+
+diff --git a/tryalloca.c b/tryalloca.c
+index c8927ab..b6e4f71 100644
+--- a/tryalloca.c
++++ b/tryalloca.c
+@@ -5,7 +5,7 @@
+ #include <malloc.h>
+ #endif
+
+-main() {
++int main() {
+ char* c=alloca(23);
+ return c!=NULL;
+ }
+diff --git a/trysocket.c b/trysocket.c
+index a01f395..381b794 100644
+--- a/trysocket.c
++++ b/trysocket.c
+@@ -6,7 +6,7 @@
+ #include <netinet/in.h>
+ #endif
+
+-main() {
++int main() {
+ int fd=socket(PF_INET,SOCK_STREAM,IPPROTO_TCP);
+ return fd!=-1;
+ }
+--
+2.35.1
+
diff --git a/www-servers/gatling/gatling-0.16-r4.ebuild b/www-servers/gatling/gatling-0.16-r4.ebuild
new file mode 100644
index 000000000000..5562859bec4a
--- /dev/null
+++ b/www-servers/gatling/gatling-0.16-r4.ebuild
@@ -0,0 +1,64 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="7"
+
+inherit toolchain-funcs
+
+DESCRIPTION="High performance web server"
+HOMEPAGE="https://www.fefe.de/gatling/"
+SRC_URI="https://www.fefe.de/gatling/${P}.tar.xz"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+IUSE="ssl diet"
+REQUIRED_USE="ssl? ( !diet )"
+
+DEPEND=">=dev-libs/libowfat-0.32-r2[diet=]
+ virtual/libcrypt:=
+ diet? ( dev-libs/dietlibc )
+ ssl? (
+ dev-libs/openssl:0=
+ )"
+RDEPEND="${DEPEND}
+ acct-group/gatling
+ acct-user/gatling
+ "
+
+PATCHES=(
+ "${FILESDIR}/${PN}-0.13-compile.patch"
+ "${FILESDIR}/${PN}-0.15-ar.patch"
+ "${FILESDIR}/${PN}-0.16-r4-0001-try-alloca-socket-fix-Wimplicit-int.patch"
+)
+
+src_prepare() {
+ default
+ rm Makefile # leaves us with GNUmakefile
+}
+
+src_compile() {
+ local DIET=
+ use diet && DIET='/usr/bin/diet'
+
+ local targets='gatling'
+ use ssl && targets+=' tlsgatling'
+
+ emake DIET="${DIET}" CC="$(tc-getCC)" \
+ CFLAGS="${CFLAGS} -I${ESYSROOT}/usr/include/libowfat" \
+ LDFLAGS="${LDFLAGS}" prefix=/usr ${targets}
+}
+
+src_install() {
+ doman gatling.1
+
+ newconfd "${FILESDIR}/gatling.confd" gatling
+ newinitd "${FILESDIR}/gatling.initd-3" gatling
+ dodoc README.{ftp,http}
+
+ dobin gatling
+ use ssl && {
+ dodoc README.tls
+ dobin tlsgatling
+ }
+}