summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatt Turner <mattst88@gentoo.org>2022-04-17 14:02:38 -0700
committerMatt Turner <mattst88@gentoo.org>2022-04-18 18:16:12 -0700
commit81df4e9c88720fc6fd5d8f7890ce5afd3d7d8dec (patch)
tree17e51f94145035bd016d6e99b60a90ef6d5a0b51
parentarch/s390: unmask new perl (diff)
downloadgentoo-81df4e9c88720fc6fd5d8f7890ce5afd3d7d8dec.tar.gz
gentoo-81df4e9c88720fc6fd5d8f7890ce5afd3d7d8dec.tar.bz2
gentoo-81df4e9c88720fc6fd5d8f7890ce5afd3d7d8dec.zip
app-text/enchant: Version bump to 2.3.3
- Bump to EAPI=8 - Add nuspell support (bug #750290) - Move enchant:2's enchant/enchant.ordering to /usr/share, and move enchant:1's enchant/enchant.ordering to /usr/share/enchant-1. Previously it was the other way around, and this causes enchant:2's test suite to fail. - Enable dev-libs/unittest++ test dependency in enchant:1, since it now ships a pkgconfig file Closes: https://bugs.gentoo.org/750290 Signed-off-by: Matt Turner <mattst88@gentoo.org>
-rw-r--r--app-text/enchant/Manifest1
-rw-r--r--app-text/enchant/enchant-1.6.1-r2.ebuild60
-rw-r--r--app-text/enchant/enchant-2.3.3.ebuild52
-rw-r--r--app-text/enchant/metadata.xml1
-rw-r--r--profiles/arch/alpha/package.use.mask4
-rw-r--r--profiles/arch/arm/package.use.mask4
-rw-r--r--profiles/arch/arm64/package.use.mask4
-rw-r--r--profiles/arch/hppa/package.use.mask4
-rw-r--r--profiles/arch/ia64/package.use.mask4
-rw-r--r--profiles/arch/mips/package.use.mask4
-rw-r--r--profiles/arch/powerpc/package.use.mask4
-rw-r--r--profiles/arch/riscv/package.use.mask4
-rw-r--r--profiles/arch/sparc/package.use.mask4
13 files changed, 150 insertions, 0 deletions
diff --git a/app-text/enchant/Manifest b/app-text/enchant/Manifest
index 36fe8e6a7737..0b9c3f27c38c 100644
--- a/app-text/enchant/Manifest
+++ b/app-text/enchant/Manifest
@@ -1,2 +1,3 @@
DIST enchant-1.6.1.tar.gz 642124 BLAKE2B d41aa9b313e7fe8b0887728b55f3c5218e270c7359b4edcdc8d9180af68687230bcc9f7d1abb9f85ac673478530e5674366c9bc7d08b983e7226725b2cdd73d3 SHA512 26c62dfa89ee40150db502651a2f876fba00569b7015f205dae27a029557effacff335bbe36124dbe6686537da2305bcab02592179d03e95fdf9741d54b98036
DIST enchant-2.3.2.tar.gz 991782 BLAKE2B ece8c4cbac2c242c23b4b8c5ab2daf1037705dbf58ad29b4863dd01cb30b2d98e11828f2b9d1ce3823aec419c871cc3dd1092e4659e10ef3e3cd2df867255be4 SHA512 886635bb55c5f0c774445e4a0f14d39e2d08eeb964257037062c2e97c2cf3348be8c631ff5e7a13144936127761964bdc60ff1e0dd6f63b292a655626f91ef62
+DIST enchant-2.3.3.tar.gz 990877 BLAKE2B 310b66931e803ccb643a47c1476122a558de7a192b50f532d4cdababe55d398268bf5bfcc0ed556d665af88f6c183c1871147d302ad39a7ebd4fc29e1ab16967 SHA512 c97764a8f219033b440cbfb820624f54993b19ba1f38b56f20336889304f753c7c513008bb92cd1424bfbf528c2d473f35bef93d9140063612e3a270fd000deb
diff --git a/app-text/enchant/enchant-1.6.1-r2.ebuild b/app-text/enchant/enchant-1.6.1-r2.ebuild
new file mode 100644
index 000000000000..d4302d6ca527
--- /dev/null
+++ b/app-text/enchant/enchant-1.6.1-r2.ebuild
@@ -0,0 +1,60 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+MY_PV="${PV//./-}"
+DESCRIPTION="Spellchecker wrapping library"
+HOMEPAGE="https://abiword.github.io/enchant/"
+SRC_URI="https://github.com/AbiWord/enchant/releases/download/${PN}-${MY_PV}/${P}.tar.gz"
+
+LICENSE="LGPL-2.1+"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~riscv ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x86-solaris"
+
+IUSE="aspell +hunspell test"
+RESTRICT="!test? ( test )"
+REQUIRED_USE="|| ( aspell hunspell )"
+
+COMMON_DEPEND="
+ >=dev-libs/glib-2.6:2
+ aspell? ( app-text/aspell )
+ hunspell? ( >=app-text/hunspell-1.2.1:0= )
+"
+RDEPEND="${COMMON_DEPEND}
+ !<app-text/enchant-2.3.3:2
+"
+DEPEND="${COMMON_DEPEND}
+ test? ( >=dev-libs/unittest++-2.0.0-r2 )
+"
+BDEPEND="virtual/pkgconfig"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-1.6.0-hunspell150_fix.patch
+)
+
+src_prepare() {
+ default
+ sed -e "s/build_zemberek=yes//" -i "${S}"/configure{.ac,} || die # bug 662484
+}
+
+src_configure() {
+ local myconf=(
+ --datadir="${EPREFIX}"/usr/share/enchant-1
+ --disable-static
+ $(use_enable aspell)
+ $(use_enable hunspell myspell)
+ --disable-hspell
+ --disable-ispell
+ --disable-uspell
+ --disable-voikko
+ --disable-zemberek
+ --with-myspell-dir="${EPREFIX}"/usr/share/myspell/
+ )
+ econf "${myconf[@]}"
+}
+
+src_install() {
+ default
+ find "${D}" -name '*.la' -delete || die
+}
diff --git a/app-text/enchant/enchant-2.3.3.ebuild b/app-text/enchant/enchant-2.3.3.ebuild
new file mode 100644
index 000000000000..237874a845fd
--- /dev/null
+++ b/app-text/enchant/enchant-2.3.3.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DESCRIPTION="Spellchecker wrapping library"
+HOMEPAGE="https://abiword.github.io/enchant/"
+SRC_URI="https://github.com/AbiWord/enchant/releases/download/v${PV}/${P}.tar.gz"
+
+LICENSE="LGPL-2.1+"
+SLOT="2"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~riscv ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x86-solaris"
+
+IUSE="aspell +hunspell nuspell test voikko"
+RESTRICT="!test? ( test )"
+REQUIRED_USE="|| ( aspell hunspell nuspell )"
+
+COMMON_DEPEND="
+ >=dev-libs/glib-2.6:2
+ aspell? ( app-text/aspell )
+ hunspell? ( >=app-text/hunspell-1.2.1:0= )
+ nuspell? ( >=app-text/nuspell-5.1.0:0= )
+ voikko? ( dev-libs/libvoikko )
+"
+RDEPEND="${COMMON_DEPEND}
+ !<app-text/enchant-1.6.1-r2:1
+"
+DEPEND="${COMMON_DEPEND}
+ test? ( >=dev-libs/unittest++-2.0.0-r2 )
+"
+BDEPEND="virtual/pkgconfig"
+
+src_configure() {
+ local myconf=(
+ --disable-static
+ $(use_enable test relocatable)
+ $(use_with aspell)
+ $(use_with hunspell)
+ $(use_with nuspell)
+ $(use_with voikko)
+ --without-hspell
+ --without-applespell
+ --without-zemberek
+ --with-hunspell-dir="${EPREFIX}"/usr/share/hunspell/
+ )
+ econf "${myconf[@]}"
+}
+
+src_install() {
+ default
+ find "${D}" -name '*.la' -delete || die
+}
diff --git a/app-text/enchant/metadata.xml b/app-text/enchant/metadata.xml
index 3033ca238ad7..3d5f422a24ed 100644
--- a/app-text/enchant/metadata.xml
+++ b/app-text/enchant/metadata.xml
@@ -8,6 +8,7 @@
<use>
<flag name="aspell">Adds support for <pkg>app-text/aspell</pkg> spell checker</flag>
<flag name="hunspell">Adds support for <pkg>app-text/hunspell</pkg> spell checker</flag>
+ <flag name="nuspell">Adds support for <pkg>app-text/nuspell</pkg> spell checker</flag>
<flag name="voikko">Adds support for <pkg>dev-libs/libvoikko</pkg> spell checker</flag>
</use>
</pkgmetadata>
diff --git a/profiles/arch/alpha/package.use.mask b/profiles/arch/alpha/package.use.mask
index 9102346f8a5f..631eabb1f5e9 100644
--- a/profiles/arch/alpha/package.use.mask
+++ b/profiles/arch/alpha/package.use.mask
@@ -1,6 +1,10 @@
# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
+# Matt Turner <mattst88@gentoo.org> (2022-04-18)
+# app-text/nuspell is not keyworded
+app-text/enchant nuspell
+
# Matt Turner <mattst88@gentoo.org> (2022-04-16)
# sys-auth/seatd is not keyworded
dev-libs/weston seatd
diff --git a/profiles/arch/arm/package.use.mask b/profiles/arch/arm/package.use.mask
index 4034a3d22ea1..64a70b3dadac 100644
--- a/profiles/arch/arm/package.use.mask
+++ b/profiles/arch/arm/package.use.mask
@@ -1,6 +1,10 @@
# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
+# Matt Turner <mattst88@gentoo.org> (2022-04-18)
+# app-text/nuspell is not keyworded
+app-text/enchant nuspell
+
# Adel Kara Slimane <adel.ks@zegrapher.com> (2022-03-14)
# Untested useflag on other arches, needs keywording
media-video/ffmpeg vmaf
diff --git a/profiles/arch/arm64/package.use.mask b/profiles/arch/arm64/package.use.mask
index e30bc8103f11..85f1547acbba 100644
--- a/profiles/arch/arm64/package.use.mask
+++ b/profiles/arch/arm64/package.use.mask
@@ -1,6 +1,10 @@
# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
+# Matt Turner <mattst88@gentoo.org> (2022-04-18)
+# app-text/nuspell is not keyworded
+app-text/enchant nuspell
+
# Adel Kara Slimane <adel.ks@zegrapher.com> (2022-03-14)
# Untested useflag on other arches, needs keywording
media-video/ffmpeg vmaf
diff --git a/profiles/arch/hppa/package.use.mask b/profiles/arch/hppa/package.use.mask
index 3b3b89939204..b96d263b1284 100644
--- a/profiles/arch/hppa/package.use.mask
+++ b/profiles/arch/hppa/package.use.mask
@@ -4,6 +4,10 @@
# NOTE: When masking a USE flag due to missing keywords, please file a keyword
# request bug for the hppa arch.
+# Matt Turner <mattst88@gentoo.org> (2022-04-18)
+# app-text/nuspell is not keyworded
+app-text/enchant nuspell
+
# Lars Wendler <polynomial-c@gentoo.org> (2022-04-01)
# gnome-base/librsvg missing keywords
media-libs/freetype svg
diff --git a/profiles/arch/ia64/package.use.mask b/profiles/arch/ia64/package.use.mask
index adc60a31c090..3302882b0146 100644
--- a/profiles/arch/ia64/package.use.mask
+++ b/profiles/arch/ia64/package.use.mask
@@ -1,6 +1,10 @@
# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
+# Matt Turner <mattst88@gentoo.org> (2022-04-18)
+# app-text/nuspell is not keyworded
+app-text/enchant nuspell
+
# Matt Turner <mattst88@gentoo.org> (2022-04-16)
# net-misc/freerdp is not keyworded
dev-libs/weston rdp
diff --git a/profiles/arch/mips/package.use.mask b/profiles/arch/mips/package.use.mask
index bc6c5cb3127f..8c2459b45e47 100644
--- a/profiles/arch/mips/package.use.mask
+++ b/profiles/arch/mips/package.use.mask
@@ -1,6 +1,10 @@
# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
+# Matt Turner <mattst88@gentoo.org> (2022-04-18)
+# app-text/nuspell is not keyworded
+app-text/enchant nuspell
+
# Adel Kara Slimane <adel.ks@zegrapher.com> (2022-03-14)
# Untested useflag on other arches, needs keywording
media-video/ffmpeg vmaf
diff --git a/profiles/arch/powerpc/package.use.mask b/profiles/arch/powerpc/package.use.mask
index 9b81c363f5b3..2479b6843d57 100644
--- a/profiles/arch/powerpc/package.use.mask
+++ b/profiles/arch/powerpc/package.use.mask
@@ -1,6 +1,10 @@
# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
+# Matt Turner <mattst88@gentoo.org> (2022-04-18)
+# app-text/nuspell is not keyworded
+app-text/enchant nuspell
+
# Adel Kara Slimane <adel.ks@zegrapher.com> (2022-03-14)
# Untested useflag on other arches, needs keywording
media-video/ffmpeg vmaf
diff --git a/profiles/arch/riscv/package.use.mask b/profiles/arch/riscv/package.use.mask
index e56b475c4880..c48167d18023 100644
--- a/profiles/arch/riscv/package.use.mask
+++ b/profiles/arch/riscv/package.use.mask
@@ -1,6 +1,10 @@
# Copyright 2019-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
+# Matt Turner <mattst88@gentoo.org> (2022-04-18)
+# app-text/nuspell is not keyworded
+app-text/enchant nuspell
+
# Jakov Smolić <jsmolic@gentoo.org> (2022-04-07)
# Depends on sys-cluster/ceph which pulls in valgrind, which is
# unavailable on riscv currently
diff --git a/profiles/arch/sparc/package.use.mask b/profiles/arch/sparc/package.use.mask
index 2ed9f67e2226..e7b2542e7273 100644
--- a/profiles/arch/sparc/package.use.mask
+++ b/profiles/arch/sparc/package.use.mask
@@ -1,6 +1,10 @@
# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
+# Matt Turner <mattst88@gentoo.org> (2022-04-18)
+# app-text/nuspell is not keyworded
+app-text/enchant nuspell
+
# Matt Turner <mattst88@gentoo.org> (2022-04-16)
# net-misc/freerdp is not keyworded
dev-libs/weston rdp