summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKent Fredric <kentnl@gentoo.org>2020-08-02 03:07:10 +1200
committerKent Fredric <kentnl@gentoo.org>2020-08-02 03:07:47 +1200
commit81e220a40bd0d31a26df24a4e30d4aa1b1c0a6b3 (patch)
tree9383c8e08390d2bd41462ed8a530ad70de54182d
parentmedia-libs/glm-0.9.9.8: fixes Fixed installation of provided CMake configurat... (diff)
downloadgentoo-81e220a4.tar.gz
gentoo-81e220a4.tar.bz2
gentoo-81e220a4.zip
dev-perl/Dist-Zilla-Plugin-OSPrereqs: Bump to version 0.11.0
- EAPI7 - Fix LICENSE Upstream: - Makefile.PL generated code now conditionally injects prereqs into the fallback prereq list as well - Detect bundle configurations that would inject invalid code into Makefile.PL - prereq_os option in configs now uses the proper option name Package-Manager: Portage-2.3.103, Repoman-2.3.22 Signed-off-by: Kent Fredric <kentnl@gentoo.org>
-rw-r--r--dev-perl/Dist-Zilla-Plugin-OSPrereqs/Dist-Zilla-Plugin-OSPrereqs-0.11.0.ebuild31
-rw-r--r--dev-perl/Dist-Zilla-Plugin-OSPrereqs/Manifest1
2 files changed, 32 insertions, 0 deletions
diff --git a/dev-perl/Dist-Zilla-Plugin-OSPrereqs/Dist-Zilla-Plugin-OSPrereqs-0.11.0.ebuild b/dev-perl/Dist-Zilla-Plugin-OSPrereqs/Dist-Zilla-Plugin-OSPrereqs-0.11.0.ebuild
new file mode 100644
index 000000000000..dec91b0b48a9
--- /dev/null
+++ b/dev-perl/Dist-Zilla-Plugin-OSPrereqs/Dist-Zilla-Plugin-OSPrereqs-0.11.0.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DIST_AUTHOR=DAGOLDEN
+DIST_VERSION=0.011
+inherit perl-module
+
+DESCRIPTION="List prereqs conditional on operating system"
+LICENSE="Artistic-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ >=dev-perl/Dist-Zilla-5.22.0
+ dev-perl/Moose
+ >=virtual/perl-Scalar-List-Utils-1.330.0
+ dev-perl/namespace-autoclean
+"
+BDEPEND="${RDEPEND}
+ >=virtual/perl-ExtUtils-MakeMaker-6.170.0
+ test? (
+ >=virtual/perl-CPAN-Meta-2.120.900
+ virtual/perl-File-Spec
+ dev-perl/Test-Fatal
+ >=virtual/perl-Test-Simple-0.880.0
+ )
+"
diff --git a/dev-perl/Dist-Zilla-Plugin-OSPrereqs/Manifest b/dev-perl/Dist-Zilla-Plugin-OSPrereqs/Manifest
index a9221626a6f2..d78c605f6780 100644
--- a/dev-perl/Dist-Zilla-Plugin-OSPrereqs/Manifest
+++ b/dev-perl/Dist-Zilla-Plugin-OSPrereqs/Manifest
@@ -1 +1,2 @@
DIST Dist-Zilla-Plugin-OSPrereqs-0.008.tar.gz 18051 BLAKE2B 6a6b1f68593d62a6e92e75eed7b390277b48d31960da7a755d068e7447c0ae1cb157ec85cf96ba12cde58dc1db93729d75ca90395053336a54412ca3711077ba SHA512 e539005fbc7d33a76f9cd48632a4f90ccd5beb278db48aad00c04fc80b2dab4de41a6c6fce22b0a9ac189a9a5e0222a6a51dc41b517b8182a00543f3ce07b672
+DIST Dist-Zilla-Plugin-OSPrereqs-0.011.tar.gz 17278 BLAKE2B 89aae8d9dd92abce1c7b8e198466dee7410fcf74e4657c1c8c15d799c2fdebcaee238300a8b7fbfe0a187239bdc45e8739fd489d61a8bf3d465333d283594012 SHA512 1103eebef6db63ce410f2033a641a3af3457ea9623d138ca7a9506847f1421e6dc26755973aaa1b8e56b3edb9664bbbba915aa39714683b42f42922bfe0926c3