summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-06-24 09:58:16 +0200
committerMichał Górny <mgorny@gentoo.org>2021-06-24 10:00:04 +0200
commit81e3a9d4511fb09cf39ee65577bc511b09eb0435 (patch)
tree3021ca22586deff7abb86999ad5ffca6d0f21ee7
parentpackage.mask: Last rite dev-python/frozendict (diff)
downloadgentoo-81e3a9d4511fb09cf39ee65577bc511b09eb0435.tar.gz
gentoo-81e3a9d4511fb09cf39ee65577bc511b09eb0435.tar.bz2
gentoo-81e3a9d4511fb09cf39ee65577bc511b09eb0435.zip
dev-python/flask-restful: Remove old
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/flask-restful/Manifest1
-rw-r--r--dev-python/flask-restful/files/flask-restful-0.3.8-werkzeug.patch41
-rw-r--r--dev-python/flask-restful/flask-restful-0.3.8.ebuild45
3 files changed, 0 insertions, 87 deletions
diff --git a/dev-python/flask-restful/Manifest b/dev-python/flask-restful/Manifest
index 3766d56af29d..fb2a8dc5a1f4 100644
--- a/dev-python/flask-restful/Manifest
+++ b/dev-python/flask-restful/Manifest
@@ -1,2 +1 @@
-DIST flask-restful-0.3.8.tar.gz 114588 BLAKE2B a18eac613300102bb5a5ca78cea1e6f81f3de21d8bd2e6c72f2f1a559e8b4228175cc7d372b68f131267cd8bc759e354e5782e527d1e992579210348cd2b78dd SHA512 15172114fcedc2f4286cf5f583d95e42c8c8ce6553f9a44e57124f2b1417bf9f094dcb5154a6933ebebc8022f39d4d7969d29d38576111f9d5b45f630b36a66c
DIST flask-restful-0.3.9.gh.tar.gz 118195 BLAKE2B a4f18c3faf06a7c9b628657aafbab4b9492793d9a61ab60a3e4d8112e0fb5e120cff2f2dae87915e44915838572ae0ca1737025ad5f906c2a953afc4b1f49c6f SHA512 34bea8ed6e9de3ad1c2ca63e7af67ed2a175f84c433b08ff643f91d88feda0e3c1c3967deb2fe5ad308b05f373b10c08245edf65ed97a7c5a3683aa900e9edf2
diff --git a/dev-python/flask-restful/files/flask-restful-0.3.8-werkzeug.patch b/dev-python/flask-restful/files/flask-restful-0.3.8-werkzeug.patch
deleted file mode 100644
index 32b0b7b2b460..000000000000
--- a/dev-python/flask-restful/files/flask-restful-0.3.8-werkzeug.patch
+++ /dev/null
@@ -1,41 +0,0 @@
-From 73376a488907af3042b52678ac4c23f8a8911e5b Mon Sep 17 00:00:00 2001
-From: Anthony Sottile <asottile@umich.edu>
-Date: Fri, 7 Feb 2020 11:06:15 -0800
-Subject: [PATCH] Fix testsuite for werkzeug 1.x (#862)
-
----
- tests/test_api.py | 4 +++-
- tests/test_reqparse.py | 4 ++--
- 2 files changed, 5 insertions(+), 3 deletions(-)
-
-diff --git a/tests/test_api.py b/tests/test_api.py
-index f7f8e661..6795d362 100644
---- a/tests/test_api.py
-+++ b/tests/test_api.py
-@@ -445,7 +445,9 @@ def test_handle_non_api_error(self):
-
- resp = app.get("/foo")
- self.assertEquals(resp.status_code, 404)
-- self.assertEquals('text/html', resp.headers['Content-Type'])
-+ # in newer versions of werkzeug this is `text/html; charset=utf8`
-+ content_type, _, _ = resp.headers['Content-Type'].partition(';')
-+ self.assertEquals('text/html', content_type)
-
- def test_non_api_error_404_catchall(self):
- app = Flask(__name__)
-diff --git a/tests/test_reqparse.py b/tests/test_reqparse.py
-index 2f1fbedf..9776f17c 100644
---- a/tests/test_reqparse.py
-+++ b/tests/test_reqparse.py
-@@ -2,9 +2,9 @@
- import unittest
- from mock import Mock, patch
- from flask import Flask
--from werkzeug import exceptions, MultiDict
-+from werkzeug import exceptions
- from werkzeug.wrappers import Request
--from werkzeug.datastructures import FileStorage
-+from werkzeug.datastructures import FileStorage, MultiDict
- from flask_restful.reqparse import Argument, RequestParser, Namespace
- import six
- import decimal
diff --git a/dev-python/flask-restful/flask-restful-0.3.8.ebuild b/dev-python/flask-restful/flask-restful-0.3.8.ebuild
deleted file mode 100644
index eea5a35b47ce..000000000000
--- a/dev-python/flask-restful/flask-restful-0.3.8.ebuild
+++ /dev/null
@@ -1,45 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-PYTHON_COMPAT=( python3_{7,8,9} )
-
-inherit distutils-r1
-
-DESCRIPTION="Simple framework for creating REST APIs"
-HOMEPAGE="
- https://flask-restful.readthedocs.io/en/latest/
- https://github.com/flask-restful/flask-restful/"
-SRC_URI="https://github.com/flask-restful/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="amd64 ~arm64 x86"
-IUSE="examples"
-
-RDEPEND="
- >=dev-python/aniso8601-0.82[${PYTHON_USEDEP}]
- >=dev-python/flask-0.8[${PYTHON_USEDEP}]
- >=dev-python/six-1.3.0[${PYTHON_USEDEP}]
- dev-python/pytz[${PYTHON_USEDEP}]
-"
-BDEPEND="
- test? (
- dev-python/mock[${PYTHON_USEDEP}]
- )
-"
-
-PATCHES=(
- "${FILESDIR}"/flask-restful-0.3.8-werkzeug.patch
-)
-
-distutils_enable_sphinx docs
-distutils_enable_tests nose
-
-python_install_all() {
- use examples && dodoc -r examples
- local DOCS=( AUTHORS.md CHANGES.md CONTRIBUTING.md README.md )
-
- distutils-r1_python_install_all
-}