summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2017-10-16 00:11:37 +0200
committerAndreas Sturmlechner <asturm@gentoo.org>2017-10-16 00:12:13 +0200
commit81e65d9926f6ba4b61e0b06e66eed985dcb70f1a (patch)
tree3616b7e6a4e2262141b6fa611708047b03923b36
parentmail-client/claws-mail: x86 stable (bug #625826) (diff)
downloadgentoo-81e65d9926f6ba4b61e0b06e66eed985dcb70f1a.tar.gz
gentoo-81e65d9926f6ba4b61e0b06e66eed985dcb70f1a.tar.bz2
gentoo-81e65d9926f6ba4b61e0b06e66eed985dcb70f1a.zip
net-p2p/qbittorrent: 3.3.16 version bump
Gentoo-bug: 613194, 621548 Package-Manager: Portage-2.3.11, Repoman-2.3.3
-rw-r--r--net-p2p/qbittorrent/Manifest1
-rw-r--r--net-p2p/qbittorrent/files/qbittorrent-3.3.16-cmake.patch44
-rw-r--r--net-p2p/qbittorrent/qbittorrent-3.3.16.ebuild64
3 files changed, 109 insertions, 0 deletions
diff --git a/net-p2p/qbittorrent/Manifest b/net-p2p/qbittorrent/Manifest
index 698850796945..101ed3b9d0eb 100644
--- a/net-p2p/qbittorrent/Manifest
+++ b/net-p2p/qbittorrent/Manifest
@@ -1,3 +1,4 @@
DIST qbittorrent-3.3.10.tar.xz 2959380 SHA256 2c657ceacdc84033da044a0a9ecba7e0fdb35858324dc097546f989166f1a8d2 SHA512 4f4e7071fa6db75ed2b5fbf5f17d5a9634aa5f2ed9fbcec52e6a0112967f5832e998384c7ff4962b1e00a0f847fa5d39bcdba36f997b5b895c7688e0dd247516 WHIRLPOOL 950b49d7a15aa7cf16dfe2bbfba72959e91f21f85ba589ce85be370b8b21c03fb389d404ed46ad2c802e3a57660094fe644b20df9bc3a0714cb5d9ea965e1b97
DIST qbittorrent-3.3.12-cmake-3.8.patch.gz 18330 SHA256 8172d04af3621ed0859ff541ae6c6e73f469125e0b7defd591191ab8c233e658 SHA512 e5aa6aa32f12c47a28658b2382faca88b64be1c198c69ad88f4fcd9f18d2db7a4e71c170dffd142b5af0184105b04dc2409417761db8859f622d42af7d25b060 WHIRLPOOL a68723a52858aed3e0474e0ccc3bcde7a451b388c8cd30ea5548f53e950902e234cb7e9cc32a86c75e367c4cad33a40beab52619de0a1f27442b89a10c25e67f
DIST qbittorrent-3.3.12.tar.xz 2989604 SHA256 56528c47f09b316ecf682e3896157c76c18898ef996728b0c5186e05a711466f SHA512 537ded71c75b3ab3fe014d77b5c4f8069ebb7a1aa94b5190b16e9ee910bfb70d462e5a3a536ba9222a97d8cceac00af0d33a92b7414b17724694d364fc2374df WHIRLPOOL 9f3b7cb85885691ea747b2569690aa3d1189798be6000e9ec2c8af65ccd86010be877af10b540422233f5b8c253bf221fad0fea6fdc9a0b5dcbc3cedf50613bd
+DIST qbittorrent-3.3.16.tar.xz 2961420 SHA256 ea08a61872c397258c2627780f6e09fe777189d9a57cc5e02a656da9aeb0be57 SHA512 518ddbf8e657b3549800b5587924a8a34826895183f199b79aac72de81e6b5c009cb3b8d4fbb19151da0d96c21eb1c2f05d6ed061608cc8f589ec6fe62ce8117 WHIRLPOOL dec3eab159c9f930d5c2a2f123b089c6ce84e7bcbd83d84f996c1a0167e4bbbdf468492a136a86485cc73611f044587e940910e34260535f2074e84680369ccb
diff --git a/net-p2p/qbittorrent/files/qbittorrent-3.3.16-cmake.patch b/net-p2p/qbittorrent/files/qbittorrent-3.3.16-cmake.patch
new file mode 100644
index 000000000000..9f5b82b218ea
--- /dev/null
+++ b/net-p2p/qbittorrent/files/qbittorrent-3.3.16-cmake.patch
@@ -0,0 +1,44 @@
+From 0ad52903890fe680307b46f4051bdd91d8aaffd5 Mon Sep 17 00:00:00 2001
+From: Eugene Shalygin <eugene.shalygin@gmail.com>
+Date: Sat, 7 Oct 2017 21:48:52 +0200
+Subject: [PATCH] cmake: do not use Qt5Widgets when locating
+ QtSingleApplication. Closes #7551.
+
+This fixes cmake builds with GUI disabled and system
+QtSingleApplication. We rely on Qt5::Core instead of Qt5::Widgets.
+---
+ cmake/Modules/FindQtSingleApplication.cmake | 10 +++++-----
+ 1 file changed, 5 insertions(+), 5 deletions(-)
+
+diff --git a/cmake/Modules/FindQtSingleApplication.cmake b/cmake/Modules/FindQtSingleApplication.cmake
+index eb56607e94..9b526c9839 100644
+--- a/cmake/Modules/FindQtSingleApplication.cmake
++++ b/cmake/Modules/FindQtSingleApplication.cmake
+@@ -30,9 +30,9 @@ IF(QT4_FOUND)
+ NAMES ${QTSINGLEAPPLICATION_NAMES}
+ PATHS ${QT_LIBRARY_DIR}
+ )
+-ELSEIF(Qt5Widgets_FOUND)
++ELSEIF(Qt5Core_FOUND)
+ message(STATUS "Looking for Qt5 single application library")
+- FOREACH(TOP_INCLUDE_PATH in ${Qt5Widgets_INCLUDE_DIRS} ${FRAMEWORK_INCLUDE_DIR})
++ FOREACH(TOP_INCLUDE_PATH in ${Qt5Core_INCLUDE_DIRS} ${FRAMEWORK_INCLUDE_DIR})
+ FIND_PATH(QTSINGLEAPPLICATION_INCLUDE_DIR QtSingleApplication ${TOP_INCLUDE_PATH}/QtSolutions)
+
+ IF(QTSINGLEAPPLICATION_INCLUDE_DIR)
+@@ -43,12 +43,12 @@ ELSEIF(Qt5Widgets_FOUND)
+ SET(QTSINGLEAPPLICATION_NAMES ${QTSINGLEAPPLICATION_NAMES}
+ Qt5Solutions_SingleApplication-2.6 libQt5Solutions_SingleApplication-2.6
+ QtSolutions_SingleApplication-2.6 libQtSolutions_SingleApplication-2.6)
+- GET_TARGET_PROPERTY(QT5_WIDGETSLIBRARY Qt5::Widgets LOCATION)
+- GET_FILENAME_COMPONENT(QT5_WIDGETSLIBRARYPATH ${QT5_WIDGETSLIBRARY} PATH)
++ GET_TARGET_PROPERTY(_QT5_CORELIBRARY Qt5::Core LOCATION)
++ GET_FILENAME_COMPONENT(_QT5_CORELIBRARYPATH ${_QT5_CORELIBRARY} PATH)
+
+ FIND_LIBRARY(QTSINGLEAPPLICATION_LIBRARY
+ NAMES ${QTSINGLEAPPLICATION_NAMES}
+- PATHS ${QT5_WIDGETSLIBRARYPATH}
++ PATHS ${_QT5_CORELIBRARYPATH}
+ )
+ ENDIF()
+
diff --git a/net-p2p/qbittorrent/qbittorrent-3.3.16.ebuild b/net-p2p/qbittorrent/qbittorrent-3.3.16.ebuild
new file mode 100644
index 000000000000..98163e4f20cf
--- /dev/null
+++ b/net-p2p/qbittorrent/qbittorrent-3.3.16.ebuild
@@ -0,0 +1,64 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit cmake-utils xdg-utils
+
+DESCRIPTION="BitTorrent client in C++ and Qt"
+HOMEPAGE="https://www.qbittorrent.org/"
+
+if [[ ${PV} == *9999 ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/${PN}/qBittorrent.git"
+else
+ MY_P=${P/_}
+ SRC_URI="mirror://sourceforge/${PN}/${MY_P}.tar.xz"
+ KEYWORDS="~amd64 ~arm ~ppc64 ~x86"
+ S=${WORKDIR}/${MY_P}
+fi
+
+LICENSE="GPL-2"
+SLOT="0"
+IUSE="+dbus debug webui +X"
+REQUIRED_USE="dbus? ( X )"
+
+RDEPEND="
+ >=dev-libs/boost-1.62.0-r1:=
+ dev-qt/qtconcurrent:5
+ dev-qt/qtcore:5
+ dev-qt/qtnetwork:5[ssl]
+ >=dev-qt/qtsingleapplication-2.6.1_p20130904-r1[qt5,X?]
+ dev-qt/qtxml:5
+ >=net-libs/libtorrent-rasterbar-1.0.6
+ sys-libs/zlib
+ dbus? ( dev-qt/qtdbus:5 )
+ X? (
+ dev-qt/qtgui:5
+ dev-qt/qtwidgets:5
+ )"
+DEPEND="${RDEPEND}
+ dev-qt/linguist-tools:5
+ virtual/pkgconfig"
+
+DOCS=( AUTHORS Changelog CONTRIBUTING.md README.md TODO )
+
+PATCHES=( "${FILESDIR}/${P}-cmake.patch" )
+
+src_configure() {
+ local mycmakeargs=(
+ -DSYSTEM_QTSINGLEAPPLICATION=ON
+ -DDBUS=$(usex dbus)
+ -DGUI=$(usex X)
+ -DWEBUI=$(usex webui)
+ )
+ cmake-utils_src_configure
+}
+
+pkg_postinst() {
+ xdg_desktop_database_update
+}
+
+pkg_postrm() {
+ xdg_desktop_database_update
+}