summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarek Szuba <marecki@gentoo.org>2022-01-03 23:03:01 +0000
committerMarek Szuba <marecki@gentoo.org>2022-01-03 23:14:39 +0000
commit81ee61d1f858dceeae35044cf560255ad51270b6 (patch)
tree089948e4e5bb58089d0a900080d48167e0de7059
parentnet-proxy/obfs4proxy: add 0.0.12 (diff)
downloadgentoo-81ee61d1.tar.gz
gentoo-81ee61d1.tar.bz2
gentoo-81ee61d1.zip
net-misc/oidc-agent: add 4.2.5
Signed-off-by: Marek Szuba <marecki@gentoo.org>
-rw-r--r--net-misc/oidc-agent/Manifest1
-rw-r--r--net-misc/oidc-agent/oidc-agent-4.2.5.ebuild78
2 files changed, 79 insertions, 0 deletions
diff --git a/net-misc/oidc-agent/Manifest b/net-misc/oidc-agent/Manifest
index 897a3e39eefd..ea2e0728a55b 100644
--- a/net-misc/oidc-agent/Manifest
+++ b/net-misc/oidc-agent/Manifest
@@ -1,2 +1,3 @@
DIST oidc-agent-4.1.1.tar.gz 801103 BLAKE2B dcb82a537787ae6ced577843c67acdd4e3fa315d017222067b2914837dfffccae27ddbdeeeaf4e8ca70c7e2744e03df5964d3ba318efd4460c73252bfd3f8e95 SHA512 e383e054623dc3b8fe73ec02df44faa05d4b69aaed47c7925f6f92d25cbc5301173fbc607b6198bc70f99e634e582fbae7c5570812086a8e5694d40ce6d2c2d1
DIST oidc-agent-4.2.4.tar.gz 823459 BLAKE2B 71c2fd983031641c5ed39ba3f1771bf283ab56eae6bba426da5308a7c9fcf2ce48103220375b9881e255eeddf05d50d58e2dee047b0b4436451c8d39b0cd55e6 SHA512 6f4f79823869197a0b74cd757b72e1d060ed9f1d9be477f815989b723a86285b200bd72b95f07a4698e754b9ad7aae48cee72603e1a6eaab71590cc63c2bae3d
+DIST oidc-agent-4.2.5.tar.gz 823881 BLAKE2B 533917fdb739ef529c1ca4e06b30a64361710c958b2b6e7a23a6d9c1f1195263ec98f1211cda5dbe9d77f6df7ca0509d29c4e0d595825a908d605ea5ececa8be SHA512 983e59dc3b97b1800733c98fc7ba5e33405a84cb66be7006932c88cb3ccdbfbc9f12d274c1f61294b0fb7ec93fecd2165196f7cc9e056bda0c23a974479f6aa2
diff --git a/net-misc/oidc-agent/oidc-agent-4.2.5.ebuild b/net-misc/oidc-agent/oidc-agent-4.2.5.ebuild
new file mode 100644
index 000000000000..eb58ba92f64c
--- /dev/null
+++ b/net-misc/oidc-agent/oidc-agent-4.2.5.ebuild
@@ -0,0 +1,78 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit xdg-utils
+
+DESCRIPTION="Agent and tools for managing OpenID Connect tokens on the command line"
+HOMEPAGE="https://github.com/indigo-dc/oidc-agent"
+SRC_URI="https://github.com/indigo-dc/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~riscv"
+IUSE="test"
+
+DEPEND="app-crypt/libsecret
+ dev-libs/libsodium:=
+ media-gfx/qrencode
+ net-libs/libmicrohttpd:=
+ sys-libs/libseccomp"
+RDEPEND="${DEPEND}"
+BDEPEND="test? ( dev-libs/check )"
+
+RESTRICT="!test? ( test )"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-4.0.2_makefile-liblist-automagic.patch
+ "${FILESDIR}"/${PN}-4.1.0_install-perms.patch
+ "${FILESDIR}"/${PN}-4.2.4_makefile-toolchain-vars.patch
+)
+
+src_prepare() {
+ default
+ sed -i -e 's|^\(\s\+\)@|\1|' Makefile || die "Failed to increase verbosity in Makefile"
+}
+
+src_install() {
+ emake \
+ PREFIX="${ED}" \
+ BIN_AFTER_INST_PATH="/usr" \
+ INCLUDE_PATH="${ED}"/usr/include \
+ LIB_PATH="${ED}"/usr/$(get_libdir) \
+ install
+
+ # This file is not compatible with Gentoo and in any case, we generally
+ # let the users load such agents themselves.
+ rm -f "${ED}"/etc/X11/Xsession.d/91${PN}
+}
+
+pkg_postinst() {
+ xdg_desktop_database_update
+
+ if [[ -z "${REPLACING_VERSIONS}" ]]; then
+ elog
+ elog "You should use oidc-gen to initially generate your account configuration"
+ elog "before it can be loaded into oidc-agent using oidc-add. For details, please"
+ elog "consult the man page of oidc-gen, or full documentation at"
+ elog " https://indigo-dc.gitbooks.io/oidc-agent/"
+ elog
+ else
+ local new_major_ver old_ver
+ new_major_ver=$(ver_cut 1)
+ for old_ver in ${REPLACING_VERSIONS}; do
+ if [[ $(ver_cut 1 ${old_ver}) != ${new_major_ver} ]]; then
+ ewarn
+ ewarn "You are upgrading from a different major version. Please restart any running instances of ${PN}"
+ ewarn "to make sure they are compatible with the updated clients."
+ ewarn
+ break
+ fi
+ done
+ fi
+}
+
+pkg_postrm() {
+ xdg_desktop_database_update
+}